about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorPol Dellaiera <pol.dellaiera@protonmail.com>2024-03-18 21:42:50 +0100
committerGitHub <noreply@github.com>2024-03-18 21:42:50 +0100
commit99e0e9ce652233400dbb995bea9169cf8a2c0196 (patch)
treec65f585e037f12988a3156b8731813b25a5ea456 /pkgs/applications
parent633722af828c76c5956dd08201c2fa62fb944f44 (diff)
parent0ce12029c8e52979c53f89327c3fafd8919c580f (diff)
downloadnixlib-99e0e9ce652233400dbb995bea9169cf8a2c0196.tar
nixlib-99e0e9ce652233400dbb995bea9169cf8a2c0196.tar.gz
nixlib-99e0e9ce652233400dbb995bea9169cf8a2c0196.tar.bz2
nixlib-99e0e9ce652233400dbb995bea9169cf8a2c0196.tar.lz
nixlib-99e0e9ce652233400dbb995bea9169cf8a2c0196.tar.xz
nixlib-99e0e9ce652233400dbb995bea9169cf8a2c0196.tar.zst
nixlib-99e0e9ce652233400dbb995bea9169cf8a2c0196.zip
Merge pull request #296971 from Rutherther/element-desktop-libnotify
element-desktop: Add libnotify to fix notifications
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/instant-messengers/element/element-desktop.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/pkgs/applications/networking/instant-messengers/element/element-desktop.nix b/pkgs/applications/networking/instant-messengers/element/element-desktop.nix
index 46a7f821446c..ffbee0f25f82 100644
--- a/pkgs/applications/networking/instant-messengers/element/element-desktop.nix
+++ b/pkgs/applications/networking/instant-messengers/element/element-desktop.nix
@@ -16,6 +16,7 @@
 , AppKit
 , CoreServices
 , desktopToDarwinBundle
+, libnotify
 , useKeytar ? true
 }:
 
@@ -77,7 +78,13 @@ stdenv.mkDerivation (finalAttrs: builtins.removeAttrs pinData [ "hashes" ] // {
     runHook postBuild
   '';
 
-  installPhase = ''
+  installPhase =
+    let
+      libPath = lib.makeLibraryPath [
+        libnotify
+      ];
+    in
+  ''
     runHook preInstall
 
     # resources
@@ -104,6 +111,7 @@ stdenv.mkDerivation (finalAttrs: builtins.removeAttrs pinData [ "hashes" ] // {
     # LD_PRELOAD workaround for sqlcipher not found: https://github.com/matrix-org/seshat/issues/102
     makeWrapper '${electron}/bin/electron' "$out/bin/${executableName}" \
       --set LD_PRELOAD ${sqlcipher}/lib/libsqlcipher.so \
+      --set LD_LIBRARY_PATH "${libPath}" \
       --add-flags "$out/share/element/electron" \
       --add-flags "\''${NIXOS_OZONE_WL:+\''${WAYLAND_DISPLAY:+--ozone-platform-hint=auto --enable-features=WaylandWindowDecorations}}"