about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2015-07-27 22:38:25 +0200
committerBjørn Forsman <bjorn.forsman@gmail.com>2015-08-10 23:12:03 +0200
commit95cb770b53586a8cbc642e392eb4f051d3b76fcf (patch)
tree7f23c700513ebf03592b39547f04c79aa16d24b6 /pkgs/applications
parentd16bb1af3da9686ca48120bafb7e049d2ab60dc4 (diff)
downloadnixlib-95cb770b53586a8cbc642e392eb4f051d3b76fcf.tar
nixlib-95cb770b53586a8cbc642e392eb4f051d3b76fcf.tar.gz
nixlib-95cb770b53586a8cbc642e392eb4f051d3b76fcf.tar.bz2
nixlib-95cb770b53586a8cbc642e392eb4f051d3b76fcf.tar.lz
nixlib-95cb770b53586a8cbc642e392eb4f051d3b76fcf.tar.xz
nixlib-95cb770b53586a8cbc642e392eb4f051d3b76fcf.tar.zst
nixlib-95cb770b53586a8cbc642e392eb4f051d3b76fcf.zip
eclipse-eclemma: init at 2.3.2.201409141915
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/eclipse/plugins.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/pkgs/applications/editors/eclipse/plugins.nix b/pkgs/applications/editors/eclipse/plugins.nix
index d65d1a48b88f..f1b5001b015b 100644
--- a/pkgs/applications/editors/eclipse/plugins.nix
+++ b/pkgs/applications/editors/eclipse/plugins.nix
@@ -121,6 +121,25 @@ in {
     };
   };
 
+  eclemma = buildEclipseUpdateSite rec {
+    name = "eclemma-${version}";
+    version = "2.3.2.201409141915";
+
+    src = fetchzip {
+      stripRoot = false;
+      url = "mirror://sourceforge/project/eclemma/01_EclEmma_Releases/2.3.2/eclemma-2.3.2.zip";
+      sha256 = "0w1kwcjh45p7msv5vpc8i6dsqwrnfmjama6vavpnxlji56jd3c43";
+    };
+
+    meta = with stdenv.lib; {
+      homepage = http://www.eclemma.org/;
+      description = "EclEmma is a free Java code coverage tool for Eclipse";
+      license = licenses.epl10;
+      platforms = platforms.all;
+      maintainers = [ maintainers.rycee ];
+    };
+  };
+
   emacsplus = buildEclipsePlugin rec {
     name = "emacsplus-${version}";
     version = "4.2.0";