about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@protonmail.ch>2019-05-28 15:12:57 -0400
committerGitHub <noreply@github.com>2019-05-28 15:12:57 -0400
commit958eef35331e37a9ad4d4f84e7177b8e9cbd35b6 (patch)
tree784bddeeb50dc3d62e30da39efe994524413a01d /pkgs/applications
parent3edeb5ccd237b769277fe7cce31fb38aea5940fc (diff)
parent7af3d2198f73387b8e0024e2f02aaace2991a6a0 (diff)
downloadnixlib-958eef35331e37a9ad4d4f84e7177b8e9cbd35b6.tar
nixlib-958eef35331e37a9ad4d4f84e7177b8e9cbd35b6.tar.gz
nixlib-958eef35331e37a9ad4d4f84e7177b8e9cbd35b6.tar.bz2
nixlib-958eef35331e37a9ad4d4f84e7177b8e9cbd35b6.tar.lz
nixlib-958eef35331e37a9ad4d4f84e7177b8e9cbd35b6.tar.xz
nixlib-958eef35331e37a9ad4d4f84e7177b8e9cbd35b6.tar.zst
nixlib-958eef35331e37a9ad4d4f84e7177b8e9cbd35b6.zip
Merge pull request #61653 from d3rped/fix/krita
krita: fixed missing python path
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/graphics/krita/default.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/pkgs/applications/graphics/krita/default.nix b/pkgs/applications/graphics/krita/default.nix
index 507cee548e09..c08bd52c989a 100644
--- a/pkgs/applications/graphics/krita/default.nix
+++ b/pkgs/applications/graphics/krita/default.nix
@@ -1,4 +1,4 @@
-{ mkDerivation, lib, stdenv, fetchurl, cmake, extra-cmake-modules
+{ mkDerivation, lib, stdenv, makeWrapper, fetchurl, cmake, extra-cmake-modules
 , karchive, kconfig, kwidgetsaddons, kcompletion, kcoreaddons
 , kguiaddons, ki18n, kitemmodels, kitemviews, kwindowsystem
 , kio, kcrash
@@ -25,7 +25,7 @@ mkDerivation rec {
     sha256 = "0h2rplc76r82b8smk61zci1ijj9xkjmf20pdqa8fc2lz4zicjxh4";
   };
 
-  nativeBuildInputs = [ cmake extra-cmake-modules python3Packages.sip ];
+  nativeBuildInputs = [ cmake extra-cmake-modules python3Packages.sip makeWrapper ];
 
   buildInputs = [
     karchive kconfig kwidgetsaddons kcompletion kcoreaddons kguiaddons
@@ -44,6 +44,12 @@ mkDerivation rec {
     "-DCMAKE_BUILD_TYPE=RelWithDebInfo"
   ];
 
+  postInstall = ''
+    for i in $out/bin/*; do
+      wrapProgram $i --prefix PYTHONPATH : "$PYTHONPATH"
+    done
+  '';
+
   meta = with lib; {
     description = "A free and open source painting application";
     homepage = https://krita.org/;