about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMario Rodas <marsam@users.noreply.github.com>2020-03-21 05:28:00 -0500
committerMario Rodas <marsam@users.noreply.github.com>2020-03-21 05:28:00 -0500
commit92da50afa856920842a353264b68673fe0dd2c8c (patch)
tree745e99c1bb979d5ee652ad02f6da2c87f5971ef4 /pkgs/applications
parent6852ecdcf5448bae3c5a10e760a862dda1e5ce3b (diff)
downloadnixlib-92da50afa856920842a353264b68673fe0dd2c8c.tar
nixlib-92da50afa856920842a353264b68673fe0dd2c8c.tar.gz
nixlib-92da50afa856920842a353264b68673fe0dd2c8c.tar.bz2
nixlib-92da50afa856920842a353264b68673fe0dd2c8c.tar.lz
nixlib-92da50afa856920842a353264b68673fe0dd2c8c.tar.xz
nixlib-92da50afa856920842a353264b68673fe0dd2c8c.tar.zst
nixlib-92da50afa856920842a353264b68673fe0dd2c8c.zip
ipfs: fix build on darwin
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/ipfs/default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/pkgs/applications/networking/ipfs/default.nix b/pkgs/applications/networking/ipfs/default.nix
index 4f71fcf3b745..c3a31f4e290f 100644
--- a/pkgs/applications/networking/ipfs/default.nix
+++ b/pkgs/applications/networking/ipfs/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, buildGoModule, fetchFromGitHub }:
+{ stdenv, buildGoModule, fetchFromGitHub, Security }:
 
 buildGoModule rec {
   pname = "ipfs";
@@ -18,6 +18,8 @@ buildGoModule rec {
 
   modSha256 = "12m4ind1s8zaa6kssblc28z2cafy20w2jp80kzif39hg5ar9bijm";
 
+  buildInputs = stdenv.lib.optionals stdenv.isDarwin [ Security ];
+
   meta = with stdenv.lib; {
     description = "A global, versioned, peer-to-peer filesystem";
     homepage = https://ipfs.io/;