about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorSandro <sandro.jaeckel@gmail.com>2021-07-14 03:29:35 +0200
committerGitHub <noreply@github.com>2021-07-14 03:29:35 +0200
commit91948984912a7baf582c4e4f877f7f046cf1924f (patch)
treeed5dfa056c9301a0ed5224cf00f79774b03af24a /pkgs/applications
parent26aaff44cc90ad2b5d2bf6ee014d059890b17ee1 (diff)
parent30ce6d8a0cc5354cc56987227a2d981991af3870 (diff)
downloadnixlib-91948984912a7baf582c4e4f877f7f046cf1924f.tar
nixlib-91948984912a7baf582c4e4f877f7f046cf1924f.tar.gz
nixlib-91948984912a7baf582c4e4f877f7f046cf1924f.tar.bz2
nixlib-91948984912a7baf582c4e4f877f7f046cf1924f.tar.lz
nixlib-91948984912a7baf582c4e4f877f7f046cf1924f.tar.xz
nixlib-91948984912a7baf582c4e4f877f7f046cf1924f.tar.zst
nixlib-91948984912a7baf582c4e4f877f7f046cf1924f.zip
Merge pull request #130128 from mvnetbiz/kfctl
kfctl: init at 1.2.0
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/cluster/kfctl/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/pkgs/applications/networking/cluster/kfctl/default.nix b/pkgs/applications/networking/cluster/kfctl/default.nix
new file mode 100644
index 000000000000..52a049ab1bba
--- /dev/null
+++ b/pkgs/applications/networking/cluster/kfctl/default.nix
@@ -0,0 +1,32 @@
+{ lib, buildGoModule, fetchFromGitHub, installShellFiles }:
+
+buildGoModule rec {
+  pname = "kfctl";
+  version = "1.2.0";
+
+  src = fetchFromGitHub {
+    owner = "kubeflow";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "sha256-FY7o4QULobLY1djfcc2l6awE/v2stN7cc2lffMkjoPc=";
+  };
+
+  vendorSha256 = "sha256-+6sxXp0LKegZjEFv1CIQ6xYh+hXLn+o9LggRYamCzpI=";
+
+  subPackages = [ "cmd/kfctl" ];
+
+  nativeBuildInputs = [ installShellFiles ];
+
+  postInstall = ''
+  installShellCompletion --cmd eksctl \
+    --bash <($out/bin/kfctl completion bash) \
+    --zsh <($out/bin/kfctl completion zsh)
+  '';
+
+  meta = with lib; {
+    description = "A CLI for deploying and managing Kubeflow";
+    homepage = "https://github.com/kubeflow/kfctl";
+    license = licenses.asl20;
+    maintainers = with maintainers; [ mvnetbiz ];
+  };
+}