about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorTimo Kaufmann <timokau@zoho.com>2018-11-25 12:15:39 +0100
committerTimo Kaufmann <timokau@zoho.com>2018-11-25 19:39:18 +0100
commit90cebaf8280d819289438429a53214d1656d942d (patch)
tree5ab2b805ea22611b54800867c720b52730b1d968 /pkgs/applications
parent2a87caa892bba6f388dbec71a45c9482433eb651 (diff)
downloadnixlib-90cebaf8280d819289438429a53214d1656d942d.tar
nixlib-90cebaf8280d819289438429a53214d1656d942d.tar.gz
nixlib-90cebaf8280d819289438429a53214d1656d942d.tar.bz2
nixlib-90cebaf8280d819289438429a53214d1656d942d.tar.lz
nixlib-90cebaf8280d819289438429a53214d1656d942d.tar.xz
nixlib-90cebaf8280d819289438429a53214d1656d942d.tar.zst
nixlib-90cebaf8280d819289438429a53214d1656d942d.zip
sage: 8.5.beta3 -> 8.5.beta4
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/math/sage/patches/no-invalid-gap-test.patch19
-rw-r--r--pkgs/applications/science/math/sage/sage-src.nix6
2 files changed, 23 insertions, 2 deletions
diff --git a/pkgs/applications/science/math/sage/patches/no-invalid-gap-test.patch b/pkgs/applications/science/math/sage/patches/no-invalid-gap-test.patch
new file mode 100644
index 000000000000..546a78764897
--- /dev/null
+++ b/pkgs/applications/science/math/sage/patches/no-invalid-gap-test.patch
@@ -0,0 +1,19 @@
+diff --git a/src/sage/libs/gap/util.pyx b/src/sage/libs/gap/util.pyx
+index bdde6aa60f..50459534f8 100644
+--- a/src/sage/libs/gap/util.pyx
++++ b/src/sage/libs/gap/util.pyx
+@@ -165,14 +165,6 @@ def gap_root():
+         sage: from sage.libs.gap.util import gap_root
+         sage: gap_root()   # random output
+         '/home/vbraun/opt/sage-5.3.rc0/local/gap/latest'
+-
+-    If GAP_ROOT_DIR is undefined or pointing to the wrong location,
+-    fall back code should be used to determine gapdir::
+-
+-        sage: import os
+-        sage: os.system("GAP_ROOT_DIR=/not_a_path sage -c \"sage.libs.gap.util.gap_root()\"")
+-        The gap-4.5.5.spkg (or later) seems to be not installed!
+-        ...
+     """
+     import os.path
+     if os.path.exists(GAP_ROOT_DIR):
diff --git a/pkgs/applications/science/math/sage/sage-src.nix b/pkgs/applications/science/math/sage/sage-src.nix
index a0c828289830..dd96121925fe 100644
--- a/pkgs/applications/science/math/sage/sage-src.nix
+++ b/pkgs/applications/science/math/sage/sage-src.nix
@@ -9,14 +9,14 @@
 # all get the same sources with the same patches applied.
 
 stdenv.mkDerivation rec {
-  version = "8.5.beta3";
+  version = "8.5.beta4";
   name = "sage-src-${version}";
 
   src = fetchFromGitHub {
     owner = "sagemath";
     repo = "sage";
     rev = version;
-    sha256 = "1nhhx576188q87ma7yygp1mgqs2mcjk89cy4dqibzbv0vmhasz3c";
+    sha256 = "0x8zi5c1glw5h7231yxdyklmf1vgrvf0zvzwa4qwnm7x2nky62zf";
   };
 
   # Patches needed because of particularities of nix or the way this is packaged.
@@ -46,6 +46,8 @@ stdenv.mkDerivation rec {
     # tests) are also run. That is necessary to test dochtml individually. See
     # https://trac.sagemath.org/ticket/26110 for an upstream discussion.
     ./patches/Only-test-py2-py3-optional-tests-when-all-of-sage-is.patch
+
+    ./patches/no-invalid-gap-test.patch
   ];
 
   # Patches needed because of package updates. We could just pin the versions of