about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@users.noreply.github.com>2019-02-22 19:17:49 -0500
committerGitHub <noreply@github.com>2019-02-22 19:17:49 -0500
commit904732d6f6dcf78d1c52538d8b2d78a9e442886a (patch)
tree4b28e9a5c74b2a3c5c03f078845bdab0f442a014 /pkgs/applications
parent3dda94df653a49b52023e004647cd2a5122c95c3 (diff)
parentac2546bffe6c980642c9f6a71df06efa226b8816 (diff)
downloadnixlib-904732d6f6dcf78d1c52538d8b2d78a9e442886a.tar
nixlib-904732d6f6dcf78d1c52538d8b2d78a9e442886a.tar.gz
nixlib-904732d6f6dcf78d1c52538d8b2d78a9e442886a.tar.bz2
nixlib-904732d6f6dcf78d1c52538d8b2d78a9e442886a.tar.lz
nixlib-904732d6f6dcf78d1c52538d8b2d78a9e442886a.tar.xz
nixlib-904732d6f6dcf78d1c52538d8b2d78a9e442886a.tar.zst
nixlib-904732d6f6dcf78d1c52538d8b2d78a9e442886a.zip
Merge pull request #56172 from worldofpeace/elementary-post
fondo, notes-up: init
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/graphics/fondo/default.nix47
-rw-r--r--pkgs/applications/office/notes-up/default.nix46
2 files changed, 93 insertions, 0 deletions
diff --git a/pkgs/applications/graphics/fondo/default.nix b/pkgs/applications/graphics/fondo/default.nix
new file mode 100644
index 000000000000..87c161b9aee8
--- /dev/null
+++ b/pkgs/applications/graphics/fondo/default.nix
@@ -0,0 +1,47 @@
+{ stdenv, fetchFromGitHub, pantheon, pkgconfig, meson, ninja, python3, glib, gsettings-desktop-schemas, gtk3, libgee, json-glib, glib-networking, libsoup, libunity, wrapGAppsHook }:
+
+stdenv.mkDerivation rec {
+  pname = "fondo";
+  version = "1.2.1";
+
+  src = fetchFromGitHub {
+    owner = "calo001";
+    repo = pname;
+    rev = version;
+    sha256 = "0xczqkkq54gjay7wdl8mpil7klfrpvcw2a0n1brq7qrfhsmhc7pc";
+  };
+
+  nativeBuildInputs = [
+    meson
+    ninja
+    pantheon.vala
+    pkgconfig
+    python3
+    wrapGAppsHook
+  ];
+
+  buildInputs = [
+    glib
+    glib-networking
+    gsettings-desktop-schemas
+    gtk3
+    json-glib
+    libgee
+    libsoup
+    libunity
+    pantheon.granite
+  ];
+
+  postPatch = ''
+    chmod +x meson/post_install.py
+    patchShebangs meson/post_install.py
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Find the most beautiful wallpapers for your desktop";
+    homepage = https://github.com/calo001/fondo;
+    license = licenses.agpl3Plus;
+    maintainers = with maintainers; [ worldofpeace ];
+    platforms = platforms.linux;
+  };
+}
diff --git a/pkgs/applications/office/notes-up/default.nix b/pkgs/applications/office/notes-up/default.nix
new file mode 100644
index 000000000000..2dee39a0ad3b
--- /dev/null
+++ b/pkgs/applications/office/notes-up/default.nix
@@ -0,0 +1,46 @@
+{ stdenv, fetchFromGitHub, pantheon, pkgconfig, cmake, ninja, gtk3, gtksourceview3, webkitgtk, gtkspell3, glib, libgee, sqlite, discount, wrapGAppsHook
+, withPantheon ? false }:
+
+stdenv.mkDerivation rec {
+  pname = "notes-up";
+  version = "1.6.3";
+
+  src = fetchFromGitHub {
+    owner = "Philip-Scott";
+    repo = "Notes-up";
+    rev = version;
+    sha256 = "06fzdb823kkami0jch9ccblsvw3x7zd1d4xz8fv3giscl3f36x4q";
+  };
+
+  nativeBuildInputs = [
+    cmake
+    ninja
+    pantheon.vala
+    pkgconfig
+    wrapGAppsHook
+  ];
+
+  buildInputs = [
+    discount
+    glib
+    gtk3
+    gtksourceview3
+    gtkspell3
+    libgee
+    pantheon.granite
+    sqlite
+    webkitgtk
+  ];
+
+  # Whether to build with contractor support (Pantheon specific)
+  cmakeFlags = if withPantheon then null else [ "-Dnoele=yes" ];
+
+  meta = with stdenv.lib; {
+    description = "Markdown notes editor and manager designed for elementary OS"
+    + stdenv.lib.optionalString withPantheon " - built with Contractor support";
+    homepage = https://github.com/Philip-Scott/Notes-up;
+    license = licenses.gpl2;
+    maintainers = with maintainers; [ davidak worldofpeace ];
+    platforms = platforms.linux;
+  };
+}