about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorNick Cao <nickcao@nichi.co>2023-12-17 09:45:54 -0500
committerGitHub <noreply@github.com>2023-12-17 09:45:54 -0500
commit8f44077260e7115c72a19fdb67faff25c889b572 (patch)
tree1a26cf1c31ac6d1aaeb55df08c38e7217ea7f958 /pkgs/applications
parent48e25fd7c56342f9d0064aafdeb26953b846817e (diff)
parentdbf93cb933e92949f584bd967a38a8b5be0f1a3a (diff)
downloadnixlib-8f44077260e7115c72a19fdb67faff25c889b572.tar
nixlib-8f44077260e7115c72a19fdb67faff25c889b572.tar.gz
nixlib-8f44077260e7115c72a19fdb67faff25c889b572.tar.bz2
nixlib-8f44077260e7115c72a19fdb67faff25c889b572.tar.lz
nixlib-8f44077260e7115c72a19fdb67faff25c889b572.tar.xz
nixlib-8f44077260e7115c72a19fdb67faff25c889b572.tar.zst
nixlib-8f44077260e7115c72a19fdb67faff25c889b572.zip
Merge pull request #274552 from xrelkd/update/clipcat
clipcat: 0.14.0 -> 0.15.0
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/clipcat/default.nix23
1 files changed, 7 insertions, 16 deletions
diff --git a/pkgs/applications/misc/clipcat/default.nix b/pkgs/applications/misc/clipcat/default.nix
index 7ba97bc7a9b4..64a3c4f3f893 100644
--- a/pkgs/applications/misc/clipcat/default.nix
+++ b/pkgs/applications/misc/clipcat/default.nix
@@ -2,42 +2,33 @@
 , fetchFromGitHub
 , rustPlatform
 , protobuf
-, xvfb-run
 , installShellFiles
 }:
 
 rustPlatform.buildRustPackage rec {
   pname = "clipcat";
-  version = "0.14.0";
+  version = "0.15.0";
 
   src = fetchFromGitHub {
     owner = "xrelkd";
     repo = pname;
     rev = "v${version}";
-    hash = "sha256-Q9uGufIfqRLk3YJjaEEyu29JP8vSwUCe4ch9tf6Vz9g=";
+    hash = "sha256-NuljH6cqgdtTJDkNv4w44s1UM4/R1gmpVyWpCzCJ3DU=";
   };
 
-  cargoHash = "sha256-9TPj4W+BSpHlOWkbiV7jNgjiYJjjw9j2c3o8vesrJeI=";
+  cargoHash = "sha256-5+qa9/QGZyZBaO2kbvpP7Ybs1EXIO1MlPFm0PDTNqCQ=";
 
   nativeBuildInputs = [
     protobuf
     installShellFiles
   ];
 
-  nativeCheckInputs = [
-    xvfb-run
+  checkFlags = [
+    # Some test cases interact with X11, skip them
+    "--skip=test_x11_clipboard"
+    "--skip=test_x11_primary"
   ];
 
-  useNextest = true;
-
-  # cargo-nextest help us retry the failed test cases
-  NEXTEST_RETRIES = 5;
-
-  # Some test cases interact with X11, we use xvfb-run here
-  checkPhase = ''
-    xvfb-run --auto-servernum cargo nextest run --release --workspace --no-fail-fast --no-capture
-  '';
-
   postInstall = ''
     for cmd in clipcatd clipcatctl clipcat-menu clipcat-notify; do
       installShellCompletion --cmd $cmd \