about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorWill Dietz <w@wdtz.org>2019-05-30 07:22:43 -0500
committerWill Dietz <w@wdtz.org>2019-05-30 22:09:22 -0500
commit8ea66b0151ac3f27f897e7005ab418429d3b8d7f (patch)
treefd17a2d21c06b0a5caea52657030383591b6bbcb /pkgs/applications
parent67abc01e4c69e9eaabbf9a6702fba910ff3604cd (diff)
downloadnixlib-8ea66b0151ac3f27f897e7005ab418429d3b8d7f.tar
nixlib-8ea66b0151ac3f27f897e7005ab418429d3b8d7f.tar.gz
nixlib-8ea66b0151ac3f27f897e7005ab418429d3b8d7f.tar.bz2
nixlib-8ea66b0151ac3f27f897e7005ab418429d3b8d7f.tar.lz
nixlib-8ea66b0151ac3f27f897e7005ab418429d3b8d7f.tar.xz
nixlib-8ea66b0151ac3f27f897e7005ab418429d3b8d7f.tar.zst
nixlib-8ea66b0151ac3f27f897e7005ab418429d3b8d7f.zip
xournalpp: 1.0.8 -> 1.0.12
* revisit plugin support, drop old patch
* use lua5_3 as it seems to expect (require)
* disable format hardening, fix build
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/graphics/xournalpp/default.nix22
1 files changed, 7 insertions, 15 deletions
diff --git a/pkgs/applications/graphics/xournalpp/default.nix b/pkgs/applications/graphics/xournalpp/default.nix
index 30a8907275b0..54b81d53d05b 100644
--- a/pkgs/applications/graphics/xournalpp/default.nix
+++ b/pkgs/applications/graphics/xournalpp/default.nix
@@ -1,7 +1,6 @@
 { stdenv
 , lib
 , fetchFromGitHub
-, fetchpatch
 
 , cmake
 , gettext
@@ -14,6 +13,7 @@
 , hicolor-icon-theme
 , libsndfile
 , libxml2
+, libzip
 , pcre
 , poppler
 , portaudio
@@ -22,31 +22,20 @@
 # Plugins don't appear to be working in this version, so disable them by not
 # building with Lua support by default. In a future version, try switching this
 # to 'true' and seeing if the top-level Plugin menu appears.
-, withLua ? false, lua
+, withLua ? true, lua
 }:
 
 stdenv.mkDerivation rec {
   name = "xournalpp-${version}";
-  version = "1.0.8";
+  version = "1.0.12";
 
   src = fetchFromGitHub {
     owner = "xournalpp";
     repo = "xournalpp";
     rev = version;
-    sha256 = "01q84xjp9z1krna10gjj562km6i3wdq8cg7paxax1k6bh52ryvf6";
+    sha256 = "0yg70hsx58s3wb5kzccivrqa7kvmdapygxmif1j64hddah2rqcn9";
   };
 
-  patches = [
-    # This patch removes the unused 'xopp-recording.sh' file which breaks the
-    # cmake build; this patch isn't in a release yet, and should be removed at
-    # or after 1.0.9 is released.
-    (fetchpatch {
-      name = "remove-xopp-recording.sh.patch";
-      url = "https://github.com/xournalpp/xournalpp/commit/a17a3f2c80c607a22d0fdeb66d38358bea7e4d85.patch";
-      sha256 = "10pcpvklm6kr0lv2xrsbpg2037ni9j6dmxgjf56p466l3gz60iwy";
-    })
-  ];
-
   nativeBuildInputs = [ cmake gettext pkgconfig wrapGAppsHook ];
   buildInputs =
     [ glib
@@ -55,6 +44,7 @@ stdenv.mkDerivation rec {
       hicolor-icon-theme
       libsndfile
       libxml2
+      libzip
       pcre
       poppler
       portaudio
@@ -62,6 +52,8 @@ stdenv.mkDerivation rec {
     ]
     ++ lib.optional withLua lua;
 
+  hardeningDisable = [ "format" ];
+
   enableParallelBuilding = true;
 
   meta = with stdenv.lib; {