about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorPaul Hendry <paul@pshendry.com>2016-05-30 01:15:58 -0700
committerFranz Pletz <fpletz@fnordicwalking.de>2016-05-30 10:15:58 +0200
commit8ea1f2d36cef8060e66f2d8a8d367672d2e3c027 (patch)
tree414426f7e42a3bf57c67ea2efe9590ef9b0868e7 /pkgs/applications
parentdd2bb96dbe44a98f247bdd4a2effebe6560522b7 (diff)
downloadnixlib-8ea1f2d36cef8060e66f2d8a8d367672d2e3c027.tar
nixlib-8ea1f2d36cef8060e66f2d8a8d367672d2e3c027.tar.gz
nixlib-8ea1f2d36cef8060e66f2d8a8d367672d2e3c027.tar.bz2
nixlib-8ea1f2d36cef8060e66f2d8a8d367672d2e3c027.tar.lz
nixlib-8ea1f2d36cef8060e66f2d8a8d367672d2e3c027.tar.xz
nixlib-8ea1f2d36cef8060e66f2d8a8d367672d2e3c027.tar.zst
nixlib-8ea1f2d36cef8060e66f2d8a8d367672d2e3c027.zip
syncthing: 0.12.25 -> 0.13.4 (#15730)
* Rename v0.12.25 package from 'syncthing' to 'syncthing012'
* Remove syncthing011
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/syncthing/default.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/pkgs/applications/networking/syncthing/default.nix b/pkgs/applications/networking/syncthing/default.nix
new file mode 100644
index 000000000000..3de4133e7945
--- /dev/null
+++ b/pkgs/applications/networking/syncthing/default.nix
@@ -0,0 +1,40 @@
+{ stdenv, fetchgit, go }:
+
+stdenv.mkDerivation rec {
+  version = "0.13.4";
+  name = "syncthing-${version}";
+
+  src = fetchgit {
+    url = https://github.com/syncthing/syncthing;
+    rev = "refs/tags/v${version}";
+    sha256 = "0aa0nqi0gmka5r5dzph4g51jlsy7w5q4ri8f4gy3qnma4pgp7pg2";
+  };
+
+  buildInputs = [ go ];
+
+  buildPhase = ''
+    mkdir -p src/github.com/syncthing
+    ln -s $(pwd) src/github.com/syncthing/syncthing
+    export GOPATH=$(pwd)
+    # Required for Go 1.5, can be removed for Go 1.6+
+    export GO15VENDOREXPERIMENT=1
+
+    # Syncthing's build.go script expects this working directory
+    cd src/github.com/syncthing/syncthing
+
+    go run build.go -no-upgrade -version v${version} install all
+  '';
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp bin/* $out/bin
+  '';
+
+  meta = {
+    homepage = https://www.syncthing.net/;
+    description = "Open Source Continuous File Synchronization";
+    license = stdenv.lib.licenses.mpl20;
+    maintainers = with stdenv.lib.maintainers; [pshendry];
+    platforms = with stdenv.lib.platforms; linux ++ freebsd ++ openbsd ++ netbsd;
+  };
+}