about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorPeter Hoeg <peter@speartail.com>2016-08-02 14:59:41 +0800
committerBenno Fünfstück <benno.fuenfstueck@gmail.com>2016-08-02 11:39:50 +0200
commit8c04c3c899cfa08e8a5e8a0e7b6d0b323f756ef6 (patch)
treea205492c208c520fdfe960b42e381923f399e01b /pkgs/applications
parent3a185d159f78b1f2ab2e954a501158ca5770f3a5 (diff)
downloadnixlib-8c04c3c899cfa08e8a5e8a0e7b6d0b323f756ef6.tar
nixlib-8c04c3c899cfa08e8a5e8a0e7b6d0b323f756ef6.tar.gz
nixlib-8c04c3c899cfa08e8a5e8a0e7b6d0b323f756ef6.tar.bz2
nixlib-8c04c3c899cfa08e8a5e8a0e7b6d0b323f756ef6.tar.lz
nixlib-8c04c3c899cfa08e8a5e8a0e7b6d0b323f756ef6.tar.xz
nixlib-8c04c3c899cfa08e8a5e8a0e7b6d0b323f756ef6.tar.zst
nixlib-8c04c3c899cfa08e8a5e8a0e7b6d0b323f756ef6.zip
notmuch-mutt: init at 0.22
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/mailreaders/notmuch/default.nix4
-rw-r--r--pkgs/applications/networking/mailreaders/notmuch/mutt.nix47
2 files changed, 50 insertions, 1 deletions
diff --git a/pkgs/applications/networking/mailreaders/notmuch/default.nix b/pkgs/applications/networking/mailreaders/notmuch/default.nix
index b9fc84d20583..bbf92ea0462a 100644
--- a/pkgs/applications/networking/mailreaders/notmuch/default.nix
+++ b/pkgs/applications/networking/mailreaders/notmuch/default.nix
@@ -5,10 +5,12 @@
 }:
 
 stdenv.mkDerivation rec {
-  name = "notmuch-0.22";
+  version = "0.22";
+  name = "notmuch-${version}";
 
   passthru = {
     pythonSourceRoot = "${name}/bindings/python";
+    inherit version;
   };
 
   src = fetchurl {
diff --git a/pkgs/applications/networking/mailreaders/notmuch/mutt.nix b/pkgs/applications/networking/mailreaders/notmuch/mutt.nix
new file mode 100644
index 000000000000..14f03c91f7c4
--- /dev/null
+++ b/pkgs/applications/networking/mailreaders/notmuch/mutt.nix
@@ -0,0 +1,47 @@
+{ stdenv, lib, fetchurl, perl, buildPerlPackage, perlPackages, makeWrapper, coreutils
+, notmuch }:
+
+stdenv.mkDerivation rec {
+  name = "notmuch-mutt-${version}";
+  version = notmuch.version;
+
+  outputs = [ "out" ];
+
+  dontStrip = true;
+
+  buildInputs = [
+    perl
+    makeWrapper
+  ] ++ (with perlPackages; [
+    FileRemove
+    DigestSHA1
+    Later
+    MailBox
+    MailMaildir
+    MailTools
+    StringShellQuote
+    TermReadLineGnu
+  ]);
+
+  src = notmuch.src;
+
+  phases = [ "unpackPhase" "installPhase" "fixupPhase" ];
+
+  installPhase = ''
+    ${coreutils}/bin/install -Dm755 \
+      ./contrib/notmuch-mutt/notmuch-mutt \
+      $out/bin/notmuch-mutt
+
+    wrapProgram $out/bin/notmuch-mutt \
+      --prefix PERL5LIB : $PERL5LIB
+  '';
+
+  meta = with lib; {
+    inherit version;
+    description = "Mutt support for notmuch";
+    homepage    = http://notmuchmua.org/;
+    license     = with licenses; mit;
+    maintainers = with maintainers; [ peterhoeg ];
+    platforms   = platforms.unix;
+  };
+}