about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2018-02-23 04:04:11 +0000
committerGitHub <noreply@github.com>2018-02-23 04:04:11 +0000
commit89aab8649e832ba7c97eea96630603882e295a45 (patch)
tree92233d77a2be9c8420a47ba808bb9ce44383c548 /pkgs/applications
parenteba35726ff48227f8c9e82d85d594155e7b8171b (diff)
parentfc42c85baf894b8e86d7f5828b04eadac3a4f8f4 (diff)
downloadnixlib-89aab8649e832ba7c97eea96630603882e295a45.tar
nixlib-89aab8649e832ba7c97eea96630603882e295a45.tar.gz
nixlib-89aab8649e832ba7c97eea96630603882e295a45.tar.bz2
nixlib-89aab8649e832ba7c97eea96630603882e295a45.tar.lz
nixlib-89aab8649e832ba7c97eea96630603882e295a45.tar.xz
nixlib-89aab8649e832ba7c97eea96630603882e295a45.tar.zst
nixlib-89aab8649e832ba7c97eea96630603882e295a45.zip
Merge pull request #35291 from svsdep/keepassrpc
keepass-keepassrpc: init at 1.7.3.1
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/keepass-plugins/keefox/default.nix34
-rw-r--r--pkgs/applications/misc/keepass-plugins/keepassrpc/default.nix35
2 files changed, 35 insertions, 34 deletions
diff --git a/pkgs/applications/misc/keepass-plugins/keefox/default.nix b/pkgs/applications/misc/keepass-plugins/keefox/default.nix
deleted file mode 100644
index 0215c5a71c2f..000000000000
--- a/pkgs/applications/misc/keepass-plugins/keefox/default.nix
+++ /dev/null
@@ -1,34 +0,0 @@
-{ stdenv, buildEnv, fetchurl, mono, unzip }:
-
-let
-  version = "1.6.4";
-  drv = stdenv.mkDerivation {
-    name = "keefox-${version}";
-    src = fetchurl {
-      url    = "https://github.com/luckyrat/KeeFox/releases/download/v${version}/${version}.xpi";
-      sha256 = "0nj4l9ssyfwbl1pxgxvd2h9q0mqhx7i0yzm4a2xjqlqwam534d1w";
-    };
-
-    meta = {
-      description = "Keepass plugin for keefox Firefox add-on";
-      homepage    = http://keefox.org;
-      platforms   = with stdenv.lib.platforms; linux;
-      license     = stdenv.lib.licenses.gpl2;
-      maintainers = [ stdenv.lib.maintainers.mjanczyk ];
-    };
-
-    buildInputs = [ unzip ];
-
-    pluginFilename = "KeePassRPC.plgx";
-
-    unpackCmd = "unzip $src deps/$pluginFilename ";
-    sourceRoot = "deps";
-
-    installPhase = ''
-      mkdir -p $out/lib/dotnet/keepass/
-      cp $pluginFilename $out/lib/dotnet/keepass/$pluginFilename
-    '';
-  };
-in
-  # Mono is required to compile plugin at runtime, after loading.
-  buildEnv { name = drv.name; paths = [ mono drv ]; }
diff --git a/pkgs/applications/misc/keepass-plugins/keepassrpc/default.nix b/pkgs/applications/misc/keepass-plugins/keepassrpc/default.nix
new file mode 100644
index 000000000000..b2980bcd8aea
--- /dev/null
+++ b/pkgs/applications/misc/keepass-plugins/keepassrpc/default.nix
@@ -0,0 +1,35 @@
+{ stdenv, buildEnv, fetchurl, mono }:
+
+let
+  version = "1.7.3.1";
+  drv = stdenv.mkDerivation {
+    name = "keepassrpc-${version}";
+    src = fetchurl {
+      url    = "https://github.com/kee-org/keepassrpc/releases/download/v${version}/KeePassRPC.plgx";
+      sha256 = "1y9b35qg27caj3pbaqqzrqpk61hbbd8617ziwdc9vl799i786m9k";
+    };
+
+    meta = with stdenv.lib; {
+      description = "The KeePassRPC plugin that needs to be installed inside KeePass in order for Kee to be able to connect your browser to your passwords";
+      homepage    = https://github.com/kee-org/keepassrpc;
+      platforms   = [ "x86_64-linux" ];
+      license     = licenses.gpl2;
+      maintainers = with maintainers; [ mjanczyk svsdep ];
+    };
+
+    pluginFilename = "KeePassRPC.plgx";
+
+    unpackCmd = ''
+      mkdir deps/
+      cp -p $src deps/$pluginFilename
+    '';
+    sourceRoot = "deps";
+
+    installPhase = ''
+      mkdir -p $out/lib/dotnet/keepass/
+      cp $pluginFilename $out/lib/dotnet/keepass/$pluginFilename
+    '';
+  };
+in
+  # Mono is required to compile plugin at runtime, after loading.
+  buildEnv { name = drv.name; paths = [ mono drv ]; }