about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2008-06-17 10:53:08 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2008-06-17 10:53:08 +0000
commit86564e26edcd39f0fd5cc0af3f22fea25ac19be8 (patch)
tree5719496d3fee98965f9352d4a3d7c917a8dd30b1 /pkgs/applications
parentd2ca06b62387cd9469c9d377ea78e2bfa5587efd (diff)
downloadnixlib-86564e26edcd39f0fd5cc0af3f22fea25ac19be8.tar
nixlib-86564e26edcd39f0fd5cc0af3f22fea25ac19be8.tar.gz
nixlib-86564e26edcd39f0fd5cc0af3f22fea25ac19be8.tar.bz2
nixlib-86564e26edcd39f0fd5cc0af3f22fea25ac19be8.tar.lz
nixlib-86564e26edcd39f0fd5cc0af3f22fea25ac19be8.tar.xz
nixlib-86564e26edcd39f0fd5cc0af3f22fea25ac19be8.tar.zst
nixlib-86564e26edcd39f0fd5cc0af3f22fea25ac19be8.zip
* Firefox 3.0.
* KVM 70.  Still doesn't fix the Samba regression though, so we can't
  use it in the build farm.

svn path=/nixpkgs/trunk/; revision=12136
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/browsers/firefox-3/builder.sh30
-rw-r--r--pkgs/applications/networking/browsers/firefox-3/default.nix33
2 files changed, 22 insertions, 41 deletions
diff --git a/pkgs/applications/networking/browsers/firefox-3/builder.sh b/pkgs/applications/networking/browsers/firefox-3/builder.sh
deleted file mode 100644
index 66f1059d657f..000000000000
--- a/pkgs/applications/networking/browsers/firefox-3/builder.sh
+++ /dev/null
@@ -1,30 +0,0 @@
-source $stdenv/setup
-
-postInstall=postInstall
-postInstall() {
-
-    # Strip some more stuff
-    strip -S $out/lib/*/* || true
-
-    # This fixes starting Firefox when there already is a running
-    # instance.  The `firefox' wrapper script actually expects to be
-    # in the same directory as `run-mozilla.sh', apparently.
-    libDir=$(cd $out/lib && ls -d firefox-*)
-    test -n "$libDir"
-    cd $out/bin
-    mv firefox ../lib/$libDir/
-    ln -s ../lib/$libDir/firefox .
-
-    # Register extensions etc.
-    echo "running firefox -register..."
-    (cd $out/lib/$libDir && LD_LIBRARY_PATH=. ./firefox-bin -register) || false
-
-    echo "running regxpcom..."
-    (cd $out/lib/$libDir && LD_LIBRARY_PATH=. ./regxpcom) || false
-
-    # Put the Firefox icon in the right place.
-    ensureDir $out/lib/$libDir/chrome/icons/default
-    ln -s ../../../icons/default.xpm  $out/lib/$libDir/chrome/icons/default/
-}
-
-genericBuild
diff --git a/pkgs/applications/networking/browsers/firefox-3/default.nix b/pkgs/applications/networking/browsers/firefox-3/default.nix
index 7f8f0eed65ab..544bb61f5e32 100644
--- a/pkgs/applications/networking/browsers/firefox-3/default.nix
+++ b/pkgs/applications/networking/browsers/firefox-3/default.nix
@@ -1,19 +1,27 @@
-args: with args;
+{ stdenv, fetchurl, pkgconfig, gtk, pango, perl, python, zip, libIDL
+, libjpeg, libpng, zlib, cairo, dbus, dbus_glib, bzip2, xlibs
+, freetype, fontconfig
+
+, # If you want the resulting program to call itself "Firefox" instead
+  # of "Deer Park", enable this option.  However, those binaries may
+  # not be distributed without permission from the Mozilla Foundation,
+  # see http://www.mozilla.org/foundation/trademarks/.
+  enableOfficialBranding ? false
+    
+}:
 
 stdenv.mkDerivation {
-  name = "firefox-3.0-beta-3";
+  name = "firefox-3.0";
 
   src = fetchurl {
-    url = http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.0rc2/source/firefox-3.0rc2-source.tar.bz2;
-    #url = http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.0b5/source/firefox-3.0b5-source.tar.bz2;
-    #url = ftp://ftp.mozilla.org/pub/firefox/releases/3.0b4/source/firefox-3.0b5-source.tar.bz2;
-    sha256 = "13g1ipnjxq4ssfj6f6pdp9rjdadb5sydfsgx6a5pqvxhzch5nq6i";
+    url = http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.0/source/firefox-3.0-source.tar.bz2;
+    sha256 = "1l1wp3w8zck55fr3spzfzzmgh326vifixa2cdiq3hf4wflf3yr36";
   };
 
   buildInputs = [
-    pkgconfig gtk perl zip libIDL libXi libjpeg libpng zlib cairo
-    python curl coreutils dbus dbus_glib pango freetype fontconfig 
-    libX11 libXrender libXft libXt
+    pkgconfig gtk perl zip libIDL libjpeg libpng zlib cairo bzip2
+    python dbus dbus_glib pango freetype fontconfig
+    xlibs.libXi xlibs.libX11 xlibs.libXrender xlibs.libXft xlibs.libXt
   ];
 
   configureFlags = [
@@ -23,8 +31,11 @@ stdenv.mkDerivation {
     "--enable-strip"
     "--with-system-jpeg"
     "--with-system-zlib"
-    #"--with-system-png" <-- "--with-system-png won't work because the system's libpng doesn't have APNG support"
-    #"--enable-system-cairo" <-- disabled for now because Firefox needs a alpha version of Cairo
+    "--with-system-bz2"
+    # "--with-system-png" # <-- "--with-system-png won't work because the system's libpng doesn't have APNG support"
+    "--enable-system-cairo" # <-- disabled for now because Firefox needs a alpha version of Cairo
+    #"--enable-system-sqlite" # <-- this seems to be discouraged
+    "--disable-crashreporter"
   ];
 
   postInstall = ''