about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorAustin Seipp <aseipp@pobox.com>2014-06-18 16:21:02 -0500
committerAustin Seipp <aseipp@pobox.com>2014-06-18 16:21:02 -0500
commit85c70f642f648739fa87c051390cd12cb317e3c6 (patch)
tree0c8f57d38a29eb928f790d5788619b06c7b5c849 /pkgs/applications
parent1e3a53e44ef3b227ea9790e3c32313be3e117f96 (diff)
parentb193dd5d7779756d0dd083f3eb06f44cb94d4339 (diff)
downloadnixlib-85c70f642f648739fa87c051390cd12cb317e3c6.tar
nixlib-85c70f642f648739fa87c051390cd12cb317e3c6.tar.gz
nixlib-85c70f642f648739fa87c051390cd12cb317e3c6.tar.bz2
nixlib-85c70f642f648739fa87c051390cd12cb317e3c6.tar.lz
nixlib-85c70f642f648739fa87c051390cd12cb317e3c6.tar.xz
nixlib-85c70f642f648739fa87c051390cd12cb317e3c6.tar.zst
nixlib-85c70f642f648739fa87c051390cd12cb317e3c6.zip
Merge pull request #2977 from bluescreen303/emacs-org2blog
Emacs org2blog - bring up to date - now works with org-8.* again
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/emacs-modes/metaweblog/default.nix31
-rw-r--r--pkgs/applications/editors/emacs-modes/org2blog/default.nix15
2 files changed, 40 insertions, 6 deletions
diff --git a/pkgs/applications/editors/emacs-modes/metaweblog/default.nix b/pkgs/applications/editors/emacs-modes/metaweblog/default.nix
new file mode 100644
index 000000000000..2a35c6ef6950
--- /dev/null
+++ b/pkgs/applications/editors/emacs-modes/metaweblog/default.nix
@@ -0,0 +1,31 @@
+{ stdenv, fetchgit, emacs, xmlRpc }:
+
+stdenv.mkDerivation rec {
+  name = "metaweblog-0.1";
+
+  src = fetchgit {
+    url = https://github.com/punchagan/metaweblog.git;
+    rev = "ceda65048afaa4c7596c7f50ced998c59ef41167";
+    sha256 = "a4c10bb1b4be574e560f87d5f07da4e24e5fffe9ecc83e6d4f9325f3a7eb1e2f";
+  };
+
+  buildInputs = [ emacs ];
+  propagatedUserEnvPkgs = [ xmlRpc ];
+
+  buildPhase = ''
+    emacs -L . -L ${xmlRpc}/share/emacs/site-lisp --batch -f batch-byte-compile *.el
+  '';
+
+  installPhase = ''
+    install -d $out/share/emacs/site-lisp
+    install *.el* $out/share/emacs/site-lisp
+  '';
+
+  meta = {
+    description = "an emacs library to access metaweblog based weblogs";
+    homepage = https://github.com/punchagan/metaweblog;
+    license = "GPLv3+";
+
+    platforms = stdenv.lib.platforms.all;
+  };
+}
diff --git a/pkgs/applications/editors/emacs-modes/org2blog/default.nix b/pkgs/applications/editors/emacs-modes/org2blog/default.nix
index e72560be8f44..d2e9e305bffb 100644
--- a/pkgs/applications/editors/emacs-modes/org2blog/default.nix
+++ b/pkgs/applications/editors/emacs-modes/org2blog/default.nix
@@ -1,19 +1,22 @@
-{ stdenv, fetchgit, emacs, xmlRpc }:
+{ stdenv, fetchgit, emacs, org, xmlRpc, metaweblog }:
 
 stdenv.mkDerivation rec {
-  name = "org2blog-0.5";
+  name = "org2blog-0.8.1";
 
   src = fetchgit {
     url = https://github.com/punchagan/org2blog.git;
-    rev = "338abe30e9bc89684f8384f8deaf826b63844da6";
-    sha256 = "46ab31e90d0d54071c126b7d5599a3e82062baa79ddf26b988bcb88d306d6827";
+    rev = "5f573ff3e4007c16517a5fe28c4f5d8dde3f8a77";
+    sha256 = "e83c08ceece92bb507be70046db4a7fa87a4af34ad3f84a727e0bd6a1dd99a33";
   };
 
   buildInputs = [ emacs ];
-  propagatedUserEnvPkgs = [ xmlRpc ];
+  propagatedUserEnvPkgs = [ org xmlRpc metaweblog ];
 
   buildPhase = ''
-    emacs -L . -L ${xmlRpc}/share/emacs/site-lisp --batch -f batch-byte-compile *.el
+    emacs -L . -L ${org}/share/emacs/site-lisp/org \
+               -L ${xmlRpc}/share/emacs/site-lisp \
+               -L ${metaweblog}/share/emacs/site-lisp \
+               --batch -f batch-byte-compile *.el
   '';
 
   installPhase = ''