about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorTimo Kaufmann <timokau@zoho.com>2020-03-31 15:17:33 +0000
committerGitHub <noreply@github.com>2020-03-31 15:17:33 +0000
commit83fd89945d355892e0e95747c9a2c519491c1600 (patch)
tree1094113f889a81f91af6f98c612b886842f1d718 /pkgs/applications
parent3bd7fc2800f19da4a716e530f063c1ea9b9cf737 (diff)
parent94c60990fc2ac185b070af63bb4ec2bb8db48f10 (diff)
downloadnixlib-83fd89945d355892e0e95747c9a2c519491c1600.tar
nixlib-83fd89945d355892e0e95747c9a2c519491c1600.tar.gz
nixlib-83fd89945d355892e0e95747c9a2c519491c1600.tar.bz2
nixlib-83fd89945d355892e0e95747c9a2c519491c1600.tar.lz
nixlib-83fd89945d355892e0e95747c9a2c519491c1600.tar.xz
nixlib-83fd89945d355892e0e95747c9a2c519491c1600.tar.zst
nixlib-83fd89945d355892e0e95747c9a2c519491c1600.zip
Merge pull request #79661 from luc65r/pkg/cemu
cemu: init at 1.3
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/math/cemu/default.nix53
1 files changed, 53 insertions, 0 deletions
diff --git a/pkgs/applications/science/math/cemu/default.nix b/pkgs/applications/science/math/cemu/default.nix
new file mode 100644
index 000000000000..f91e5be51700
--- /dev/null
+++ b/pkgs/applications/science/math/cemu/default.nix
@@ -0,0 +1,53 @@
+{ fetchFromGitHub
+, stdenv
+, mkDerivation
+, SDL2
+, libGL
+, libarchive
+, libusb
+, qtbase
+, qmake
+, git
+, libpng_apng
+, pkgconfig
+}:
+
+mkDerivation rec {
+  pname = "CEmu";
+  version = "1.3";
+  src = fetchFromGitHub {
+    owner = "CE-Programming";
+    repo = "CEmu";
+    rev = "v${version}";
+    sha256 = "1wcdnzcqscawj6jfdj5wwmw9g9vsd6a1rx0rrramakxzf8b7g47r";
+    fetchSubmodules = true;
+  };
+
+  nativeBuildInputs = [
+    qmake
+    git
+    pkgconfig
+  ];
+
+  buildInputs = [
+    SDL2
+    libGL
+    libarchive
+    libusb
+    qtbase
+    libpng_apng
+  ];
+
+  qmakeFlags = [
+    "gui/qt"
+  ];
+
+  meta = with stdenv.lib; {
+    changelog = "https://github.com/CE-Programming/CEmu/releases/tag/v${version}";
+    description = "Third-party TI-84 Plus CE / TI-83 Premium CE emulator, focused on developer features";
+    homepage = "https://ce-programming.github.io/CEmu";
+    license = licenses.gpl3;
+    maintainers = with maintainers; [ luc65r ];
+    platforms = [ "x86_64-linux" "x86_64-darwin" ];
+  };
+}