about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorFrederik Rietdijk <freddyrietdijk@fridh.nl>2019-07-15 21:14:04 +0200
committerGitHub <noreply@github.com>2019-07-15 21:14:04 +0200
commit800da69c8a5eae83bceee98af0c09e1b3440b3bf (patch)
treeca631e2a86d5e6bb40e95d6fa13c79b0d4d8940b /pkgs/applications
parent2e1a90e5d018a5e6b1dc1b5b3c726d6be26b22f8 (diff)
parente6223c022b94fad4b85e88319515d6f58910b5d7 (diff)
downloadnixlib-800da69c8a5eae83bceee98af0c09e1b3440b3bf.tar
nixlib-800da69c8a5eae83bceee98af0c09e1b3440b3bf.tar.gz
nixlib-800da69c8a5eae83bceee98af0c09e1b3440b3bf.tar.bz2
nixlib-800da69c8a5eae83bceee98af0c09e1b3440b3bf.tar.lz
nixlib-800da69c8a5eae83bceee98af0c09e1b3440b3bf.tar.xz
nixlib-800da69c8a5eae83bceee98af0c09e1b3440b3bf.tar.zst
nixlib-800da69c8a5eae83bceee98af0c09e1b3440b3bf.zip
Merge pull request #64551 from jonringer/update-pyproj
proj: 5.2.0 -> 6.1.1
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/gis/grass/default.nix34
-rw-r--r--pkgs/applications/gis/openorienteering-mapper/default.nix5
-rw-r--r--pkgs/applications/gis/qgis/unwrapped.nix21
-rw-r--r--pkgs/applications/gis/saga/default.nix8
-rw-r--r--pkgs/applications/gis/saga/lts.nix36
-rw-r--r--pkgs/applications/misc/merkaartor/default.nix2
-rw-r--r--pkgs/applications/misc/osm2xmap/default.nix2
-rw-r--r--pkgs/applications/science/astronomy/openspace/default.nix29
8 files changed, 60 insertions, 77 deletions
diff --git a/pkgs/applications/gis/grass/default.nix b/pkgs/applications/gis/grass/default.nix
index b7cf84ff9591..360d94d1b825 100644
--- a/pkgs/applications/gis/grass/default.nix
+++ b/pkgs/applications/gis/grass/default.nix
@@ -1,19 +1,23 @@
-{ stdenv, fetchurl, flex, bison, pkgconfig, zlib, libtiff, libpng, fftw
+{ stdenv, fetchFromGitHub, flex, bison, pkgconfig, zlib, libtiff, libpng, fftw
 , cairo, readline, ffmpeg, makeWrapper, wxGTK30, netcdf, blas
-, proj, gdal, geos, sqlite, postgresql, mysql, python2Packages, libLAS
+, proj, gdal, geos, sqlite, postgresql, mysql, python2Packages, libLAS, proj-datumgrid
 }:
 
-stdenv.mkDerivation {
-  name = "grass-7.2.2";
-  src = fetchurl {
-    url = https://grass.osgeo.org/grass72/source/grass-7.2.2.tar.gz;
-    sha256 = "0yzljbrxlqp4wbw08n1dvmm4vmwkg8glf1ff4xyh589r5ryb7gxv";
+stdenv.mkDerivation rec {
+  name = "grass";
+  version = "7.6.1";
+
+  src = with stdenv.lib; fetchFromGitHub {
+    owner = "OSGeo";
+    repo = "grass";
+    rev = "${name}_${replaceStrings ["."] ["_"] version}";
+    sha256 = "1amjk9rz7vw5ha7nyl5j2bfwj5if9w62nlwx5qbp1x7spldimlll";
   };
 
   nativeBuildInputs = [ pkgconfig ];
-  buildInputs = [ flex bison zlib proj gdal libtiff libpng fftw sqlite cairo
+  buildInputs = [ flex bison zlib proj gdal libtiff libpng fftw sqlite cairo proj
   readline ffmpeg makeWrapper wxGTK30 netcdf geos postgresql mysql.connector-c blas
-  libLAS ]
+  libLAS proj-datumgrid ]
     ++ (with python2Packages; [ python dateutil wxPython30 numpy ]);
 
   # On Darwin the installer tries to symlink the help files into a system
@@ -22,6 +26,8 @@ stdenv.mkDerivation {
 
   configureFlags = [
     "--with-proj-share=${proj}/share/proj"
+    "--with-proj-includes=${proj.dev}/include"
+    "--with-proj-lib=${proj}/lib"
     "--without-opengl"
     "--with-readline"
     "--with-wxwidgets"
@@ -49,9 +55,11 @@ stdenv.mkDerivation {
       scripts/d.what.vect/d.what.vect.py \
       scripts/g.extension/g.extension.py \
       scripts/g.extension.all/g.extension.all.py \
+      scripts/r.drain/r.drain.py \
       scripts/r.pack/r.pack.py \
       scripts/r.tileset/r.tileset.py \
       scripts/r.unpack/r.unpack.py \
+      scripts/v.clip/v.clip.py \
       scripts/v.rast.stats/v.rast.stats.py \
       scripts/v.to.lines/v.to.lines.py \
       scripts/v.what.strds/v.what.strds.py \
@@ -72,13 +80,15 @@ stdenv.mkDerivation {
     done
   '';
 
+  NIX_CFLAGS_COMPILE = [ "-DACCEPT_USE_OF_DEPRECATED_PROJ_API_H=1" ];
+
   postInstall = ''
-    wrapProgram $out/bin/grass72 \
+    wrapProgram $out/bin/grass76 \
     --set PYTHONPATH $PYTHONPATH \
     --set GRASS_PYTHON ${python2Packages.python}/bin/${python2Packages.python.executable} \
     --suffix LD_LIBRARY_PATH ':' '${gdal}/lib'
-    ln -s $out/grass-*/lib $out/lib
-    ln -s $out/grass-*/include $out/include
+    ln -s $out/grass*/lib $out/lib
+    ln -s $out/grass*/include $out/include
   '';
 
   enableParallelBuilding = true;
diff --git a/pkgs/applications/gis/openorienteering-mapper/default.nix b/pkgs/applications/gis/openorienteering-mapper/default.nix
index a5a0492ab876..b4d3e9f93a47 100644
--- a/pkgs/applications/gis/openorienteering-mapper/default.nix
+++ b/pkgs/applications/gis/openorienteering-mapper/default.nix
@@ -20,9 +20,6 @@ stdenv.mkDerivation rec {
 
   cmakeFlags =
     [
-    # Required by the build to be specified
-    "-DPROJ4_ROOT=${proj}"
-
     # Building the manual and bundling licenses fails
     "-DLICENSING_PROVIDER:BOOL=OFF"
     "-DMapper_MANUAL_QTHELP:BOOL=OFF"
@@ -43,6 +40,8 @@ stdenv.mkDerivation rec {
     "-DMapper_PACKAGE_GDAL=0"
     ]);
 
+  # Needs to be available when proj_api.h gets evaluted by CPP
+  NIX_CFLAGS_COMPILE = [ "-DACCEPT_USE_OF_DEPRECATED_PROJ_API_H" ];
 
   postInstall =
     stdenv.lib.optionalString stdenv.isDarwin ''
diff --git a/pkgs/applications/gis/qgis/unwrapped.nix b/pkgs/applications/gis/qgis/unwrapped.nix
index 6e7fb375eab9..a57b180d5b23 100644
--- a/pkgs/applications/gis/qgis/unwrapped.nix
+++ b/pkgs/applications/gis/qgis/unwrapped.nix
@@ -1,6 +1,6 @@
-{ stdenv, lib, fetchurl, cmake, ninja, flex, bison, proj, geos, xlibsWrapper, sqlite, gsl
+{ stdenv, lib, fetchFromGitHub, cmake, ninja, flex, bison, proj, geos, xlibsWrapper, sqlite, gsl
 , qwt, fcgi, python3Packages, libspatialindex, libspatialite, postgresql
-, txt2tags, openssl, libzip, hdf5, netcdf
+, txt2tags, openssl, libzip, hdf5, netcdf, exiv2
 , qtbase, qtwebkit, qtsensors, qca-qt5, qtkeychain, qscintilla, qtserialport, qtxmlpatterns
 , withGrass ? true, grass
 }:
@@ -10,12 +10,15 @@ let
     [ qscintilla-qt5 gdal jinja2 numpy psycopg2
       chardet dateutil pyyaml pytz requests urllib3 pygments pyqt5 sip owslib six ];
 in stdenv.mkDerivation rec {
-  version = "3.4.8";
-  name = "qgis-unwrapped-${version}";
+  version = "3.8.0";
+  pname = "qgis";
+  name = "${pname}-unwrapped-${version}";
 
-  src = fetchurl {
-    url = "http://qgis.org/downloads/qgis-${version}.tar.bz2";
-    sha256 = "13dy9y7ipv25x3k31njhjljdav36xay6s82g6ywaqf1xxh3s567w";
+  src = fetchFromGitHub {
+    owner = "qgis";
+    repo = "QGIS";
+    rev = "final-${lib.replaceStrings ["."] ["_"] version}";
+    sha256 = "11jqj6lavpw9piv0rm8vvbgd99zhcxl6yfjg699wlrjlyf71xac5";
   };
 
   passthru = {
@@ -23,7 +26,7 @@ in stdenv.mkDerivation rec {
     inherit python3Packages;
   };
 
-  buildInputs = [ openssl proj geos xlibsWrapper sqlite gsl qwt
+  buildInputs = [ openssl proj geos xlibsWrapper sqlite gsl qwt exiv2
     fcgi libspatialindex libspatialite postgresql txt2tags libzip hdf5 netcdf
     qtbase qtwebkit qtsensors qca-qt5 qtkeychain qscintilla qtserialport qtxmlpatterns] ++
     (stdenv.lib.optional withGrass grass) ++ pythonBuildInputs;
@@ -36,7 +39,7 @@ in stdenv.mkDerivation rec {
   # build to use PYQT5_SIP_DIR consistently.
   postPatch = ''
      substituteInPlace cmake/FindPyQt5.py \
-       --replace 'pyqtcfg.pyqt_sip_dir' '"${python3Packages.pyqt5}/share/sip/PyQt5"'
+       --replace 'sip_dir = cfg.default_sip_dir' 'sip_dir = "${python3Packages.pyqt5}/share/sip/PyQt5"'
    '';
 
   cmakeFlags = [ "-DCMAKE_SKIP_BUILD_RPATH=OFF"
diff --git a/pkgs/applications/gis/saga/default.nix b/pkgs/applications/gis/saga/default.nix
index 34bb8c9f55ad..7440e2633a33 100644
--- a/pkgs/applications/gis/saga/default.nix
+++ b/pkgs/applications/gis/saga/default.nix
@@ -3,7 +3,9 @@
   unixODBC , poppler, hdf4, hdf5, netcdf, sqlite, qhull, giflib }:
 
 stdenv.mkDerivation rec {
-  name = "saga-7.2.0";
+  pname = "saga";
+  version = "7.3.0";
+  name = "${pname}-${version}";
 
   # See https://groups.google.com/forum/#!topic/nix-devel/h_vSzEJAPXs
   # for why the have additional buildInputs on darwin
@@ -17,8 +19,8 @@ stdenv.mkDerivation rec {
   CXXFLAGS = stdenv.lib.optionalString stdenv.cc.isClang "-std=c++11 -Wno-narrowing";
 
   src = fetchurl {
-    url = "mirror://sourceforge/project/saga-gis/SAGA%20-%207/SAGA%20-%207.2.0/saga-7.2.0.tar.gz";
-    sha256 = "10gjc5mc5kwg2c2la22hgwx6s5q60z9xxffjpjw0zrlhksijl5an";
+    url = "https://sourceforge.net/projects/saga-gis/files/SAGA%20-%207/SAGA%20-%207.3.0/saga-7.3.0.tar.gz";
+    sha256 = "1g7v6vx7b8mfhbbg03pdk4kyks20maqbcdbasnxazhs8pl2zih7k";
   };
 
   meta = with stdenv.lib; {
diff --git a/pkgs/applications/gis/saga/lts.nix b/pkgs/applications/gis/saga/lts.nix
deleted file mode 100644
index ca0034aa9708..000000000000
--- a/pkgs/applications/gis/saga/lts.nix
+++ /dev/null
@@ -1,36 +0,0 @@
-{ stdenv, fetchgit, gdal, wxGTK30, proj, libiodbc, lzma, jasper,
-  libharu, opencv, vigra, postgresql, autoreconfHook, Cocoa
-  , unixODBC , poppler, hdf4, hdf5, netcdf, sqlite, qhull, giflib }:
-
-stdenv.mkDerivation rec {
-  name = "saga-2.3.2";
-
-  # See https://groups.google.com/forum/#!topic/nix-devel/h_vSzEJAPXs
-  # for why the have additional buildInputs on darwin
-  buildInputs = [ autoreconfHook gdal wxGTK30 proj libharu opencv vigra
-                  postgresql libiodbc lzma jasper
-                  unixODBC poppler hdf4.out hdf5 netcdf sqlite qhull giflib ]
-                ++ stdenv.lib.optional stdenv.isDarwin Cocoa ;
-
-  enableParallelBuilding = true;
-
-  CXXFLAGS = stdenv.lib.optionalString stdenv.cc.isClang "-std=c++11 -Wno-narrowing";
-
-  sourceRoot = "code-b6f474f/saga-gis";
-
-  patches = [ ./clang_patch.patch ./finite.patch];
-
-  src = fetchgit {
-    url = "https://git.code.sf.net/p/saga-gis/code.git";
-    rev = "b6f474f8af4af7f0ff82548cc6f88c53547d91f5";
-    sha256 = "0iakynai8mhcwj6wxvafkqhd7b417ss7hyhbcp9wf6092l6vc2zd";
-  };
-
-  meta = with stdenv.lib; {
-    description = "System for Automated Geoscientific Analyses";
-    homepage = http://www.saga-gis.org;
-    license = licenses.gpl2Plus;
-    maintainers = [ maintainers.mpickering ];
-    platforms = with platforms; unix;
-  };
-}
diff --git a/pkgs/applications/misc/merkaartor/default.nix b/pkgs/applications/misc/merkaartor/default.nix
index 0833464f2c25..dec55e9c1e5c 100644
--- a/pkgs/applications/misc/merkaartor/default.nix
+++ b/pkgs/applications/misc/merkaartor/default.nix
@@ -18,6 +18,8 @@ stdenv.mkDerivation rec {
 
   enableParallelBuilding = true;
 
+  NIX_CFLAGS_COMPILE = [ "-DACCEPT_USE_OF_DEPRECATED_PROJ_API_H" ];
+
   postInstall = ''
     wrapProgram $out/bin/merkaartor \
       --set QT_QPA_PLATFORM_PLUGIN_PATH ${qtbase.bin}/lib/qt-*/plugins/platforms
diff --git a/pkgs/applications/misc/osm2xmap/default.nix b/pkgs/applications/misc/osm2xmap/default.nix
index 5787adef2a3e..9d0fb3fdeb7c 100644
--- a/pkgs/applications/misc/osm2xmap/default.nix
+++ b/pkgs/applications/misc/osm2xmap/default.nix
@@ -20,6 +20,8 @@ stdenv.mkDerivation rec {
     "INSTALL_SHAREDIR=$(out)/share/"
   ];
 
+  NIX_CFLAGS_COMPILE = [ "-DACCEPT_USE_OF_DEPRECATED_PROJ_API_H" ];
+
   installFlags = [ "DESTDIR=$(out)" ];
 
   buildInputs = [ libroxml proj libyamlcpp boost ];
diff --git a/pkgs/applications/science/astronomy/openspace/default.nix b/pkgs/applications/science/astronomy/openspace/default.nix
index ee3a71cf1813..dc7c7c920a17 100644
--- a/pkgs/applications/science/astronomy/openspace/default.nix
+++ b/pkgs/applications/science/astronomy/openspace/default.nix
@@ -5,7 +5,7 @@
 stdenv.mkDerivation rec {
   version = "0.11.1";
   name    = "openspace-${version}";
-  
+
   src = fetchFromGitHub {
     owner  = "OpenSpace";
     repo   = "OpenSpace";
@@ -13,37 +13,37 @@ stdenv.mkDerivation rec {
     sha256 = "0msqixf30r0d41xmfmzkdfw6w9jkx2ph5clq8xiwrg1jc3z9q7nv";
     fetchSubmodules = true;
   };
-  
+
   buildInputs = [
     makeWrapper cmake
     curl boost gdal glew soil
     libX11 libXi libXxf86vm libXcursor libXrandr libXinerama
   ];
-      
+
   glmPlatformH = fetchurl {
     url    = "https://raw.githubusercontent.com/g-truc/glm/dd48b56e44d699a022c69155c8672caacafd9e8a/glm/simd/platform.h";
     sha256 = "0y91hlbgn5va7ijg5mz823gqkq9hqxl00lwmdwnf8q2g086rplzw";
   };
-  
+
   # See <https://github.com/g-truc/glm/issues/726>
   prePatch = ''
     cp ${glmPlatformH} ext/sgct/include/glm/simd/platform.h
     cp ${glmPlatformH} ext/ghoul/ext/glm/glm/simd/platform.h
   '';
-  
+
   patches = [
     # See <https://github.com/opensgct/sgct/issues/13>
     ./vrpn.patch
-    
+
     ./constexpr.patch
     ./config.patch
 
     # WARNING: This patch disables some slow torrents in a very dirty way.
-    ./assets.patch 
+    ./assets.patch
   ];
-  
+
   bundle = "$out/usr/share/openspace";
-  
+
   preConfigure = ''
     cmakeFlagsArray=(
       $cmakeFlagsArray
@@ -51,28 +51,28 @@ stdenv.mkDerivation rec {
       "-DCMAKE_INSTALL_PREFIX=${bundle}"
     )
   '';
-  
+
   preInstall = ''
     mkdir -p $out/bin
     mkdir -p ${bundle}
   '';
-  
+
   postInstall = ''
     cp ext/spice/libSpice.so       ${bundle}/lib
     cp ext/ghoul/ext/lua/libLua.so ${bundle}/lib
   '';
-  
+
   postFixup = ''
     for bin in ${bundle}/bin/*
     do
       rpath=$(patchelf --print-rpath $bin)
       patchelf --set-rpath $rpath:${bundle}/lib $bin
-      
+
       name=$(basename $bin)
       makeWrapper $bin $out/bin/$name --run "cd ${bundle}"
     done
   '';
-  
+
   meta = {
     description     = "Open-source astrovisualization project";
     longDescription = ''
@@ -85,5 +85,6 @@ stdenv.mkDerivation rec {
     homepage  = https://www.openspaceproject.com/;
     license   = stdenv.lib.licenses.mit;
     platforms = stdenv.lib.platforms.linux;
+    broken = true; # fails to build
   };
 }