about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorBen Siraphob <bensiraphob@gmail.com>2021-03-26 12:13:53 +0700
committerBen Siraphob <bensiraphob@gmail.com>2021-03-26 12:18:16 +0700
commit7d97e284e8ca433cfe77f103617d1e5a6eb151ec (patch)
treea09aca74597cfca904df9f92c82cb4bf3be552f6 /pkgs/applications
parent17885fe3dbfcc4f239657742b2e4fb7d8ff67827 (diff)
downloadnixlib-7d97e284e8ca433cfe77f103617d1e5a6eb151ec.tar
nixlib-7d97e284e8ca433cfe77f103617d1e5a6eb151ec.tar.gz
nixlib-7d97e284e8ca433cfe77f103617d1e5a6eb151ec.tar.bz2
nixlib-7d97e284e8ca433cfe77f103617d1e5a6eb151ec.tar.lz
nixlib-7d97e284e8ca433cfe77f103617d1e5a6eb151ec.tar.xz
nixlib-7d97e284e8ca433cfe77f103617d1e5a6eb151ec.tar.zst
nixlib-7d97e284e8ca433cfe77f103617d1e5a6eb151ec.zip
treewide: remove redundant stdenv
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/neovim/neovim-qt.nix2
-rw-r--r--pkgs/applications/networking/cluster/helm/wrapper.nix4
-rw-r--r--pkgs/applications/networking/sync/rsync/base.nix2
-rw-r--r--pkgs/applications/networking/sync/rsync/default.nix2
-rw-r--r--pkgs/applications/networking/sync/rsync/rrsync.nix2
5 files changed, 5 insertions, 7 deletions
diff --git a/pkgs/applications/editors/neovim/neovim-qt.nix b/pkgs/applications/editors/neovim/neovim-qt.nix
index 505fd41f797c..d925ddd2a528 100644
--- a/pkgs/applications/editors/neovim/neovim-qt.nix
+++ b/pkgs/applications/editors/neovim/neovim-qt.nix
@@ -1,4 +1,4 @@
-{ lib, stdenv, mkDerivation, fetchFromGitHub, cmake, doxygen, makeWrapper
+{ lib, mkDerivation, fetchFromGitHub, cmake, doxygen, makeWrapper
 , msgpack, neovim, pythonPackages, qtbase }:
 
 mkDerivation rec {
diff --git a/pkgs/applications/networking/cluster/helm/wrapper.nix b/pkgs/applications/networking/cluster/helm/wrapper.nix
index edad7fa1bc99..21a29e31243b 100644
--- a/pkgs/applications/networking/cluster/helm/wrapper.nix
+++ b/pkgs/applications/networking/cluster/helm/wrapper.nix
@@ -1,6 +1,4 @@
-{ stdenv, symlinkJoin, lib, makeWrapper
-, writeText
-}:
+{ symlinkJoin, lib, makeWrapper, writeText }:
 
 helm:
 
diff --git a/pkgs/applications/networking/sync/rsync/base.nix b/pkgs/applications/networking/sync/rsync/base.nix
index 7c7d3a1f418e..3479458088ed 100644
--- a/pkgs/applications/networking/sync/rsync/base.nix
+++ b/pkgs/applications/networking/sync/rsync/base.nix
@@ -1,4 +1,4 @@
-{ lib, stdenv, fetchurl }:
+{ lib, fetchurl }:
 
 rec {
   version = "3.2.3";
diff --git a/pkgs/applications/networking/sync/rsync/default.nix b/pkgs/applications/networking/sync/rsync/default.nix
index c50ea08510af..a38352a328aa 100644
--- a/pkgs/applications/networking/sync/rsync/default.nix
+++ b/pkgs/applications/networking/sync/rsync/default.nix
@@ -15,7 +15,7 @@ assert enableXXHash -> xxHash != null;
 assert enableZstd -> zstd != null;
 
 let
-  base = import ./base.nix { inherit lib stdenv fetchurl; };
+  base = import ./base.nix { inherit lib fetchurl; };
 in
 stdenv.mkDerivation rec {
   name = "rsync-${base.version}";
diff --git a/pkgs/applications/networking/sync/rsync/rrsync.nix b/pkgs/applications/networking/sync/rsync/rrsync.nix
index 5a4c2600569e..83eb4658d2f3 100644
--- a/pkgs/applications/networking/sync/rsync/rrsync.nix
+++ b/pkgs/applications/networking/sync/rsync/rrsync.nix
@@ -1,7 +1,7 @@
 { lib, stdenv, fetchurl, perl, rsync }:
 
 let
-  base = import ./base.nix { inherit stdenv lib fetchurl; };
+  base = import ./base.nix { inherit lib fetchurl; };
 in
 stdenv.mkDerivation {
   name = "rrsync-${base.version}";