about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorTimo Kaufmann <timokau@zoho.com>2018-11-27 18:26:16 +0100
committerTimo Kaufmann <timokau@zoho.com>2018-11-27 18:26:16 +0100
commit7ca2915a502c883eb68bd939251452b9057d3c9d (patch)
treee98e338fcb977b2d9d8f885329f4453767319ec2 /pkgs/applications
parent2dd9a0ed72a1f99fbc4f972889a82e29d972886e (diff)
downloadnixlib-7ca2915a502c883eb68bd939251452b9057d3c9d.tar
nixlib-7ca2915a502c883eb68bd939251452b9057d3c9d.tar.gz
nixlib-7ca2915a502c883eb68bd939251452b9057d3c9d.tar.bz2
nixlib-7ca2915a502c883eb68bd939251452b9057d3c9d.tar.lz
nixlib-7ca2915a502c883eb68bd939251452b9057d3c9d.tar.xz
nixlib-7ca2915a502c883eb68bd939251452b9057d3c9d.tar.zst
nixlib-7ca2915a502c883eb68bd939251452b9057d3c9d.zip
sage: 8.5.beta4 -> 8.5.beta5
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/math/sage/default.nix14
-rw-r--r--pkgs/applications/science/math/sage/sage-env.nix1
-rw-r--r--pkgs/applications/science/math/sage/sage-src.nix13
3 files changed, 5 insertions, 23 deletions
diff --git a/pkgs/applications/science/math/sage/default.nix b/pkgs/applications/science/math/sage/default.nix
index 832b2f110565..dfdf210eec04 100644
--- a/pkgs/applications/science/math/sage/default.nix
+++ b/pkgs/applications/science/math/sage/default.nix
@@ -70,7 +70,7 @@ let
   sage-env = callPackage ./sage-env.nix {
     sagelib = python.pkgs.sagelib;
     inherit env-locations;
-    inherit python rWrapper ecl singular palp flint pynac pythonEnv;
+    inherit python ecl singular palp flint pynac pythonEnv;
     pkg-config = pkgs.pkgconfig; # not to confuse with pythonPackages.pkgconfig
   };
 
@@ -124,18 +124,6 @@ let
     ignoreCollisions = true;
   } // { extraLibs = pythonRuntimeDeps; }; # make the libs accessible
 
-  # needs to be rWrapper, standard "R" doesn't include default packages
-  rWrapper = pkgs.rWrapper.override {
-    # https://trac.sagemath.org/ticket/25674
-    R = pkgs.R.overrideAttrs (attrs: rec {
-      name = "R-3.4.4";
-      src = fetchurl {
-        url = "http://cran.r-project.org/src/base/R-3/${name}.tar.gz";
-        sha256 = "0dq3jsnwsb5j3fhl0wi3p5ycv8avf8s5j1y4ap3d2mkjmcppvsdk";
-      };
-    });
-  };
-
   arb = pkgs.arb.override { inherit flint; };
 
   singular = pkgs.singular.override { inherit flint; };
diff --git a/pkgs/applications/science/math/sage/sage-env.nix b/pkgs/applications/science/math/sage/sage-env.nix
index 725ca0438670..7d4a66ea2b9c 100644
--- a/pkgs/applications/science/math/sage/sage-env.nix
+++ b/pkgs/applications/science/math/sage/sage-env.nix
@@ -76,6 +76,7 @@ let
     singular
     giac
     palp
+    # needs to be rWrapper since the default `R` doesn't include R's default libraries
     rWrapper
     gfan
     cddlib
diff --git a/pkgs/applications/science/math/sage/sage-src.nix b/pkgs/applications/science/math/sage/sage-src.nix
index dd96121925fe..81386533a39c 100644
--- a/pkgs/applications/science/math/sage/sage-src.nix
+++ b/pkgs/applications/science/math/sage/sage-src.nix
@@ -9,14 +9,14 @@
 # all get the same sources with the same patches applied.
 
 stdenv.mkDerivation rec {
-  version = "8.5.beta4";
+  version = "8.5.beta5";
   name = "sage-src-${version}";
 
   src = fetchFromGitHub {
     owner = "sagemath";
     repo = "sage";
     rev = version;
-    sha256 = "0x8zi5c1glw5h7231yxdyklmf1vgrvf0zvzwa4qwnm7x2nky62zf";
+    sha256 = "1jnlk4y7njkg095kd3rhsi5929k6q90lzgyb7pshsjz251866nyv";
   };
 
   # Patches needed because of particularities of nix or the way this is packaged.
@@ -70,6 +70,7 @@ stdenv.mkDerivation rec {
     );
   in [
     # New glpk version has new warnings, filter those out until upstream sage has found a solution
+    # Should be fixed with glpk > 4.65.
     # https://trac.sagemath.org/ticket/24824
     ./patches/pari-stackwarn.patch # not actually necessary since the pari upgrade, but necessary for the glpk patch to apply
     (fetchpatch {
@@ -78,14 +79,6 @@ stdenv.mkDerivation rec {
       stripLen = 1;
     })
 
-    # needed for ntl update
-    # https://trac.sagemath.org/ticket/25532
-    (fetchpatch {
-      name = "lcalc-c++11.patch";
-      url = "https://git.archlinux.org/svntogit/community.git/plain/trunk/sagemath-lcalc-c++11.patch?h=packages/sagemath&id=0e31ae526ab7c6b5c0bfacb3f8b1c4fd490035aa";
-      sha256 = "0p5wnvbx65i7cp0bjyaqgp4rly8xgnk12pqwaq3dqby0j2bk6ijb";
-    })
-
     (fetchpatch {
       name = "cython-0.29.patch";
       url = "https://git.sagemath.org/sage.git/patch/?h=f77de1d0e7f90ee12761140500cb8cbbb789ab20";