about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas.tynkkynen@iki.fi>2016-04-29 14:46:54 +0300
committerTuomas Tynkkynen <tuomas.tynkkynen@iki.fi>2016-04-29 14:46:54 +0300
commit7996c54ae807871d9e1a0e102c30a1a51d446e6c (patch)
tree45a1ba5bb622850aa582b7520bca488b45347fd5 /pkgs/applications
parent8a3b70791c4b643822eb5feb3f9e23ec5e56b863 (diff)
parent4a0cbae0702eed8ea8d9d3141f022ff4db71db58 (diff)
downloadnixlib-7996c54ae807871d9e1a0e102c30a1a51d446e6c.tar
nixlib-7996c54ae807871d9e1a0e102c30a1a51d446e6c.tar.gz
nixlib-7996c54ae807871d9e1a0e102c30a1a51d446e6c.tar.bz2
nixlib-7996c54ae807871d9e1a0e102c30a1a51d446e6c.tar.lz
nixlib-7996c54ae807871d9e1a0e102c30a1a51d446e6c.tar.xz
nixlib-7996c54ae807871d9e1a0e102c30a1a51d446e6c.tar.zst
nixlib-7996c54ae807871d9e1a0e102c30a1a51d446e6c.zip
Merge pull request #15058 from yochai/master
eclipse: fix build error
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/eclipse/build-eclipse.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/applications/editors/eclipse/build-eclipse.nix b/pkgs/applications/editors/eclipse/build-eclipse.nix
index 074a622667fa..e6828e6adad2 100644
--- a/pkgs/applications/editors/eclipse/build-eclipse.nix
+++ b/pkgs/applications/editors/eclipse/build-eclipse.nix
@@ -23,7 +23,7 @@ stdenv.mkDerivation rec {
     tar xfvz $src -C $out
 
     # Patch binaries.
-    interpreter=$(echo ${stdenv.glibc}/lib/ld-linux*.so.2)
+    interpreter=$(echo ${stdenv.glibc.out}/lib/ld-linux*.so.2)
     libCairo=$out/eclipse/libcairo-swt.so
     patchelf --set-interpreter $interpreter $out/eclipse/eclipse
     [ -f $libCairo ] && patchelf --set-rpath ${freetype}/lib:${fontconfig}/lib:${libX11}/lib:${libXrender}/lib:${zlib}/lib $libCairo
@@ -36,7 +36,7 @@ stdenv.mkDerivation rec {
 
     makeWrapper $out/eclipse/eclipse $out/bin/eclipse \
       --prefix PATH : ${jdk}/bin \
-      --prefix LD_LIBRARY_PATH : ${glib}/lib:${gtk}/lib:${libXtst}/lib${stdenv.lib.optionalString (webkitgtk2 != null) ":${webkitgtk2}/lib"} \
+      --prefix LD_LIBRARY_PATH : ${glib}/lib:${gtk.out}/lib:${libXtst}/lib${stdenv.lib.optionalString (webkitgtk2 != null) ":${webkitgtk2}/lib"} \
       --add-flags "-configuration \$HOME/.eclipse/''${productId}_$productVersion/configuration"
 
     # Create desktop item.