about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorDennis Gosnell <cdep.illabout@gmail.com>2024-01-12 14:45:27 +0900
committerDennis Gosnell <cdep.illabout@gmail.com>2024-01-16 16:09:16 +0900
commit795f3e1cbaae5d2aa2b27af316e3b06154838e08 (patch)
tree534d830d875cc1d8f59335e87fe04e2aa92bc228 /pkgs/applications
parentdc8a34cf0f162018bf5cba4d5ea92df46cba970a (diff)
downloadnixlib-795f3e1cbaae5d2aa2b27af316e3b06154838e08.tar
nixlib-795f3e1cbaae5d2aa2b27af316e3b06154838e08.tar.gz
nixlib-795f3e1cbaae5d2aa2b27af316e3b06154838e08.tar.bz2
nixlib-795f3e1cbaae5d2aa2b27af316e3b06154838e08.tar.lz
nixlib-795f3e1cbaae5d2aa2b27af316e3b06154838e08.tar.xz
nixlib-795f3e1cbaae5d2aa2b27af316e3b06154838e08.tar.zst
nixlib-795f3e1cbaae5d2aa2b27af316e3b06154838e08.zip
tftui: init at 0.12.4
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/cluster/tftui/default.nix54
1 files changed, 54 insertions, 0 deletions
diff --git a/pkgs/applications/networking/cluster/tftui/default.nix b/pkgs/applications/networking/cluster/tftui/default.nix
new file mode 100644
index 000000000000..3a9d657dbdd2
--- /dev/null
+++ b/pkgs/applications/networking/cluster/tftui/default.nix
@@ -0,0 +1,54 @@
+{ lib
+, buildPythonApplication
+, fetchPypi
+, makeWrapper
+, poetry-core
+, posthog
+, pyperclip
+, requests
+, rich
+, textual
+, enableUsageTracking ? false
+}:
+
+buildPythonApplication rec {
+  pname = "tftui";
+  version = "0.12.4";
+  pyproject = true;
+
+  src = fetchPypi {
+    inherit pname version;
+    hash = "sha256-E4Y0qA7SooMlHh+oSFUl1hfblpirr/Jdb1C2fqU43t0=";
+  };
+
+  propagatedBuildInputs = [
+    posthog
+    pyperclip
+    requests
+    rich
+    textual
+  ];
+
+  nativeBuildInputs = [
+    makeWrapper
+    poetry-core
+  ];
+
+  pythonImportsCheck = [
+    "tftui"
+  ];
+
+  postInstall = lib.optionalString (!enableUsageTracking) ''
+    wrapProgram $out/bin/tftui \
+      --add-flags "--disable-usage-tracking"
+  '';
+
+  meta = with lib; {
+    description = "Textual UI to view and interact with Terraform state";
+    homepage = "https://github.com/idoavrah/terraform-tui";
+    changelog = "https://github.com/idoavrah/terraform-tui/releases";
+    license = licenses.asl20;
+    maintainers = with maintainers; teams.bitnomial.members;
+    mainProgram = "tftui";
+  };
+}