about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorDaniel Schaefer <git@danielschaefer.me>2019-04-24 05:48:22 +0200
committerDaniel Schaefer <git@danielschaefer.me>2019-04-29 14:05:50 +0200
commit786f02f7a45621b9f628f63649ff92546aff83b7 (patch)
tree92784e131ccac4a1a63f7dbae6c228fb9d81468b /pkgs/applications
parent5f14e83bd6b9ef1c83b035011267dd3d40278476 (diff)
downloadnixlib-786f02f7a45621b9f628f63649ff92546aff83b7.tar
nixlib-786f02f7a45621b9f628f63649ff92546aff83b7.tar.gz
nixlib-786f02f7a45621b9f628f63649ff92546aff83b7.tar.bz2
nixlib-786f02f7a45621b9f628f63649ff92546aff83b7.tar.lz
nixlib-786f02f7a45621b9f628f63649ff92546aff83b7.tar.xz
nixlib-786f02f7a45621b9f628f63649ff92546aff83b7.tar.zst
nixlib-786f02f7a45621b9f628f63649ff92546aff83b7.zip
treewide: Remove usage of isNull
isNull "is deprecated; just write e == null instead" says the Nix manual
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/renoise/default.nix4
-rw-r--r--pkgs/applications/networking/mailreaders/lumail/default.nix2
-rw-r--r--pkgs/applications/science/math/cplex/default.nix2
-rw-r--r--pkgs/applications/science/math/sage/sage-with-env.nix2
-rw-r--r--pkgs/applications/video/kodi/plugins.nix2
5 files changed, 6 insertions, 6 deletions
diff --git a/pkgs/applications/audio/renoise/default.nix b/pkgs/applications/audio/renoise/default.nix
index 081c4ab41acb..ddbefd129ffe 100644
--- a/pkgs/applications/audio/renoise/default.nix
+++ b/pkgs/applications/audio/renoise/default.nix
@@ -19,7 +19,7 @@ stdenv.mkDerivation rec {
 
   src =
     if stdenv.hostPlatform.system == "x86_64-linux" then
-        if builtins.isNull releasePath then
+        if releasePath == null then
         fetchurl {
           url = "https://files.renoise.com/demo/Renoise_${urlVersion version}_Demo_x86_64.tar.bz2";
           sha256 = "0pan68fr22xbj7a930y29527vpry3f07q3i9ya4fp6g7aawffsga";
@@ -27,7 +27,7 @@ stdenv.mkDerivation rec {
         else
         releasePath
     else if stdenv.hostPlatform.system == "i686-linux" then
-        if builtins.isNull releasePath then
+        if releasePath == null then
         fetchurl {
           url = "http://files.renoise.com/demo/Renoise_${urlVersion version}_Demo_x86.tar.bz2";
           sha256 = "1lccjj4k8hpqqxxham5v01v2rdwmx3c5kgy1p9lqvzqma88k4769";
diff --git a/pkgs/applications/networking/mailreaders/lumail/default.nix b/pkgs/applications/networking/mailreaders/lumail/default.nix
index 79deab46912b..bc0918737dd5 100644
--- a/pkgs/applications/networking/mailreaders/lumail/default.nix
+++ b/pkgs/applications/networking/mailreaders/lumail/default.nix
@@ -10,7 +10,7 @@ let
   alternativeConfig = builtins.toFile "lumail2.lua"
     (builtins.readFile alternativeGlobalConfigFilePath);
 
-  globalConfig = if isNull alternativeGlobalConfigFilePath then ''
+  globalConfig = if alternativeGlobalConfigFilePath == null then ''
     mkdir -p $out/etc/lumail2
     cp global.config.lua $out/etc/lumail2.lua
     for n in ./lib/*.lua; do
diff --git a/pkgs/applications/science/math/cplex/default.nix b/pkgs/applications/science/math/cplex/default.nix
index dae5e1b76d35..dc0e9ea1aa5d 100644
--- a/pkgs/applications/science/math/cplex/default.nix
+++ b/pkgs/applications/science/math/cplex/default.nix
@@ -12,7 +12,7 @@ stdenv.mkDerivation rec {
   version = "128";
   
   src =
-    if builtins.isNull releasePath then
+    if releasePath == null then
       throw ''
         This nix expression requires that the cplex installer is already
         downloaded to your machine. Get it from IBM: 
diff --git a/pkgs/applications/science/math/sage/sage-with-env.nix b/pkgs/applications/science/math/sage/sage-with-env.nix
index 18060f342a92..5bb7eda47d5d 100644
--- a/pkgs/applications/science/math/sage/sage-with-env.nix
+++ b/pkgs/applications/science/math/sage/sage-with-env.nix
@@ -59,7 +59,7 @@ let
 
   # return the names of all dependencies in the transitive closure
   transitiveClosure = dep:
-  if isNull dep then
+  if dep == null then
     # propagatedBuildInputs might contain null
     # (although that might be considered a programming error in the derivation)
     []
diff --git a/pkgs/applications/video/kodi/plugins.nix b/pkgs/applications/video/kodi/plugins.nix
index 91fd7eab1268..b9976e540196 100644
--- a/pkgs/applications/video/kodi/plugins.nix
+++ b/pkgs/applications/video/kodi/plugins.nix
@@ -59,7 +59,7 @@ let self = rec {
     extraRuntimeDependencies = [ ];
 
     installPhase = ''
-      ${if isNull sourceDir then "" else "cd $src/$sourceDir"}
+      ${if sourceDir == null then "" else "cd $src/$sourceDir"}
       d=$out${pluginDir}/${namespace}
       mkdir -p $d
       sauce="."