about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorAndreas Rammhold <andreas@rammhold.de>2018-05-13 19:19:55 +0200
committerAndreas Rammhold <andreas@rammhold.de>2018-05-16 21:08:19 +0200
commit780d122d727423542213b202f5efe8d1cc3d3a2a (patch)
tree842b348befcfc361ec4785a078b17a4cfb6d12f5 /pkgs/applications
parent16b6f53910f19b84c5d8c5fb58a8ce958fc8a7d3 (diff)
downloadnixlib-780d122d727423542213b202f5efe8d1cc3d3a2a.tar
nixlib-780d122d727423542213b202f5efe8d1cc3d3a2a.tar.gz
nixlib-780d122d727423542213b202f5efe8d1cc3d3a2a.tar.bz2
nixlib-780d122d727423542213b202f5efe8d1cc3d3a2a.tar.lz
nixlib-780d122d727423542213b202f5efe8d1cc3d3a2a.tar.xz
nixlib-780d122d727423542213b202f5efe8d1cc3d3a2a.tar.zst
nixlib-780d122d727423542213b202f5efe8d1cc3d3a2a.zip
firefox: fix build on aarch64 with version >= 60
The firefox build fails with an error referring to ssse2 which doesn't
exist on aarch64.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/browsers/firefox/common.nix4
-rw-r--r--pkgs/applications/networking/browsers/firefox/packages.nix10
2 files changed, 11 insertions, 3 deletions
diff --git a/pkgs/applications/networking/browsers/firefox/common.nix b/pkgs/applications/networking/browsers/firefox/common.nix
index 5b88a61afce6..9a3da4307146 100644
--- a/pkgs/applications/networking/browsers/firefox/common.nix
+++ b/pkgs/applications/networking/browsers/firefox/common.nix
@@ -28,7 +28,9 @@
 # WARNING: NEVER set any of the options below to `true` by default.
 # Set to `privacySupport` or `false`.
 
-, webrtcSupport ? !privacySupport
+# webrtcSupport breaks the aarch64 build on version >= 60.
+# https://bugzilla.mozilla.org/show_bug.cgi?id=1434589
+, webrtcSupport ? (if lib.versionAtLeast version "60" && stdenv.isAarch64 then false else !privacySupport)
 , geolocationSupport ? !privacySupport
 , googleAPISupport ? geolocationSupport
 , crashreporterSupport ? false
diff --git a/pkgs/applications/networking/browsers/firefox/packages.nix b/pkgs/applications/networking/browsers/firefox/packages.nix
index 33bdb62929e6..35a818dd6c96 100644
--- a/pkgs/applications/networking/browsers/firefox/packages.nix
+++ b/pkgs/applications/networking/browsers/firefox/packages.nix
@@ -12,6 +12,12 @@ let
     ./fix-pa-context-connect-retval.patch
   ];
 
+  firefox60_aarch64_skia_patch = fetchpatch {
+      name = "aarch64-skia.patch";
+      url = https://src.fedoraproject.org/rpms/firefox/raw/8cff86d95da3190272d1beddd45b41de3148f8ef/f/build-aarch64-skia.patch;
+      sha256 = "11acb0ms4jrswp7268nm2p8g8l4lv8zc666a5bqjbb09x9k6b78k";
+  };
+
 in
 
 rec {
@@ -26,7 +32,7 @@ rec {
 
     patches = nixpkgsPatches ++ [
       ./no-buildconfig.patch
-    ];
+    ] ++ lib.optional stdenv.isAarch64 firefox60_aarch64_skia_patch;
 
     meta = {
       description = "A web browser built from Firefox source tree";
@@ -68,7 +74,7 @@ rec {
 
     patches = nixpkgsPatches ++ [
       ./no-buildconfig.patch
-    ];
+    ] ++ lib.optional stdenv.isAarch64 firefox60_aarch64_skia_patch;
 
     meta = firefox.meta // {
       description = "A web browser built from Firefox Extended Support Release source tree";