about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-09-15 12:16:44 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-09-15 12:16:49 -0700
commit773b4deb7c5c6300f23f2ec2db4751e40f6520fa (patch)
tree45e1caaa95b76b129efe46e8c048be03c91f3baf /pkgs/applications
parent316a09377d12b29764b5daf51e0df8986a5fe175 (diff)
parenta6f6c0eeeb45ad122022366724e396955f0f775b (diff)
downloadnixlib-773b4deb7c5c6300f23f2ec2db4751e40f6520fa.tar
nixlib-773b4deb7c5c6300f23f2ec2db4751e40f6520fa.tar.gz
nixlib-773b4deb7c5c6300f23f2ec2db4751e40f6520fa.tar.bz2
nixlib-773b4deb7c5c6300f23f2ec2db4751e40f6520fa.tar.lz
nixlib-773b4deb7c5c6300f23f2ec2db4751e40f6520fa.tar.xz
nixlib-773b4deb7c5c6300f23f2ec2db4751e40f6520fa.tar.zst
nixlib-773b4deb7c5c6300f23f2ec2db4751e40f6520fa.zip
Merge commit 'a6f6c0e' into master.upstream
This is a partial merge of staging where we have up to date binaries for
all packages.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/codeblocks/default.nix4
-rw-r--r--pkgs/applications/misc/terminal-notifier/default.nix6
-rw-r--r--pkgs/applications/networking/copy-com/default.nix2
-rw-r--r--pkgs/applications/networking/dropbox/default.nix4
-rw-r--r--pkgs/applications/office/libreoffice/default.nix4
-rw-r--r--pkgs/applications/science/logic/otter/default.nix6
-rw-r--r--pkgs/applications/science/math/content/default.nix2
-rw-r--r--pkgs/applications/science/math/mathematica/9.nix2
-rw-r--r--pkgs/applications/science/math/mathematica/default.nix2
-rw-r--r--pkgs/applications/video/gnash/default.nix1
10 files changed, 23 insertions, 10 deletions
diff --git a/pkgs/applications/editors/codeblocks/default.nix b/pkgs/applications/editors/codeblocks/default.nix
index 750234b6399f..53b7b5750a04 100644
--- a/pkgs/applications/editors/codeblocks/default.nix
+++ b/pkgs/applications/editors/codeblocks/default.nix
@@ -23,6 +23,10 @@ stdenv.mkDerivation rec {
   configureFlags = [ "--enable-pch=no" ]
     ++ optional contribPlugins "--with-contrib-plugins";
 
+  # Fix boost 1.59 compat
+  # Try removing in the next version
+  CPPFLAGS = "-DBOOST_ERROR_CODE_HEADER_ONLY -DBOOST_SYSTEM_NO_DEPRECATED";
+
   meta = with stdenv.lib; {
     maintainers = [ maintainers.linquize ];
     platforms = platforms.all;
diff --git a/pkgs/applications/misc/terminal-notifier/default.nix b/pkgs/applications/misc/terminal-notifier/default.nix
index 946556140232..2afebec9ee36 100644
--- a/pkgs/applications/misc/terminal-notifier/default.nix
+++ b/pkgs/applications/misc/terminal-notifier/default.nix
@@ -16,7 +16,11 @@ stdenv.mkDerivation rec {
     mkdir -p $out/Applications
     mkdir -p $out/bin
     cp -r terminal-notifier.app $out/Applications
-    ln -s $out/Applications/terminal-notifier.app/Contents/MacOS/terminal-notifier $out/bin/terminal-notifier
+    cat >$out/bin/terminal-notifier <<EOF
+    cd $out/Applications/terminal-notifier.app
+    exec ./Contents/MacOS/terminal-notifier
+    EOF
+    chmod +x $out/bin/terminal-notifier
   '';
 
   meta = with lib; {
diff --git a/pkgs/applications/networking/copy-com/default.nix b/pkgs/applications/networking/copy-com/default.nix
index 7dd2702325b2..968218309ed7 100644
--- a/pkgs/applications/networking/copy-com/default.nix
+++ b/pkgs/applications/networking/copy-com/default.nix
@@ -52,7 +52,7 @@ in stdenv.mkDerivation {
 
     RPATH=${libPaths}:$out/${appdir}
     echo "Updating rpaths to $RPATH in:"
-    find "$out/${appdir}" -type f -a -perm /0100 \
+    find "$out/${appdir}" -type f -a -perm -0100 \
       -print -exec patchelf --force-rpath --set-rpath "$RPATH" {} \;
   '';
 
diff --git a/pkgs/applications/networking/dropbox/default.nix b/pkgs/applications/networking/dropbox/default.nix
index 3fa6fb51ee14..0af5dfba3f24 100644
--- a/pkgs/applications/networking/dropbox/default.nix
+++ b/pkgs/applications/networking/dropbox/default.nix
@@ -101,12 +101,12 @@ in stdenv.mkDerivation {
     rm "$out/${appdir}/qt.conf"
     rm -fr "$out/${appdir}/plugins"
 
-    find "$out/${appdir}" -type f -a -perm /0100 \
+    find "$out/${appdir}" -type f -a -perm -0100 \
       -print -exec patchelf --set-interpreter ${stdenv.glibc}/lib/${interpreter} {} \;
 
     RPATH=${ldpath}:${gcc.cc}/lib:$out/${appdir}
     echo "updating rpaths to: $RPATH"
-    find "$out/${appdir}" -type f -a -perm /0100 \
+    find "$out/${appdir}" -type f -a -perm -0100 \
       -print -exec patchelf --force-rpath --set-rpath "$RPATH" {} \;
 
     mkdir -p "$out/share/applications"
diff --git a/pkgs/applications/office/libreoffice/default.nix b/pkgs/applications/office/libreoffice/default.nix
index 14e8cc0048ee..f1adef86dc94 100644
--- a/pkgs/applications/office/libreoffice/default.nix
+++ b/pkgs/applications/office/libreoffice/default.nix
@@ -86,6 +86,10 @@ in stdenv.mkDerivation rec {
   QT4DIR = qt4;
   KDE4DIR = kde4.kdelibs;
 
+  # Fix boost 1.59 compat
+  # Try removing in the next version
+  CPPFLAGS = "-DBOOST_ERROR_CODE_HEADER_ONLY -DBOOST_SYSTEM_NO_DEPRECATED";
+
   preConfigure = ''
     configureFlagsArray=(
       "--with-parallelism=$NIX_BUILD_CORES"
diff --git a/pkgs/applications/science/logic/otter/default.nix b/pkgs/applications/science/logic/otter/default.nix
index 653c5dad03f7..398f6c9a3e22 100644
--- a/pkgs/applications/science/logic/otter/default.nix
+++ b/pkgs/applications/science/logic/otter/default.nix
@@ -20,9 +20,9 @@ stdenv.mkDerivation {
   buildPhase = ''
     find . -name Makefile | xargs sed -i -e "s@/bin/rm@$(type -P rm)@g"
     find . -name Makefile | xargs sed -i -e "s@/bin/mv@$(type -P mv)@g"
-    find . -perm +111 -type f | xargs sed -i -e "s@/bin/csh@$(type -P csh)@g"
-    find . -perm +111 -type f | xargs sed -i -e "s@/bin/rm@$(type -P rm)@g"
-    find . -perm +111 -type f | xargs sed -i -e "s@/bin/mv@$(type -P mv)@g"
+    find . -perm -0100 -type f | xargs sed -i -e "s@/bin/csh@$(type -P csh)@g"
+    find . -perm -0100 -type f | xargs sed -i -e "s@/bin/rm@$(type -P rm)@g"
+    find . -perm -0100 -type f | xargs sed -i -e "s@/bin/mv@$(type -P mv)@g"
 
     sed -i -e "s/^XLIBS *=.*/XLIBS=-lXaw -lXt -lX11/" source/formed/Makefile 
 
diff --git a/pkgs/applications/science/math/content/default.nix b/pkgs/applications/science/math/content/default.nix
index 57fdb525719b..48e20d427d15 100644
--- a/pkgs/applications/science/math/content/default.nix
+++ b/pkgs/applications/science/math/content/default.nix
@@ -82,7 +82,7 @@ rec {
     find . -name '*.so' -exec cp '{}' $out/lib ';'
     find . -name '*.txt' -exec cp '{}' $out/share/${name}/doc ';'
     find . -name '*.hlp' -exec cp '{}' $out/share/${name}/doc ';'
-    find . -perm +111 -a ! -name '*.*' -exec cp '{}' $out/bin ';'
+    find . -perm -0100 -a ! -name '*.*' -exec cp '{}' $out/bin ';'
     cp -r . $out/share/${name}/build-snapshot
   '') ["buildContent" "defEnsureDir" "minInit"];
       
diff --git a/pkgs/applications/science/math/mathematica/9.nix b/pkgs/applications/science/math/mathematica/9.nix
index c9357d7352f0..3c7f758d91bc 100644
--- a/pkgs/applications/science/math/mathematica/9.nix
+++ b/pkgs/applications/science/math/mathematica/9.nix
@@ -86,7 +86,7 @@ stdenv.mkDerivation rec {
 
   preFixup = ''
     echo "=== PatchElfing away ==="
-    find $out/libexec/Mathematica/SystemFiles -type f -perm +100 | while read f; do
+    find $out/libexec/Mathematica/SystemFiles -type f -perm -0100 | while read f; do
       type=$(readelf -h "$f" 2>/dev/null | grep 'Type:' | sed -e 's/ *Type: *\([A-Z]*\) (.*/\1/')
       if [ -z "$type" ]; then
         :
diff --git a/pkgs/applications/science/math/mathematica/default.nix b/pkgs/applications/science/math/mathematica/default.nix
index 5fc704178836..39f2409a987c 100644
--- a/pkgs/applications/science/math/mathematica/default.nix
+++ b/pkgs/applications/science/math/mathematica/default.nix
@@ -96,7 +96,7 @@ stdenv.mkDerivation rec {
 
   preFixup = ''
     echo "=== PatchElfing away ==="
-    find $out/libexec/Mathematica/SystemFiles -type f -perm +100 | while read f; do
+    find $out/libexec/Mathematica/SystemFiles -type f -perm -0100 | while read f; do
       type=$(readelf -h "$f" 2>/dev/null | grep 'Type:' | sed -e 's/ *Type: *\([A-Z]*\) (.*/\1/')
       if [ -z "$type" ]; then
         :
diff --git a/pkgs/applications/video/gnash/default.nix b/pkgs/applications/video/gnash/default.nix
index fc773211f69b..5a170047e8fc 100644
--- a/pkgs/applications/video/gnash/default.nix
+++ b/pkgs/applications/video/gnash/default.nix
@@ -117,5 +117,6 @@ stdenv.mkDerivation rec {
 
     maintainers = [ ];
     platforms = stdenv.lib.platforms.gnu;
+    broken = true;
   };
 } // {mozillaPlugin = "/plugins";}