about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2016-05-22 13:41:15 +0200
committerVladimír Čunát <vcunat@gmail.com>2016-05-22 13:41:15 +0200
commit73f1f5eb3969743fe459e7cc36cfb766c7f5318a (patch)
tree3b55d851edb0ea73b65cb9ac5b53f5e13cd556dd /pkgs/applications
parent4c646dd6cb608a8e9f7d9f70dddb85fd4b076543 (diff)
downloadnixlib-73f1f5eb3969743fe459e7cc36cfb766c7f5318a.tar
nixlib-73f1f5eb3969743fe459e7cc36cfb766c7f5318a.tar.gz
nixlib-73f1f5eb3969743fe459e7cc36cfb766c7f5318a.tar.bz2
nixlib-73f1f5eb3969743fe459e7cc36cfb766c7f5318a.tar.lz
nixlib-73f1f5eb3969743fe459e7cc36cfb766c7f5318a.tar.xz
nixlib-73f1f5eb3969743fe459e7cc36cfb766c7f5318a.tar.zst
nixlib-73f1f5eb3969743fe459e7cc36cfb766c7f5318a.zip
imagemagick: split dev output to fix #9604
Also fixup references to imagemagick.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/emacs-modes/emacs-w3m/default.nix6
-rw-r--r--pkgs/applications/graphics/ImageMagick/default.nix16
-rw-r--r--pkgs/applications/misc/calibre/default.nix4
-rw-r--r--pkgs/applications/networking/instant-messengers/pidgin-plugins/pidgin-latex/default.nix2
-rw-r--r--pkgs/applications/window-managers/i3/lock-fancy.nix2
5 files changed, 18 insertions, 12 deletions
diff --git a/pkgs/applications/editors/emacs-modes/emacs-w3m/default.nix b/pkgs/applications/editors/emacs-modes/emacs-w3m/default.nix
index 850041ccfc77..b4fb8d1937df 100644
--- a/pkgs/applications/editors/emacs-modes/emacs-w3m/default.nix
+++ b/pkgs/applications/editors/emacs-modes/emacs-w3m/default.nix
@@ -19,11 +19,11 @@ stdenv.mkDerivation rec {
   patchPhase = ''
     sed -i "w3m.el" \
         -e 's|defcustom w3m-command nil|defcustom w3m-command "${w3m}/bin/w3m"|g ;
-            s|(w3m-which-command "display")|"${imagemagick}/bin/display"|g'
+            s|(w3m-which-command "display")|"${imagemagick.out}/bin/display"|g'
 
     sed -i "w3m-image.el" \
-        -e 's|(w3m-which-command "convert")|"${imagemagick}/bin/convert"|g ;
-            s|(w3m-which-command "identify")|"${imagemagick}/bin/identify"|g'
+        -e 's|(w3m-which-command "convert")|"${imagemagick.out}/bin/convert"|g ;
+            s|(w3m-which-command "identify")|"${imagemagick.out}/bin/identify"|g'
   '';
 
   configureFlags = [
diff --git a/pkgs/applications/graphics/ImageMagick/default.nix b/pkgs/applications/graphics/ImageMagick/default.nix
index 9b17fbde7f5f..e73cc9024c61 100644
--- a/pkgs/applications/graphics/ImageMagick/default.nix
+++ b/pkgs/applications/graphics/ImageMagick/default.nix
@@ -43,7 +43,8 @@ stdenv.mkDerivation rec {
 
   patches = [ ./imagetragick.patch ] ++ cfg.patches;
 
-  outputs = [ "out" "doc" ];
+  outputs = [ "dev" "out" "doc" ]; # bin/ isn't really big
+  outputMan = "out"; # it's tiny
 
   enableParallelBuilding = true;
 
@@ -76,18 +77,23 @@ stdenv.mkDerivation rec {
     ;
 
   postInstall = ''
-
-    (cd "$out/include" && ln -s ImageMagick* ImageMagick)
+    (cd "$dev/include" && ln -s ImageMagick* ImageMagick)
+    moveToOutput "bin/*-config" "$dev"
+    moveToOutput "lib/ImageMagick-*/config-Q16" "$dev" # includes configure params
+    for file in "$dev"/bin/*-config; do
+      substituteInPlace "$file" --replace pkg-config \
+        "PKG_CONFIG_PATH='$dev/lib/pkgconfig' '${pkgconfig}/bin/pkg-config'"
+    done
   '' + lib.optionalString (ghostscript != null) ''
     for la in $out/lib/*.la; do
-      sed 's|-lgs|-L${ghostscript}/lib -lgs|' -i $la
+      sed 's|-lgs|-L${lib.getLib ghostscript}/lib -lgs|' -i $la
     done
   '';
 
   meta = with stdenv.lib; {
     homepage = http://www.imagemagick.org/;
     description = "A software suite to create, edit, compose, or convert bitmap images";
-    platforms = platforms.linux ++ [ "x86_64-darwin" ];
+    platforms = platforms.linux ++ platforms.darwin;
     maintainers = with maintainers; [ the-kenny wkennington ];
   };
 }
diff --git a/pkgs/applications/misc/calibre/default.nix b/pkgs/applications/misc/calibre/default.nix
index 46f4e8635a93..83b782e65d6f 100644
--- a/pkgs/applications/misc/calibre/default.nix
+++ b/pkgs/applications/misc/calibre/default.nix
@@ -47,8 +47,8 @@ stdenv.mkDerivation rec {
     export HOME=$TMPDIR/fakehome
     export POPPLER_INC_DIR=${poppler_utils.dev}/include/poppler
     export POPPLER_LIB_DIR=${poppler_utils.out}/lib
-    export MAGICK_INC=${imagemagick}/include/ImageMagick
-    export MAGICK_LIB=${imagemagick}/lib
+    export MAGICK_INC=${imagemagick.dev}/include/ImageMagick
+    export MAGICK_LIB=${imagemagick.out}/lib
     export FC_INC_DIR=${fontconfig.dev}/include/fontconfig
     export FC_LIB_DIR=${fontconfig.lib}/lib
     export PODOFO_INC_DIR=${podofo}/include/podofo
diff --git a/pkgs/applications/networking/instant-messengers/pidgin-plugins/pidgin-latex/default.nix b/pkgs/applications/networking/instant-messengers/pidgin-plugins/pidgin-latex/default.nix
index 4a5522039c84..41a1ea3c3e7c 100644
--- a/pkgs/applications/networking/instant-messengers/pidgin-plugins/pidgin-latex/default.nix
+++ b/pkgs/applications/networking/instant-messengers/pidgin-plugins/pidgin-latex/default.nix
@@ -19,7 +19,7 @@ stdenv.mkDerivation {
   '';
 
   passthru = {
-    wrapArgs = "--prefix PATH ':' ${texLive}/bin:${imagemagick}/bin";
+    wrapArgs = "--prefix PATH ':' ${texLive}/bin:${imagemagick.out}/bin";
   };
 
   meta = with stdenv.lib; {
diff --git a/pkgs/applications/window-managers/i3/lock-fancy.nix b/pkgs/applications/window-managers/i3/lock-fancy.nix
index ecf08a529d17..ce4517fe86aa 100644
--- a/pkgs/applications/window-managers/i3/lock-fancy.nix
+++ b/pkgs/applications/window-managers/i3/lock-fancy.nix
@@ -17,7 +17,7 @@ stdenv.mkDerivation rec {
     sed -i -e "s|dirname|${coreutils}/bin/dirname|" lock
     sed -i -e "s|rm |${coreutils}/bin/rm |" lock
     sed -i -e "s|scrot |${scrot}/bin/scrot |" lock
-    sed -i -e "s|convert |${imagemagick}/bin/convert |" lock
+    sed -i -e "s|convert |${imagemagick.out}/bin/convert |" lock
     sed -i -e "s|awk |${gawk}/bin/awk|" lock
     sed -i -e "s|i3lock |${i3lock-color}/bin/i3lock-color |" lock
   '';