about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2021-03-25 16:05:57 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2021-04-03 17:06:08 +0200
commit7368564f99e34b91a673274d8de0362cccc3f592 (patch)
tree264e01e696dfda46209ddf221159952ce20e79df /pkgs/applications
parentd8ed6258b46399d41f0877fa16f9740e43ea53a0 (diff)
downloadnixlib-7368564f99e34b91a673274d8de0362cccc3f592.tar
nixlib-7368564f99e34b91a673274d8de0362cccc3f592.tar.gz
nixlib-7368564f99e34b91a673274d8de0362cccc3f592.tar.bz2
nixlib-7368564f99e34b91a673274d8de0362cccc3f592.tar.lz
nixlib-7368564f99e34b91a673274d8de0362cccc3f592.tar.xz
nixlib-7368564f99e34b91a673274d8de0362cccc3f592.tar.zst
nixlib-7368564f99e34b91a673274d8de0362cccc3f592.zip
gurobi: stay with python2
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/math/gurobi/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/pkgs/applications/science/math/gurobi/default.nix b/pkgs/applications/science/math/gurobi/default.nix
index 6066d0325f54..2bfeaa005687 100644
--- a/pkgs/applications/science/math/gurobi/default.nix
+++ b/pkgs/applications/science/math/gurobi/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, lib, fetchurl, autoPatchelfHook, python }:
+{ stdenv, lib, fetchurl, autoPatchelfHook, python2 }:
 
 let
   majorVersion = "8.1";
@@ -14,7 +14,9 @@ in stdenv.mkDerivation rec {
   sourceRoot = "gurobi${builtins.replaceStrings ["."] [""] version}/linux64";
 
   nativeBuildInputs = [ autoPatchelfHook ];
-  buildInputs = [ (python.withPackages (ps: [ ps.gurobipy ])) ];
+  buildInputs = [ (python2.withPackages (ps: [ ps.gurobipy ])) ];
+
+  strictDeps = true;
 
   buildPhase = ''
     cd src/build