about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2020-04-07 13:41:55 +0200
committerGitHub <noreply@github.com>2020-04-07 13:41:55 +0200
commit718305392f0e66ac4693eaaf66e49fce8a3ae744 (patch)
tree4d38f22491abdacf3dcff50638ce61af854829c6 /pkgs/applications
parente2b327cd4e84dfaa8b77a612ae22c7998f0bc084 (diff)
parent617fa430d7667b72ae72146226b3dbef7cede598 (diff)
downloadnixlib-718305392f0e66ac4693eaaf66e49fce8a3ae744.tar
nixlib-718305392f0e66ac4693eaaf66e49fce8a3ae744.tar.gz
nixlib-718305392f0e66ac4693eaaf66e49fce8a3ae744.tar.bz2
nixlib-718305392f0e66ac4693eaaf66e49fce8a3ae744.tar.lz
nixlib-718305392f0e66ac4693eaaf66e49fce8a3ae744.tar.xz
nixlib-718305392f0e66ac4693eaaf66e49fce8a3ae744.tar.zst
nixlib-718305392f0e66ac4693eaaf66e49fce8a3ae744.zip
Merge pull request #84384 from euank/pkg/k3s-update
k3s: remove extra buildInputs
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/cluster/k3s/default.nix24
1 files changed, 12 insertions, 12 deletions
diff --git a/pkgs/applications/networking/cluster/k3s/default.nix b/pkgs/applications/networking/cluster/k3s/default.nix
index 316b86efe613..0fd581438681 100644
--- a/pkgs/applications/networking/cluster/k3s/default.nix
+++ b/pkgs/applications/networking/cluster/k3s/default.nix
@@ -1,7 +1,7 @@
 { stdenv, lib, makeWrapper, socat, iptables, iproute, bridge-utils
 , conntrack-tools, buildGoPackage, git, runc, libseccomp, pkgconfig
-, autoPatchelfHook, breakpointHook, ethtool, utillinux, ipset
-, fetchFromGitHub, fetchurl, fetchzip, fetchgit
+, ethtool, utillinux, ipset, fetchFromGitHub, fetchurl, fetchzip
+, fetchgit
 }:
 
 with lib;
@@ -64,10 +64,10 @@ let
     };
 
     meta = {
-      description = "k3s-cni-plugins";
+      description = "CNI plugins, as patched by rancher for k3s";
       license = licenses.asl20;
       homepage = https://k3s.io;
-      maintainers = [];
+      maintainers = [ maintainers.euank ];
       platforms = platforms.linux;
     };
   };
@@ -76,7 +76,7 @@ let
   k3sRepo = fetchgit {
     url = "https://github.com/rancher/k3s";
     rev = "v${k3sVersion}";
-    leaveDotGit = true; # for version / build date below
+    leaveDotGit = true; # ./scripts/version.sh depends on git
     sha256 = "0qahyc0mf9glxj49va6d20mcncqg4svfic2iz8b1lqid5c4g68mm";
   };
   # Stage 1 of the k3s build:
@@ -110,8 +110,8 @@ let
 
     patches = [ ./patches/00-k3s.patch ];
 
-    nativeBuildInputs = [ pkgconfig autoPatchelfHook breakpointHook ];
-    buildInputs = [ git runc libseccomp ];
+    nativeBuildInputs = [ git pkgconfig ];
+    buildInputs = [ libseccomp ];
 
     buildPhase = ''
       pushd go/src/${goPackagePath}
@@ -136,7 +136,7 @@ let
       description = "The various binaries that get packaged into the final k3s binary.";
       license = licenses.asl20;
       homepage = https://k3s.io;
-      maintainers = [];
+      maintainers = [ maintainers.euank ];
       platforms = platforms.linux;
     };
   };
@@ -150,8 +150,8 @@ let
 
     patches = [ ./patches/00-k3s.patch ];
 
-    nativeBuildInputs = [ pkgconfig autoPatchelfHook breakpointHook ];
-    buildInputs = [ git k3sBuildStage1 ];
+    nativeBuildInputs = [ git pkgconfig ];
+    buildInputs = [ k3sBuildStage1 k3sPlugins runc ];
 
     # In order to build the thick k3s binary (which is what
     # ./scripts/package-cli does), we need to get all the binaries that script
@@ -191,7 +191,7 @@ let
       description = "The k3s go binary which is used by the final wrapped output below.";
       license = licenses.asl20;
       homepage = https://k3s.io;
-      maintainers = [];
+      maintainers = [ maintainers.euank ];
       platforms = platforms.linux;
     };
   };
@@ -229,7 +229,7 @@ stdenv.mkDerivation rec {
       description = "A lightweight Kubernetes distribution.";
       license = licenses.asl20;
       homepage = https://k3s.io;
-      maintainers = with maintainers; [ euank ];
+      maintainers = [ maintainers.euank ];
       platforms = platforms.linux;
     };
 }