about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorNick Novitski <github@nicknovitski.com>2019-07-22 05:02:47 -0700
committerzimbatm <zimbatm@zimbatm.com>2019-07-22 12:02:47 +0000
commit7136e0d0a6f61734994c566e2cc72fd75733b873 (patch)
treefcaeaea68f596a81fb885790ce87c3aac4bd52ba /pkgs/applications
parentb24841dd2260516bfde0b9029619a0f9ef87e97c (diff)
downloadnixlib-7136e0d0a6f61734994c566e2cc72fd75733b873.tar
nixlib-7136e0d0a6f61734994c566e2cc72fd75733b873.tar.gz
nixlib-7136e0d0a6f61734994c566e2cc72fd75733b873.tar.bz2
nixlib-7136e0d0a6f61734994c566e2cc72fd75733b873.tar.lz
nixlib-7136e0d0a6f61734994c566e2cc72fd75733b873.tar.xz
nixlib-7136e0d0a6f61734994c566e2cc72fd75733b873.tar.zst
nixlib-7136e0d0a6f61734994c566e2cc72fd75733b873.zip
bundlerUpdateScript: init and use (#64822)
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/graphics/image_optim/default.nix8
-rwxr-xr-xpkgs/applications/graphics/image_optim/update.sh9
-rw-r--r--pkgs/applications/misc/doing/default.nix8
-rw-r--r--pkgs/applications/misc/gollum/default.nix6
-rw-r--r--pkgs/applications/misc/pt/default.nix6
-rw-r--r--pkgs/applications/misc/taskjuggler/default.nix6
-rw-r--r--pkgs/applications/networking/cluster/terraform-landscape/default.nix7
-rw-r--r--pkgs/applications/networking/mailreaders/sup/default.nix10
-rw-r--r--pkgs/applications/office/ledger-web/default.nix6
-rw-r--r--pkgs/applications/office/timetrap/default.nix6
-rw-r--r--pkgs/applications/version-management/git-and-tools/bitbucket-server-cli/default.nix6
-rw-r--r--pkgs/applications/version-management/git-and-tools/git-fame/default.nix6
12 files changed, 44 insertions, 40 deletions
diff --git a/pkgs/applications/graphics/image_optim/default.nix b/pkgs/applications/graphics/image_optim/default.nix
index c3dffee3aa8d..385f9825e46f 100644
--- a/pkgs/applications/graphics/image_optim/default.nix
+++ b/pkgs/applications/graphics/image_optim/default.nix
@@ -1,4 +1,4 @@
-{ lib, bundlerApp, ruby, makeWrapper,
+{ lib, bundlerApp, bundlerUpdateScript, makeWrapper,
   withPngcrush ? true,       pngcrush ? null,
   withPngout ? true,         pngout ? null,
   withAdvpng ? true,         advancecomp ? null,
@@ -45,8 +45,6 @@ bundlerApp {
   pname = "image_optim";
   gemdir = ./.;
 
-  inherit ruby;
-
   exes = [ "image_optim" ];
 
   buildInputs = [ makeWrapper ];
@@ -56,11 +54,13 @@ bundlerApp {
       --prefix PATH : ${makeBinPath optionalDepsPath}
   '';
 
+  passthru.updateScript = bundlerUpdateScript "image_optim";
+
   meta = with lib; {
     description = "Command line tool and ruby interface to optimize (lossless compress, optionally lossy) jpeg, png, gif and svg images using external utilities (advpng, gifsicle, jhead, jpeg-recompress, jpegoptim, jpegrescan, jpegtran, optipng, pngcrush, pngout, pngquant, svgo)";
     homepage    = https://github.com/toy/image_optim;
     license     = licenses.mit;
-    maintainers = with maintainers; [ srghma ];
+    maintainers = with maintainers; [ srghma nicknovitski ];
     platforms   = platforms.all;
   };
 }
diff --git a/pkgs/applications/graphics/image_optim/update.sh b/pkgs/applications/graphics/image_optim/update.sh
deleted file mode 100755
index 8afd7f90436d..000000000000
--- a/pkgs/applications/graphics/image_optim/update.sh
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/usr/bin/env nix-shell
-#!nix-shell -i bash -p bundix bundler
-
-SCRIPT_DIR=$(dirname "$(readlink -f "$BASH_SOURCE")")
-
-cd $SCRIPT_DIR
-
-bundle lock --update
-bundix
diff --git a/pkgs/applications/misc/doing/default.nix b/pkgs/applications/misc/doing/default.nix
index 9ae2ea41d831..20c802a1cbdf 100644
--- a/pkgs/applications/misc/doing/default.nix
+++ b/pkgs/applications/misc/doing/default.nix
@@ -1,8 +1,6 @@
-{ lib, bundlerEnv, ruby
+{ lib, bundlerEnv, ruby, bundlerUpdateScript
 }:
 
-# Bundix:
-# nix-shell -p bundix zlib
 bundlerEnv rec {
   pname = "doing";
   version = (import ./gemset.nix).doing.version;
@@ -10,6 +8,8 @@ bundlerEnv rec {
   inherit ruby;
   gemdir = ./.;
 
+  passthru.updateScript = bundlerUpdateScript "doing";
+
   meta = with lib; {
     description = "A command line tool for keeping track of what you’re doing and tracking what you’ve done.";
     longDescription = ''
@@ -19,7 +19,7 @@ bundlerEnv rec {
     '';
     homepage    = https://brettterpstra.com/projects/doing/;
     license     = licenses.mit;
-    maintainers = with maintainers; [ ktf ];
+    maintainers = with maintainers; [ ktf nicknovitski ];
     platforms   = platforms.unix;
   };
 }
diff --git a/pkgs/applications/misc/gollum/default.nix b/pkgs/applications/misc/gollum/default.nix
index 4a0a4e38a61b..62f2d7a069d9 100644
--- a/pkgs/applications/misc/gollum/default.nix
+++ b/pkgs/applications/misc/gollum/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, bundlerEnv, ruby, makeWrapper
+{ stdenv, bundlerEnv, ruby, makeWrapper, bundlerUpdateScript
 , git }:
 
 stdenv.mkDerivation rec {
@@ -23,11 +23,13 @@ stdenv.mkDerivation rec {
       --prefix PATH ":" ${stdenv.lib.makeBinPath [ git ]}
   '';
 
+  passthru.updateScript = bundlerUpdateScript "gollum";
+
   meta = with stdenv.lib; {
     description = "A simple, Git-powered wiki";
     homepage = https://github.com/gollum/gollum;
     license = licenses.mit;
-    maintainers = with maintainers; [ jgillich primeos ];
+    maintainers = with maintainers; [ jgillich primeos nicknovitski ];
     platforms = platforms.unix;
   };
 }
diff --git a/pkgs/applications/misc/pt/default.nix b/pkgs/applications/misc/pt/default.nix
index 6f9078bb50a7..f5504721987a 100644
--- a/pkgs/applications/misc/pt/default.nix
+++ b/pkgs/applications/misc/pt/default.nix
@@ -1,15 +1,17 @@
-{ lib, bundlerApp }:
+{ lib, bundlerApp, bundlerUpdateScript }:
 
 bundlerApp {
   pname = "pt";
   gemdir = ./.;
   exes = [ "pt" ];
 
+  passthru.updateScript = bundlerUpdateScript "pt";
+
   meta = with lib; {
     description = "Minimalist command-line Pivotal Tracker client";
     homepage    = http://www.github.com/raul/pt;
     license     = licenses.mit;
-    maintainers = with maintainers; [ ebzzry manveru ];
+    maintainers = with maintainers; [ ebzzry manveru nicknovitski ];
     platforms   = platforms.unix;
   };
 }
diff --git a/pkgs/applications/misc/taskjuggler/default.nix b/pkgs/applications/misc/taskjuggler/default.nix
index 1b3bacf71df8..838cc199a6ca 100644
--- a/pkgs/applications/misc/taskjuggler/default.nix
+++ b/pkgs/applications/misc/taskjuggler/default.nix
@@ -1,4 +1,4 @@
-{ lib, bundlerApp }:
+{ lib, bundlerApp, bundlerUpdateScript }:
 
 bundlerApp {
   pname = "taskjuggler";
@@ -9,11 +9,13 @@ bundlerApp {
     "tj3ts_receiver" "tj3ts_sender" "tj3ts_summary" "tj3webd"
   ];
 
+  passthru.updateScript = bundlerUpdateScript "taskjuggler";
+
   meta = with lib; {
     description = "A modern and powerful project management tool";
     homepage    = http://taskjuggler.org/;
     license     = licenses.gpl2;
     platforms   = platforms.unix;
-    maintainers = [ maintainers.manveru ];
+    maintainers = with maintainers; [ manveru nicknovitski ];
   };
 }
diff --git a/pkgs/applications/networking/cluster/terraform-landscape/default.nix b/pkgs/applications/networking/cluster/terraform-landscape/default.nix
index 1380005a1c15..6973938b60de 100644
--- a/pkgs/applications/networking/cluster/terraform-landscape/default.nix
+++ b/pkgs/applications/networking/cluster/terraform-landscape/default.nix
@@ -1,17 +1,18 @@
-{ lib, bundlerApp, ruby }:
+{ lib, bundlerApp, bundlerUpdateScript }:
 
 bundlerApp {
   pname = "terraform_landscape";
 
-  inherit ruby;
   gemdir = ./.;
   exes = [ "landscape" ];
 
+  passthru.updateScript = bundlerUpdateScript "terraform-landscape";
+
   meta = with lib; {
     description = "Improve Terraform's plan output to be easier to read and understand";
     homepage    = https://github.com/coinbase/terraform-landscape;
     license     = with licenses; apsl20;
-    maintainers = with maintainers; [ mbode manveru ];
+    maintainers = with maintainers; [ mbode manveru nicknovitski ];
     platforms   = platforms.unix;
   };
 }
diff --git a/pkgs/applications/networking/mailreaders/sup/default.nix b/pkgs/applications/networking/mailreaders/sup/default.nix
index f7b7d6e8c3d8..ccd092ba63cc 100644
--- a/pkgs/applications/networking/mailreaders/sup/default.nix
+++ b/pkgs/applications/networking/mailreaders/sup/default.nix
@@ -1,8 +1,4 @@
-{ lib, bundlerApp }:
-
-# Updated with:
-# rm gemset.nix Gemfile.lock
-# nix-shell -p bundler bundix --run 'bundle lock && bundix'
+{ lib, bundlerApp, bundlerUpdateScript }:
 
 bundlerApp {
   pname = "sup";
@@ -20,11 +16,13 @@ bundlerApp {
     "sup-tweak-labels"
   ];
 
+  passthru.updateScript = bundlerUpdateScript "sup";
+
   meta = with lib; {
     description = "A curses threads-with-tags style email client";
     homepage    = http://sup-heliotrope.github.io;
     license     = licenses.gpl2;
-    maintainers = with maintainers; [ cstrahan lovek323 manveru ];
+    maintainers = with maintainers; [ cstrahan lovek323 manveru nicknovitski ];
     platforms   = platforms.unix;
   };
 }
diff --git a/pkgs/applications/office/ledger-web/default.nix b/pkgs/applications/office/ledger-web/default.nix
index 13c559cfac10..df8298579e8f 100644
--- a/pkgs/applications/office/ledger-web/default.nix
+++ b/pkgs/applications/office/ledger-web/default.nix
@@ -1,4 +1,4 @@
-{ lib, bundlerApp
+{ lib, bundlerApp, bundlerUpdateScript
 , withPostgresql ? true, postgresql
 , withSqlite ? false, sqlite
 }:
@@ -11,11 +11,13 @@ bundlerApp rec {
   buildInputs =    lib.optional withPostgresql postgresql
                 ++ lib.optional withSqlite sqlite;
 
+  passthru.updateScript = bundlerUpdateScript "ledger-web";
+
   meta = with lib; {
     description = "A web frontend to the Ledger CLI tool";
     homepage = https://github.com/peterkeen/ledger-web;
     license = licenses.mit;
-    maintainers = with maintainers; [ peterhoeg manveru ];
+    maintainers = with maintainers; [ peterhoeg manveru nicknovitski ];
     platforms = platforms.linux;
   };
 }
diff --git a/pkgs/applications/office/timetrap/default.nix b/pkgs/applications/office/timetrap/default.nix
index efeb23b3e83d..6d094ecb5dcc 100644
--- a/pkgs/applications/office/timetrap/default.nix
+++ b/pkgs/applications/office/timetrap/default.nix
@@ -1,15 +1,17 @@
-{ lib, bundlerApp }:
+{ lib, bundlerApp, bundlerUpdateScript }:
 
 bundlerApp {
   pname = "timetrap";
   gemdir = ./.;
   exes = [ "t" "timetrap" ];
 
+  passthru.updateScript = bundlerUpdateScript "timetrap";
+
   meta = with lib; {
     description = "A simple command line time tracker written in ruby";
     homepage    = https://github.com/samg/timetrap;
     license     = licenses.mit;
-    maintainers = with maintainers; [ jerith666 manveru ];
+    maintainers = with maintainers; [ jerith666 manveru nicknovitski ];
     platforms   = platforms.unix;
   };
 }
diff --git a/pkgs/applications/version-management/git-and-tools/bitbucket-server-cli/default.nix b/pkgs/applications/version-management/git-and-tools/bitbucket-server-cli/default.nix
index 341b50f0ef22..fda89e331809 100644
--- a/pkgs/applications/version-management/git-and-tools/bitbucket-server-cli/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/bitbucket-server-cli/default.nix
@@ -1,4 +1,4 @@
-{ lib, bundlerEnv, ruby }:
+{ lib, bundlerEnv, ruby, bundlerUpdateScript }:
 
 bundlerEnv rec {
   name = "bitbucket-server-cli-${version}";
@@ -9,11 +9,13 @@ bundlerEnv rec {
 
   pname = "atlassian-stash";
 
+  passthru.updateScript = bundlerUpdateScript "gitAndTools.bitbucket-server-cli";
+
   meta = with lib; {
     description = "A command line interface to interact with BitBucket Server (formerly Atlassian Stash)";
     homepage    = https://bitbucket.org/atlassian/bitbucket-server-cli;
     license     = licenses.mit;
-    maintainers = with maintainers; [ jgertm ];
+    maintainers = with maintainers; [ jgertm nicknovitski ];
     platforms   = platforms.unix;
   };
 }
diff --git a/pkgs/applications/version-management/git-and-tools/git-fame/default.nix b/pkgs/applications/version-management/git-and-tools/git-fame/default.nix
index 9ca7a67a53e7..2d6de24167bd 100644
--- a/pkgs/applications/version-management/git-and-tools/git-fame/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/git-fame/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, bundlerEnv, ruby }:
+{ stdenv, bundlerEnv, ruby, bundlerUpdateScript }:
 
 bundlerEnv rec {
   inherit ruby;
@@ -7,13 +7,15 @@ bundlerEnv rec {
 
   gemdir = ./.;
 
+  passthru.updateScript = bundlerUpdateScript "gitAndTools.git-fame";
+
   meta = with stdenv.lib; {
     description = ''
       A command-line tool that helps you summarize and pretty-print collaborators based on contributions
       '';
     homepage    = http://oleander.io/git-fame-rb;
     license     = licenses.mit;
-    maintainers = with maintainers; [ expipiplus1 ];
+    maintainers = with maintainers; [ expipiplus1 nicknovitski ];
     platforms   = platforms.unix;
   };
 }