about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2019-01-02 17:19:23 +0100
committerVladimír Čunát <vcunat@gmail.com>2019-01-02 17:19:23 +0100
commit70bff06140175862b2489301ff6595b4e84235e7 (patch)
treed90e25a694b718ddd1fc5b4b96c9c1f3a1f61091 /pkgs/applications
parentf603c1c52c585cd8835f6ec28d9b909064c3cd13 (diff)
parentde96413bbfc3deae4e81b48d7d973f836985c39c (diff)
downloadnixlib-70bff06140175862b2489301ff6595b4e84235e7.tar
nixlib-70bff06140175862b2489301ff6595b4e84235e7.tar.gz
nixlib-70bff06140175862b2489301ff6595b4e84235e7.tar.bz2
nixlib-70bff06140175862b2489301ff6595b4e84235e7.tar.lz
nixlib-70bff06140175862b2489301ff6595b4e84235e7.tar.xz
nixlib-70bff06140175862b2489301ff6595b4e84235e7.tar.zst
nixlib-70bff06140175862b2489301ff6595b4e84235e7.zip
Merge branch 'master' into staging
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/altcoins/namecoin.nix4
-rw-r--r--pkgs/applications/audio/faust/faustlive.nix4
-rw-r--r--pkgs/applications/editors/neovim/default.nix4
-rw-r--r--pkgs/applications/editors/neovim/neovim-remote.nix4
-rw-r--r--pkgs/applications/editors/sublime/3/packages.nix6
-rw-r--r--pkgs/applications/graphics/wings/default.nix29
-rw-r--r--pkgs/applications/misc/digitalbitbox/default.nix4
-rw-r--r--pkgs/applications/misc/fsv/default.nix47
-rw-r--r--pkgs/applications/misc/pwsafe/default.nix4
-rw-r--r--pkgs/applications/misc/rofi/config.patch54
-rw-r--r--pkgs/applications/misc/rofi/default.nix12
-rw-r--r--pkgs/applications/misc/translate-shell/default.nix4
-rw-r--r--pkgs/applications/misc/visidata/default.nix4
-rw-r--r--pkgs/applications/misc/xterm/default.nix4
-rw-r--r--pkgs/applications/networking/instant-messengers/fractal/default.nix43
-rw-r--r--pkgs/applications/networking/instant-messengers/toxic/default.nix4
-rw-r--r--pkgs/applications/office/gnucash/2.4.nix91
-rw-r--r--pkgs/applications/office/gnucash/2.6.nix116
-rw-r--r--pkgs/applications/office/trilium/default.nix58
-rw-r--r--pkgs/applications/science/electronics/kicad/default.nix4
-rw-r--r--pkgs/applications/version-management/git-and-tools/git-remote-gcrypt/default.nix4
-rw-r--r--pkgs/applications/version-management/gitkraken/default.nix11
22 files changed, 198 insertions, 317 deletions
diff --git a/pkgs/applications/altcoins/namecoin.nix b/pkgs/applications/altcoins/namecoin.nix
index 93f9faf833a1..4b8dc5525dc4 100644
--- a/pkgs/applications/altcoins/namecoin.nix
+++ b/pkgs/applications/altcoins/namecoin.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub, openssl, boost, libevent, autoreconfHook, db4, miniupnpc, eject, pkgconfig, qt4, protobuf, libqrencode, hexdump
+{ stdenv, fetchFromGitHub, openssl, boost, libevent, autoreconfHook, db4, miniupnpc, eject, pkgconfig, qt4, protobuf, qrencode, hexdump
 , withGui }:
 
 with stdenv.lib;
@@ -29,7 +29,7 @@ stdenv.mkDerivation rec {
   ] ++ optionals withGui [
     qt4
     protobuf
-    libqrencode
+    qrencode
   ];
 
   enableParallelBuilding = true;
diff --git a/pkgs/applications/audio/faust/faustlive.nix b/pkgs/applications/audio/faust/faustlive.nix
index b8ff73f2cb32..754c48070603 100644
--- a/pkgs/applications/audio/faust/faustlive.nix
+++ b/pkgs/applications/audio/faust/faustlive.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchFromGitHub
-, llvm, qt48Full, libqrencode, libmicrohttpd, libjack2, alsaLib, faust, curl
+, llvm, qt48Full, qrencode, libmicrohttpd, libjack2, alsaLib, faust, curl
 , bc, coreutils, which
 }:
 
@@ -14,7 +14,7 @@ stdenv.mkDerivation rec {
   };
 
   buildInputs = [
-    llvm qt48Full libqrencode libmicrohttpd libjack2 alsaLib faust curl
+    llvm qt48Full qrencode libmicrohttpd libjack2 alsaLib faust curl
     bc coreutils which
   ];
 
diff --git a/pkgs/applications/editors/neovim/default.nix b/pkgs/applications/editors/neovim/default.nix
index 26fc44cc6b11..99c3c62663c9 100644
--- a/pkgs/applications/editors/neovim/default.nix
+++ b/pkgs/applications/editors/neovim/default.nix
@@ -11,13 +11,13 @@ let
 
   neovim = stdenv.mkDerivation rec {
     name = "neovim-unwrapped-${version}";
-    version = "0.3.1";
+    version = "0.3.2";
 
     src = fetchFromGitHub {
       owner = "neovim";
       repo = "neovim";
       rev = "v${version}";
-      sha256 = "19jy9nr2ffscli6wsysqkdvqvh7sgkkwhzkw3yypfrvg4pj9rl56";
+      sha256 = "0gniick8jbra1xz5nmg9jyxr7dsnbh9n9bcbp7fq3acb2qnrd22y";
     };
 
     enableParallelBuilding = true;
diff --git a/pkgs/applications/editors/neovim/neovim-remote.nix b/pkgs/applications/editors/neovim/neovim-remote.nix
index 11566293c49b..d9b928f111ae 100644
--- a/pkgs/applications/editors/neovim/neovim-remote.nix
+++ b/pkgs/applications/editors/neovim/neovim-remote.nix
@@ -4,14 +4,14 @@ with stdenv.lib;
 
 pythonPackages.buildPythonPackage rec {
   pname = "neovim-remote";
-  version = "2.1.1";
+  version = "2.1.3";
   disabled = !pythonPackages.isPy3k;
 
   src = fetchFromGitHub {
     owner = "mhinz";
     repo = "neovim-remote";
     rev = "v${version}";
-    sha256 = "1hkzcc141imjin03wpfykw50k0vs7vj1lr09czb2hsyf937gyjqn";
+    sha256 = "0nx987af29ajlpwnwfc3z8gplxv69gj53s4bzm6pwwsfbhfakdah";
   };
 
   propagatedBuildInputs = with pythonPackages; [ pynvim psutil ];
diff --git a/pkgs/applications/editors/sublime/3/packages.nix b/pkgs/applications/editors/sublime/3/packages.nix
index f9a6f1cb6dc9..2d214f18e9f6 100644
--- a/pkgs/applications/editors/sublime/3/packages.nix
+++ b/pkgs/applications/editors/sublime/3/packages.nix
@@ -5,9 +5,9 @@ let
 in
   rec {
     sublime3-dev = common {
-      buildVersion = "3183";
-      x32sha256 = "0rgah7iq9y3afbawcb723d2b7m56lz0ji5l8klxvkp59c9rphqxh";
-      x64sha256 = "1n3zarkhs22p2vi32fswb0fvcn9fzivmziw6zcvjy02c0rmxmdkz";
+      buildVersion = "3184";
+      x32sha256 = "1b6f1fid75g5z247dbnyyj276lrlv99scrdk1vvfcr6vyws77vzr";
+      x64sha256 = "03127jhfjr17ai96p3axh5b5940fds8jcw6vkid8y6dmvd2dpylz";
     } {};
 
     sublime3 = common {
diff --git a/pkgs/applications/graphics/wings/default.nix b/pkgs/applications/graphics/wings/default.nix
index 9ecf94e21c01..ed3220d2bf96 100644
--- a/pkgs/applications/graphics/wings/default.nix
+++ b/pkgs/applications/graphics/wings/default.nix
@@ -1,34 +1,35 @@
-{ fetchurl, stdenv, erlang, esdl, cl }:
+{ fetchurl, stdenv, erlang, cl, libGL, libGLU }:
 
 stdenv.mkDerivation rec {
-  name = "wings-1.5.4";
+  name = "wings-2.2.1";
   src = fetchurl {
     url = "mirror://sourceforge/wings/${name}.tar.bz2";
-    sha256 = "0qz6rmmkqgk3p0d3v2ikkf22n511bq0m7xp3kkradwrp28fcl15x";
+    sha256 = "1adlq3wd9bz0hjznpzsgilxgsbhr0kk01f06872mq37v4cbw76bh";
   };
 
-  ERL_LIBS = "${esdl}/lib/erlang/lib:${cl}/lib/erlang/lib";
+  ERL_LIBS = "${cl}/lib/erlang/lib";
 
   patchPhase = ''
-    sed -i 's,include("sdl_keyboard.hrl"),include_lib("esdl/include/sdl_keyboard.hrl"),' \
-      src/wings_body.erl plugins_src/commands/wpc_constraints.erl
-
-    # Fix reference
-    sed -i 's,wings/e3d/,,' plugins_src/import_export/wpc_lwo.erl
+    sed -i 's,-Werror ,,' e3d/Makefile
+    sed -i 's,../../wings/,../,' icons/Makefile
+    find plugins_src -mindepth 2 -type f -name "*.[eh]rl" -exec sed -i 's,wings/src/,../../src/,' {} \;
+    find plugins_src -mindepth 2 -type f -name "*.[eh]rl" -exec sed -i 's,wings/e3d/,../../e3d/,' {} \;
+    find plugins_src -mindepth 2 -type f -name "*.[eh]rl" -exec sed -i 's,wings/intl_tools/,../../intl_tools/,' {} \;
+    find . -type f -name "*.[eh]rl" -exec sed -i 's,wings/src/,../src/,' {} \;
+    find . -type f -name "*.[eh]rl" -exec sed -i 's,wings/e3d/,../e3d/,' {} \;
+    find . -type f -name "*.[eh]rl" -exec sed -i 's,wings/intl_tools/,../intl_tools/,' {} \;
   '';
 
-  buildInputs = [ erlang esdl cl ];
+  buildInputs = [ erlang cl libGL libGLU ];
 
   # I did not test the *cl* part. I added the -pa just by imitation.
   installPhase = ''
     mkdir -p $out/bin $out/lib/${name}/ebin
     cp ebin/* $out/lib/${name}/ebin
-    cp -R fonts textures shaders plugins $out/lib/$name
+    cp -R textures shaders plugins $out/lib/$name
     cat << EOF > $out/bin/wings
     #!/bin/sh
-    ${erlang}/bin/erl -smp disable \
-      -pa ${esdl}/lib/erlang/lib/${cl.name}/ebin \
-      -pa ${esdl}/lib/erlang/lib/${esdl.name}/ebin \
+    ${erlang}/bin/erl \
       -pa $out/lib/${name}/ebin -run wings_start start_halt "$@"
     EOF
     chmod +x $out/bin/wings
diff --git a/pkgs/applications/misc/digitalbitbox/default.nix b/pkgs/applications/misc/digitalbitbox/default.nix
index 3e6a6ab53f77..939e2e9fc166 100644
--- a/pkgs/applications/misc/digitalbitbox/default.nix
+++ b/pkgs/applications/misc/digitalbitbox/default.nix
@@ -6,7 +6,7 @@
 , libcap
 , libevent
 , libtool
-, libqrencode
+, qrencode
 , udev
 , libusb
 , makeWrapper
@@ -74,7 +74,7 @@ in stdenv.mkDerivation rec {
     libtool
     udev
     libusb
-    libqrencode
+    qrencode
 
     qtbase
     qtwebsockets
diff --git a/pkgs/applications/misc/fsv/default.nix b/pkgs/applications/misc/fsv/default.nix
new file mode 100644
index 000000000000..782a37040d8f
--- /dev/null
+++ b/pkgs/applications/misc/fsv/default.nix
@@ -0,0 +1,47 @@
+{ stdenv, fetchurl, fetchFromGitHub, autoreconfHook
+, libtool, pkgconfig, gtk2, libGLU, file
+}:
+
+let
+  gtkglarea = stdenv.mkDerivation rec {
+    name    = "gtkglarea-${version}";
+    version = "2.1.0";
+    src = fetchurl {
+      url    = "mirror://gnome/sources/gtkglarea/2.1/${name}.tar.xz";
+      sha256 = "1pl2vdj6l64j864ilhkq1bcggb3hrlxjwk5m029i7xfjfxc587lf";
+    };
+    nativeBuildInputs = [ pkgconfig ];
+    buildInputs       = [ gtk2 libGLU ];
+    hardeningDisable  = [ "format" ];
+  };
+
+in stdenv.mkDerivation rec {
+  name    = "fsv-${version}";
+  version = "0.9-1";
+
+  src = fetchFromGitHub {
+    owner  = "mcuelenaere"; 
+    repo   = "fsv";
+    rev    = name;
+    sha256 = "0n09jd7yqj18mx6zqbg7kab4idg5llr15g6avafj74fpg1h7iimj";
+  };
+
+  nativeBuildInputs = [ autoreconfHook libtool pkgconfig ];
+  buildInputs       = [ file gtk2 libGLU gtkglarea ];
+
+  meta = with stdenv.lib; {
+    description     = "fsv is a file system visualizer in cyberspace";
+    longDescription = ''
+      fsv (pronounced eff-ess-vee) is a file system visualizer in cyberspace.
+      It lays out files and directories in three dimensions, geometrically
+      representing the file system hierarchy to allow visual overview
+      and analysis. fsv can visualize a modest home directory, a workstation's
+      hard drive, or any arbitrarily large collection of files, limited only
+      by the host computer's memory and graphics hardware.
+    '';
+    homepage    = https://github.com/mcuelenaere/fsv;
+    license     = licenses.lgpl2;
+    platforms   = platforms.mesaPlatforms;
+    maintainers = with maintainers; [ rnhmjoj ];
+  };
+}
diff --git a/pkgs/applications/misc/pwsafe/default.nix b/pkgs/applications/misc/pwsafe/default.nix
index 7b0e299924cb..a0b702fa1451 100644
--- a/pkgs/applications/misc/pwsafe/default.nix
+++ b/pkgs/applications/misc/pwsafe/default.nix
@@ -1,6 +1,6 @@
 { stdenv, fetchFromGitHub, cmake, pkgconfig, zip, gettext, perl
 , wxGTK31, libXi, libXt, libXtst, xercesc, xextproto
-, libqrencode, libuuid, libyubikey, yubikey-personalization
+, qrencode, libuuid, libyubikey, yubikey-personalization
 }:
 
 stdenv.mkDerivation rec {
@@ -17,7 +17,7 @@ stdenv.mkDerivation rec {
 
   nativeBuildInputs = [ cmake pkgconfig zip ];
   buildInputs = [
-    gettext perl libqrencode libuuid
+    gettext perl qrencode libuuid
     libXi libXt libXtst wxGTK31 xercesc xextproto
     libyubikey yubikey-personalization
   ];
diff --git a/pkgs/applications/misc/rofi/config.patch b/pkgs/applications/misc/rofi/config.patch
deleted file mode 100644
index 46982d51e00c..000000000000
--- a/pkgs/applications/misc/rofi/config.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-diff --git a/script/rofi-theme-selector b/script/rofi-theme-selector
-index 0646e4bc..f827dbfe 100755
---- a/script/rofi-theme-selector
-+++ b/script/rofi-theme-selector
-@@ -42,34 +42,7 @@ function find_themes()
-     DIRS=${XDG_DATA_DIRS}
-     OLDIFS=${IFS}
-     IFS=:
--    if [ -z "${XDG_DATA_DIRS}" ]
--    then
--        echo "XDG_DATA_DIRS needs to be set for this script to function correctly."
--        echo -n "Using dirs from \$PATH: "
--        DIRS=
--        # Iterate over items in $PATH
--        for p in ${PATH}; do
--            # Remove trailing / if exists.
--            x=${p%/}
--            # remove both /bin and /sbin and /games from end
--            x=${x%/bin}
--            x=${x%/sbin}
--            x=${x%/games}
--            # Add /share
--            x=${x}/share
--            # Check if entry exists Prepend : so :${x}: matches nicely
--            case ":${DIRS}" in
--                *$x:*);;
--                *) DIRS+="$x:";;
--            esac
--        done
--        # Remove trailing :
--        DIRS=${DIRS%:}
--        echo "${DIRS}"
--    fi
--    # Add user dir.
--    DIRS+=":${HOME}/.local/share/"
--    DIRS+=":${HOME}/.config/"
-+    DIRS+=":%ROFIOUT%/"
-     for p in ${DIRS}; do 
-     	p=${p%/}
-         TD=${p}/rofi/themes
-@@ -164,7 +137,12 @@ Current theme: <b>${CUR}</b>"""
- ###
- function set_theme()
- {
--    CDIR="${HOME}/.config/rofi/"
-+    if [ -d "${XDG_CONFIG_HOME}" ]; then
-+      CDIR="${XDG_CONFIG_HOME}/rofi/"
-+    else
-+      CDIR="${HOME}/.config/rofi/"
-+    fi
-+
-     if [ ! -d "${CDIR}" ]
-     then
-         mkdir -p ${CDIR}
diff --git a/pkgs/applications/misc/rofi/default.nix b/pkgs/applications/misc/rofi/default.nix
index 63b047976b3d..0edcde12e341 100644
--- a/pkgs/applications/misc/rofi/default.nix
+++ b/pkgs/applications/misc/rofi/default.nix
@@ -4,28 +4,20 @@
 }:
 
 stdenv.mkDerivation rec {
-  version = "1.5.1";
+  version = "1.5.2";
   name = "rofi-unwrapped-${version}";
 
   src = fetchurl {
     url = "https://github.com/DaveDavenport/rofi/releases/download/${version}/rofi-${version}.tar.gz";
-    sha256 = "1dc33zf33z38jcxb0lxpyd31waalpf6d4cd9z5f9m5qphdk1g679";
+    sha256 = "1rczxz6l32vnclarzga1sm1d5iq9rfscb9j7f8ih185n59hf0517";
   };
 
-  # config.patch may be removed in the future - https://github.com/DaveDavenport/rofi/pull/781
-  patches = [ ./config.patch ];
-
   preConfigure = ''
     patchShebangs "script"
     # root not present in build /etc/passwd
     sed -i 's/~root/~nobody/g' test/helper-expand.c
   '';
 
-  postFixup = ''
-    substituteInPlace "$out"/bin/rofi-theme-selector \
-        --replace "%ROFIOUT%" "$out/share"
-  '';
-
   nativeBuildInputs = [ autoreconfHook pkgconfig ];
   buildInputs = [ libxkbcommon pango cairo git bison flex librsvg check
     libstartup_notification libxcb xcbutil xcbutilwm xcbutilxrm which
diff --git a/pkgs/applications/misc/translate-shell/default.nix b/pkgs/applications/misc/translate-shell/default.nix
index 15c4b8185a22..5d50238a9f00 100644
--- a/pkgs/applications/misc/translate-shell/default.nix
+++ b/pkgs/applications/misc/translate-shell/default.nix
@@ -3,13 +3,13 @@
 stdenv.mkDerivation rec {
   name = "${pname}-${version}";
   pname = "translate-shell";
-  version = "0.9.6.8";
+  version = "0.9.6.9";
 
   src = fetchFromGitHub {
     owner = "soimort";
     repo = "translate-shell";
     rev = "v${version}";
-    sha256 = "17fc5nlc594lvmihx39h4ddmi8ja3qqsyswzxadbaz7l3zm356b8";
+    sha256 = "1xyf0vdxmbgqcgsr1gvgwh1q4fh080h68radkim6pfcwzffliszm";
   };
 
   buildInputs = [ makeWrapper ];
diff --git a/pkgs/applications/misc/visidata/default.nix b/pkgs/applications/misc/visidata/default.nix
index 20e3c3daccb0..68e3de4b3417 100644
--- a/pkgs/applications/misc/visidata/default.nix
+++ b/pkgs/applications/misc/visidata/default.nix
@@ -4,13 +4,13 @@
 buildPythonApplication rec {
   name = "${pname}-${version}";
   pname = "visidata";
-  version = "1.5";
+  version = "1.5.1";
 
   src = fetchFromGitHub {
     owner = "saulpw";
     repo = "visidata";
     rev = "v${version}";
-    sha256 = "0schpfksxddbsv0s54pv1jrf151nw9kr51m41fp0ycnw7z2jqirm";
+    sha256 = "1pflv7nnv9nyfhynrdbh5pgvjxzj53hgqd972dis9rwwwkla26ng";
   };
 
   propagatedBuildInputs = [dateutil pyyaml openpyxl xlrd h5py fonttools
diff --git a/pkgs/applications/misc/xterm/default.nix b/pkgs/applications/misc/xterm/default.nix
index 3a3025e7d692..e29bdd46e26a 100644
--- a/pkgs/applications/misc/xterm/default.nix
+++ b/pkgs/applications/misc/xterm/default.nix
@@ -3,14 +3,14 @@
 }:
 
 stdenv.mkDerivation rec {
-  name = "xterm-339";
+  name = "xterm-341";
 
   src = fetchurl {
     urls = [
      "ftp://ftp.invisible-island.net/xterm/${name}.tgz"
      "https://invisible-mirror.net/archives/xterm/${name}.tgz"
    ];
-    sha256 = "1kigkl4va1jxycqcf5dkg4d74j1fgrxhfbp8ib367crn6fqnprk5";
+    sha256 = "0i6b6gpr5qzbgv3jfl86q8d47bgppxr5gq503ng1ll2x5gx7v833";
   };
 
   buildInputs =
diff --git a/pkgs/applications/networking/instant-messengers/fractal/default.nix b/pkgs/applications/networking/instant-messengers/fractal/default.nix
new file mode 100644
index 000000000000..45137aafcaeb
--- /dev/null
+++ b/pkgs/applications/networking/instant-messengers/fractal/default.nix
@@ -0,0 +1,43 @@
+{ stdenv, fetchurl, fetchFromGitLab, meson, ninja, gettext, cargo, rustc, python3, rustPlatform, pkgconfig, gtksourceview
+, hicolor-icon-theme, glib, libhandy, gtk3, libsecret, dbus, openssl, sqlite, gst_all_1, wrapGAppsHook }:
+
+rustPlatform.buildRustPackage rec {
+  version = "4.0.0";
+  name = "fractal-${version}";
+
+  src = fetchFromGitLab {
+    domain = "gitlab.gnome.org";
+    owner = "GNOME";
+    repo = "fractal";
+    rev = version;
+    sha256 = "05q47jdgbi5jz01280msb8gxnbsrgf2jvglfm6k40f1xw4wxkrzy";
+  };
+
+  nativeBuildInputs = [
+    meson ninja pkgconfig gettext cargo rustc python3 wrapGAppsHook
+  ];
+  buildInputs = [
+    glib gtk3 libhandy dbus openssl sqlite gst_all_1.gstreamer gst_all_1.gst-plugins-base gst_all_1.gst-plugins-bad
+    gtksourceview hicolor-icon-theme libsecret
+  ];
+
+  postPatch = ''
+    patchShebangs scripts/meson_post_install.py
+  '';
+
+  # Don't use buildRustPackage phases, only use it for rust deps setup
+  configurePhase = null;
+  buildPhase = null;
+  checkPhase = null;
+  installPhase = null;
+
+  cargoSha256 = "0hlvdcdzkggc2adggmlxz0yxigwp3320wfav77gddlvfip1f90sw";
+
+  meta = with stdenv.lib; {
+    description = "Matrix group messaging app";
+    homepage = https://gitlab.gnome.org/GNOME/fractal;
+    license = licenses.gpl3;
+    maintainers = with maintainers; [ dtzWill ];
+  };
+}
+
diff --git a/pkgs/applications/networking/instant-messengers/toxic/default.nix b/pkgs/applications/networking/instant-messengers/toxic/default.nix
index cbf2dd7d99a2..c8cd91f07277 100644
--- a/pkgs/applications/networking/instant-messengers/toxic/default.nix
+++ b/pkgs/applications/networking/instant-messengers/toxic/default.nix
@@ -1,6 +1,6 @@
 { stdenv, fetchFromGitHub, libsodium, ncurses, curl
 , libtoxcore, openal, libvpx, freealut, libconfig, pkgconfig, libopus
-, libqrencode, gdk_pixbuf, libnotify }:
+, qrencode, gdk_pixbuf, libnotify }:
 
 stdenv.mkDerivation rec {
   name = "toxic-${version}";
@@ -19,7 +19,7 @@ stdenv.mkDerivation rec {
   buildInputs = [
     libtoxcore libsodium ncurses curl gdk_pixbuf libnotify
   ] ++ stdenv.lib.optionals (!stdenv.isAarch32) [
-    openal libopus libvpx freealut libqrencode
+    openal libopus libvpx freealut qrencode
   ];
   nativeBuildInputs = [ pkgconfig libconfig ];
 
diff --git a/pkgs/applications/office/gnucash/2.4.nix b/pkgs/applications/office/gnucash/2.4.nix
deleted file mode 100644
index 40c91d6488d6..000000000000
--- a/pkgs/applications/office/gnucash/2.4.nix
+++ /dev/null
@@ -1,91 +0,0 @@
-{ fetchurl, stdenv, pkgconfig, libxml2, gconf, glib, gtk2, libgnomeui, libofx
-, libgtkhtml, gtkhtml, libgnomeprint, goffice, enchant, gettext, libbonoboui
-, intltool, perl, guile, slibGuile, swig, isocodes, bzip2, makeWrapper, libglade
-, libgsf, libart_lgpl, perlPackages, aqbanking, gwenhywfar, hicolor-icon-theme
-, pcre
-}:
-
-/* If you experience GConf errors when running GnuCash on NixOS, see
- * http://wiki.nixos.org/wiki/Solve_GConf_errors_when_running_GNOME_applications
- * for a possible solution.
- */
-
-stdenv.mkDerivation rec {
-  name = "gnucash-2.4.15";
-
-  src = fetchurl {
-    url = "mirror://sourceforge/gnucash/${name}.tar.bz2";
-    sha256 = "058mgfwic6a2g7jq6iip5hv45md1qaxy25dj4lvlzjjr141wm4gx";
-  };
-
-  nativeBuildInputs = [ pkgconfig ];
-  buildInputs = [
-    libxml2 gconf glib gtk2 libgnomeui libgtkhtml gtkhtml
-    libgnomeprint goffice enchant gettext intltool perl guile slibGuile
-    swig isocodes bzip2 makeWrapper libofx libglade libgsf libart_lgpl
-    perlPackages.DateManip perlPackages.FinanceQuote aqbanking gwenhywfar
-    hicolor-icon-theme pcre
-  ];
-  propagatedUserEnvPkgs = [ gconf ];
-
-  configureFlags = [
-    "CFLAGS=-O3"
-    "CXXFLAGS=-O3"
-    "--disable-dbi"
-    "--enable-ofx"
-    "--enable-aqbanking"
-  ];
-
-  postInstall = ''
-    # Auto-updaters don't make sense in Nix.
-    rm $out/bin/gnc-fq-update
-
-    sed -i $out/bin/update-gnucash-gconf \
-       -e 's|--config-source=[^ ]* --install-schema-file|--makefile-install-rule|'
-
-    for prog in $(echo "$out/bin/"*)
-    do
-      # Don't wrap the gnc-fq-* scripts, since gnucash calls them as
-      # "perl <script>', i.e. they must be Perl scripts.
-      if [[ $prog =~ gnc-fq ]]; then continue; fi
-      wrapProgram "$prog"                                               \
-        --set SCHEME_LIBRARY_PATH "$SCHEME_LIBRARY_PATH"                \
-        --prefix GUILE_LOAD_PATH ":" "$GUILE_LOAD_PATH"                 \
-        --prefix LD_LIBRARY_PATH ":" "${libgnomeui}/lib/libglade/2.0"   \
-        --prefix LD_LIBRARY_PATH ":" "${libbonoboui}/lib/libglade/2.0"  \
-        --prefix PERL5LIB ":" "$PERL5LIB"                               \
-        --set GCONF_CONFIG_SOURCE 'xml::~/.gconf'                       \
-        --prefix PATH ":" "$out/bin:${stdenv.lib.makeBinPath [ perl gconf ]}"
-    done
-  '';
-
-  # The following settings fix failures in the test suite. It's not required otherwise.
-  NIX_LDFLAGS = "-rpath=${guile}/lib -rpath=${glib.out}/lib";
-  preCheck = "export GNC_DOT_DIR=$PWD/dot-gnucash";
-
-  doCheck = false;      # https://github.com/NixOS/nixpkgs/issues/11084
-
-  enableParallelBuilding = true;
-
-  meta = {
-    description = "Personal and small-business financial-accounting application";
-
-    longDescription = ''
-      GnuCash is personal and small-business financial-accounting software,
-      freely licensed under the GNU GPL and available for GNU/Linux, BSD,
-      Solaris, macOS and Microsoft Windows.
-
-      Designed to be easy to use, yet powerful and flexible, GnuCash allows
-      you to track bank accounts, stocks, income and expenses.  As quick and
-      intuitive to use as a checkbook register, it is based on professional
-      accounting principles to ensure balanced books and accurate reports.
-    '';
-
-    license = stdenv.lib.licenses.gpl2Plus;
-
-    homepage = http://www.gnucash.org/;
-
-    maintainers = [ stdenv.lib.maintainers.peti stdenv.lib.maintainers.domenkozar ];
-    platforms = stdenv.lib.platforms.gnu ++ stdenv.lib.platforms.linux;
-  };
-}
diff --git a/pkgs/applications/office/gnucash/2.6.nix b/pkgs/applications/office/gnucash/2.6.nix
deleted file mode 100644
index 471d2d757d96..000000000000
--- a/pkgs/applications/office/gnucash/2.6.nix
+++ /dev/null
@@ -1,116 +0,0 @@
-{ fetchurl, fetchpatch, stdenv, intltool, pkgconfig, file, makeWrapper
-, libxml2, libxslt, perl, perlPackages, gconf, guile
-, glib, gtk2, libofx, aqbanking, gwenhywfar, libgnomecanvas, goffice
-, webkit, glibcLocales, gsettings-desktop-schemas, dconf
-, gettext, swig, slibGuile, enchant, bzip2, isocodes, libdbi, libdbiDrivers
-, pango, gdk_pixbuf, hicolor-icon-theme
-}:
-
-/*
-Two cave-ats right now:
-  1. HTML reports are broken
-  2. You need to have dconf installed (GNOME3 should have it automatically,
-     otherwise put it in environment.systemPackages), for settings
-*/
-
-stdenv.mkDerivation rec {
-  name = "gnucash-2.6.18-1";
-
-  src = fetchurl {
-    url = "mirror://sourceforge/gnucash/${name}.tar.bz2";
-    sha256 = "1794qi7lkn1kbnhzk08wawacfcphbln3ngdl3q0qax5drv7hnwv8";
-  };
-
-  patches = [
-    (fetchpatch {
-     sha256 = "11nlf9j7jm1i37mfcmmnkplxr3nlf257fxd01095vd65i2rn1m8h";
-     name = "fix-brittle-test.patch";
-     url = "https://github.com/Gnucash/gnucash/commit/42ac55e03a1a84739f4a5b7a247c31d91c0adc4a.patch";
-    })
-  ];
-
-  nativeBuildInputs = [ intltool pkgconfig file makeWrapper ];
-
-  buildInputs = [
-    # general
-    libxml2 libxslt glibcLocales gettext swig enchant
-    bzip2 isocodes
-    # glib, gtk...
-    glib gtk2 goffice webkit hicolor-icon-theme
-    # gnome...
-    dconf gconf libgnomecanvas gsettings-desktop-schemas
-    # financial
-    libofx aqbanking gwenhywfar
-    # perl
-    perl perlPackages.FinanceQuote perlPackages.DateManip
-    # guile
-    guile slibGuile
-    # database backends
-    libdbi libdbiDrivers
-  ];
-
-  postPatch = ''
-    patchShebangs ./src
-  '';
-
-  configureFlags = [
-    "CFLAGS=-O3"
-    "CXXFLAGS=-O3"
-    "--enable-dbi"
-    "--with-dbi-dbd-dir=${libdbiDrivers}/lib/dbd/"
-    "--enable-ofx"
-    "--enable-aqbanking"
-  ];
-
-  postInstall = ''
-    # Auto-updaters don't make sense in Nix.
-    rm $out/bin/gnc-fq-update
-
-    #sed -i $out/bin/update-gnucash-gconf \
-    #   -e 's|--config-source=[^ ]* --install-schema-file|--makefile-install-rule|'
-
-    for prog in $(echo "$out/bin/"*)
-    do
-      # Don't wrap the gnc-fq-* scripts, since gnucash calls them as
-      # "perl <script>', i.e. they must be Perl scripts.
-      if [[ $prog =~ gnc-fq ]]; then continue; fi
-      wrapProgram "$prog"                                               \
-        --set SCHEME_LIBRARY_PATH "$SCHEME_LIBRARY_PATH"                \
-        --prefix GUILE_LOAD_PATH ":" "$GUILE_LOAD_PATH"                 \
-        --prefix PERL5LIB ":" "$PERL5LIB"                               \
-        --set GCONF_CONFIG_SOURCE 'xml::~/.gconf'                       \
-        --prefix XDG_DATA_DIRS : "$GSETTINGS_SCHEMAS_PATH:$out/share/gsettings-schemas/${name}" \
-        --prefix GIO_EXTRA_MODULES : "${stdenv.lib.getLib dconf}/lib/gio/modules"  \
-        --prefix PATH ":" "$out/bin:${stdenv.lib.makeBinPath [ perl gconf ]}"
-    done
-  '';
-
-  # The following settings fix failures in the test suite. It's not required otherwise.
-  LD_LIBRARY_PATH = stdenv.lib.makeLibraryPath [ guile glib gtk2 pango gdk_pixbuf ];
-  preCheck = "export GNC_DOT_DIR=$PWD/dot-gnucash";
-  doCheck = true;
-
-  enableParallelBuilding = true;
-
-  meta = {
-    description = "Personal and small-business financial-accounting application";
-
-    longDescription = ''
-      GnuCash is personal and small-business financial-accounting software,
-      freely licensed under the GNU GPL and available for GNU/Linux, BSD,
-      Solaris, macOS and Microsoft Windows.
-
-      Designed to be easy to use, yet powerful and flexible, GnuCash allows
-      you to track bank accounts, stocks, income and expenses.  As quick and
-      intuitive to use as a checkbook register, it is based on professional
-      accounting principles to ensure balanced books and accurate reports.
-    '';
-
-    license = stdenv.lib.licenses.gpl2Plus;
-
-    homepage = http://www.gnucash.org/;
-
-    maintainers = [ stdenv.lib.maintainers.peti stdenv.lib.maintainers.domenkozar ];
-    platforms = stdenv.lib.platforms.gnu ++ stdenv.lib.platforms.linux;
-  };
-}
diff --git a/pkgs/applications/office/trilium/default.nix b/pkgs/applications/office/trilium/default.nix
new file mode 100644
index 000000000000..c274ef0440d7
--- /dev/null
+++ b/pkgs/applications/office/trilium/default.nix
@@ -0,0 +1,58 @@
+{ stdenv, fetchurl, p7zip, autoPatchelfHook, atomEnv, makeWrapper, makeDesktopItem }:
+
+let
+  description = "Trilium Notes is a hierarchical note taking application with focus on building large personal knowledge bases.";
+  desktopItem = makeDesktopItem {
+    name = "Trilium";
+    exec = "trilium";
+    icon = "trilium";
+    comment = description;
+    desktopName = "Trilium Notes";
+    categories = "Office";
+  };
+
+in stdenv.mkDerivation rec {
+  name = "trilium-${version}";
+  version = "0.26.1";
+
+  src = fetchurl {
+    url = "https://github.com/zadam/trilium/releases/download/v${version}/trilium-linux-x64-${version}.7z";
+    sha256 = "184b0b0s8q32h1mpkrin8x1q0kjvard7r7xqrclziwwxg4khp3cz";
+  };
+
+  nativeBuildInputs = [
+    p7zip /* for unpacking */
+    autoPatchelfHook
+    makeWrapper
+  ];
+
+  buildInputs = atomEnv.packages;
+
+  installPhase = ''
+    mkdir -p $out/bin
+    mkdir -p $out/share/trilium
+    mkdir -p $out/share/{applications,icons/hicolor/scalable/apps}
+
+    cp -r ./* $out/share/trilium
+    ln -s $out/share/trilium/trilium $out/bin/trilium
+
+    ln -s $out/share/trilium/resources/app/src/public/images/trilium.svg $out/share/icons/hicolor/scalable/apps/trilium.svg
+    cp ${desktopItem}/share/applications/* $out/share/applications
+  '';
+
+
+  # This "shouldn't" be needed, remove when possible :)
+  preFixup = ''
+    wrapProgram $out/bin/trilium --prefix LD_LIBRARY_PATH : "${atomEnv.libPath}"
+  '';
+
+  dontStrip = true;
+
+  meta = with stdenv.lib; {
+    inherit description;
+    homepage = https://github.com/zadam/trilium;
+    license = licenses.agpl3;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ emmanuelrosa dtzWill ];
+  };
+}
diff --git a/pkgs/applications/science/electronics/kicad/default.nix b/pkgs/applications/science/electronics/kicad/default.nix
index 5d0165eb6dda..e77f4a603a81 100644
--- a/pkgs/applications/science/electronics/kicad/default.nix
+++ b/pkgs/applications/science/electronics/kicad/default.nix
@@ -13,11 +13,11 @@ with lib;
 stdenv.mkDerivation rec {
   name = "kicad-${version}";
   series = "5.0";
-  version = "5.0.1";
+  version = "5.0.2";
 
   src = fetchurl {
     url = "https://launchpad.net/kicad/${series}/${version}/+download/kicad-${version}.tar.xz";
-    sha256 = "0skig2wdxxc2677m8a8m1xrg3pkhqiqnmkcyr2hv0b2j30rzdr2z";
+    sha256 = "10605rr10x0353n6yk2z095ydnkd1i6j1ncbq64pfxdn5vkhcd1g";
   };
 
   postPatch = ''
diff --git a/pkgs/applications/version-management/git-and-tools/git-remote-gcrypt/default.nix b/pkgs/applications/version-management/git-and-tools/git-remote-gcrypt/default.nix
index adfdb9a541c1..a8df4846bf5c 100644
--- a/pkgs/applications/version-management/git-and-tools/git-remote-gcrypt/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/git-remote-gcrypt/default.nix
@@ -2,14 +2,14 @@
 
 stdenv.mkDerivation rec {
   name = "git-remote-gcrypt-${version}";
-  version = "1.1";
+  version = "1.2";
   rev = version;
 
   src = fetchFromGitHub {
     inherit rev;
     owner = "spwhitton";
     repo = "git-remote-gcrypt";
-    sha256 = "0mhz5mqnr35rk7j4wyhp7hzmqgv8r554n9qlm4iw565bz7acvq24";
+    sha256 = "0isfg0vlmcphxzj4jm32dycprhym26ina1b28jgc4j57kiqqrdcy";
   };
 
   outputs = [ "out" "man" ];
diff --git a/pkgs/applications/version-management/gitkraken/default.nix b/pkgs/applications/version-management/gitkraken/default.nix
index 0fcbe54be175..dfc2484b1a51 100644
--- a/pkgs/applications/version-management/gitkraken/default.nix
+++ b/pkgs/applications/version-management/gitkraken/default.nix
@@ -1,8 +1,8 @@
 { stdenv, libXcomposite, libgnome-keyring, makeWrapper, udev, curl, alsaLib
-, libXfixes, atk, gtk2, libXrender, pango, gnome2, cairo, freetype, fontconfig
+, libXfixes, atk, gtk3, libXrender, pango, gnome2, cairo, freetype, fontconfig
 , libX11, libXi, libxcb, libXext, libXcursor, glib, libXScrnSaver, libxkbfile, libXtst
 , nss, nspr, cups, fetchurl, expat, gdk_pixbuf, libXdamage, libXrandr, dbus
-, dpkg, makeDesktopItem
+, dpkg, makeDesktopItem, openssl
 }:
 
 with stdenv.lib;
@@ -12,11 +12,11 @@ let
 in
 stdenv.mkDerivation rec {
   name = "gitkraken-${version}";
-  version = "4.0.5";
+  version = "4.1.1";
 
   src = fetchurl {
     url = "https://release.axocdn.com/linux/GitKraken-v${version}.deb";
-    sha256 = "15wxcahlnz2k3331wqv30d5gq38fqh178hv87xky9b9vyh8qpcvz";
+    sha256 = "188k6vaafv6szzhslsfabnnn68ispsv54d98rcm3m0bmp8kg5p7f";
   };
 
   libPath = makeLibraryPath [
@@ -49,9 +49,10 @@ stdenv.mkDerivation rec {
     libXcomposite
     libXfixes
     libXrender
-    gtk2
+    gtk3
     gnome2.GConf
     libgnome-keyring
+    openssl
   ];
 
   desktopItem = makeDesktopItem {