about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJoachim F <joachifm@users.noreply.github.com>2016-08-03 18:31:43 +0200
committerGitHub <noreply@github.com>2016-08-03 18:31:43 +0200
commit70bf9314989b7714672f861b010bbfc824584ee7 (patch)
treed0ce9a1d2bba7e9ab11e7fb26e61d912a923dbc9 /pkgs/applications
parentef46388c487cc58cd064ba2298a4ea9c7076c28a (diff)
parent3a910eed61a50267fffe8ce2ea0110959a93cbd7 (diff)
downloadnixlib-70bf9314989b7714672f861b010bbfc824584ee7.tar
nixlib-70bf9314989b7714672f861b010bbfc824584ee7.tar.gz
nixlib-70bf9314989b7714672f861b010bbfc824584ee7.tar.bz2
nixlib-70bf9314989b7714672f861b010bbfc824584ee7.tar.lz
nixlib-70bf9314989b7714672f861b010bbfc824584ee7.tar.xz
nixlib-70bf9314989b7714672f861b010bbfc824584ee7.tar.zst
nixlib-70bf9314989b7714672f861b010bbfc824584ee7.zip
Merge pull request #17410 from knedlsepp/motif-on-darwin
motif: Add support for darwin
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/nedit/default.nix9
-rw-r--r--pkgs/applications/misc/catclock/default.nix2
2 files changed, 6 insertions, 5 deletions
diff --git a/pkgs/applications/editors/nedit/default.nix b/pkgs/applications/editors/nedit/default.nix
index 14220956698c..8a478b275933 100644
--- a/pkgs/applications/editors/nedit/default.nix
+++ b/pkgs/applications/editors/nedit/default.nix
@@ -1,7 +1,5 @@
 { stdenv, fetchurl, xlibsWrapper, motif, libXpm }:
 
-assert stdenv.isLinux;
-
 stdenv.mkDerivation rec {
   name = "nedit-5.6a";
   
@@ -12,7 +10,9 @@ stdenv.mkDerivation rec {
 
   buildInputs = [ xlibsWrapper motif libXpm ];
 
-  buildFlags = if stdenv.isLinux then "linux" else "";
+  buildFlags = if stdenv.isLinux then "linux" else
+               # the linux config works fine on darwin too!
+               if stdenv.isDarwin then "linux" else "";
 
   NIX_CFLAGS_COMPILE="-DBUILD_UNTESTED_NEDIT -L${motif}/lib";
 
@@ -21,7 +21,8 @@ stdenv.mkDerivation rec {
     cp -p source/nedit source/nc $out/bin
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = http://www.nedit.org;
+    platforms = with platforms; linux ++ darwin;
   };
 }
diff --git a/pkgs/applications/misc/catclock/default.nix b/pkgs/applications/misc/catclock/default.nix
index 8df06980b471..75f5ab406fe0 100644
--- a/pkgs/applications/misc/catclock/default.nix
+++ b/pkgs/applications/misc/catclock/default.nix
@@ -26,6 +26,6 @@ stdenv.mkDerivation rec {
     homepage = http://codefromabove.com/2014/05/catclock/;
     license = with licenses; mit;
     maintainers = with maintainers; [ ramkromberg ];
-    platforms = with platforms; linux;
+    platforms = with platforms; linux ++ darwin;
   };
 }