about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2017-01-20 16:33:08 +0100
committerVladimír Čunát <vcunat@gmail.com>2017-01-20 16:33:59 +0100
commit6b6553c768b35241930e18fecc9a0e5b95e209b6 (patch)
treefb1a8a642e40d051358d5ec9263b07861e209d2b /pkgs/applications
parente3597b9ddf94234b9ec61d46782b7797334b4a4e (diff)
parent5326cb7340e0cdc8a6f49291b3a127be9743a127 (diff)
downloadnixlib-6b6553c768b35241930e18fecc9a0e5b95e209b6.tar
nixlib-6b6553c768b35241930e18fecc9a0e5b95e209b6.tar.gz
nixlib-6b6553c768b35241930e18fecc9a0e5b95e209b6.tar.bz2
nixlib-6b6553c768b35241930e18fecc9a0e5b95e209b6.tar.lz
nixlib-6b6553c768b35241930e18fecc9a0e5b95e209b6.tar.xz
nixlib-6b6553c768b35241930e18fecc9a0e5b95e209b6.tar.zst
nixlib-6b6553c768b35241930e18fecc9a0e5b95e209b6.zip
Merge branch 'staging'
It contains security updates.  I somehow forgot to push this yesterday.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/gpodder/default.nix8
-rw-r--r--pkgs/applications/audio/linuxband/default.nix4
-rw-r--r--pkgs/applications/editors/ed/default.nix9
-rw-r--r--pkgs/applications/office/zim/default.nix7
-rw-r--r--pkgs/applications/virtualization/virt-manager/default.nix10
5 files changed, 19 insertions, 19 deletions
diff --git a/pkgs/applications/audio/gpodder/default.nix b/pkgs/applications/audio/gpodder/default.nix
index eb9ddf164d48..569326ec375f 100644
--- a/pkgs/applications/audio/gpodder/default.nix
+++ b/pkgs/applications/audio/gpodder/default.nix
@@ -1,9 +1,9 @@
-{ stdenv, fetchurl, pythonPackages, mygpoclient, intltool
+{ stdenv, fetchurl, python2Packages, mygpoclient, intltool
 , ipodSupport ? true, libgpod
 , gnome3
 }:
 
-pythonPackages.buildPythonApplication rec {
+python2Packages.buildPythonApplication rec {
   name = "gpodder-${version}";
 
   version = "3.9.1";
@@ -24,12 +24,12 @@ pythonPackages.buildPythonApplication rec {
   '';
 
   buildInputs = [
-    intltool pythonPackages.coverage pythonPackages.minimock
+    intltool python2Packages.coverage python2Packages.minimock
     gnome3.gnome_themes_standard gnome3.defaultIconTheme
     gnome3.gsettings_desktop_schemas
   ];
 
-  propagatedBuildInputs = with pythonPackages; [
+  propagatedBuildInputs = with python2Packages; [
     feedparser dbus-python mygpoclient pygtk eyeD3
   ] ++ stdenv.lib.optional ipodSupport libgpod;
 
diff --git a/pkgs/applications/audio/linuxband/default.nix b/pkgs/applications/audio/linuxband/default.nix
index 5c127a289c07..ba1d88373fff 100644
--- a/pkgs/applications/audio/linuxband/default.nix
+++ b/pkgs/applications/audio/linuxband/default.nix
@@ -1,7 +1,7 @@
-{ stdenv, fetchurl, makeWrapper, pkgconfig, MMA, libjack2, libsmf, pythonPackages }:
+{ stdenv, fetchurl, makeWrapper, pkgconfig, MMA, libjack2, libsmf, python2Packages }:
 
 let
-  inherit (pythonPackages) pyGtkGlade pygtksourceview python;
+  inherit (python2Packages) pyGtkGlade pygtksourceview python;
 in stdenv.mkDerivation rec {
   version = "12.02.1";
   name = "linuxband-${version}";
diff --git a/pkgs/applications/editors/ed/default.nix b/pkgs/applications/editors/ed/default.nix
index 9cb644cc9315..ec56667a4ba6 100644
--- a/pkgs/applications/editors/ed/default.nix
+++ b/pkgs/applications/editors/ed/default.nix
@@ -1,7 +1,8 @@
 { fetchurl, stdenv }:
 
 stdenv.mkDerivation rec {
-  name = "ed-1.13";
+  name = "ed-${version}";
+  version = "1.14.1";
 
   src = fetchurl {
     # gnu only provides *.lz tarball, which is unfriendly for stdenv bootstrapping
@@ -9,13 +10,13 @@ stdenv.mkDerivation rec {
     # When updating, please make sure the sources pulled match those upstream by
     # Unpacking both tarballs and running `find . -type f -exec sha256sum \{\} \; | sha256sum`
     # in the resulting directory
-    urls = let file_md5 = "fb8ffc8d8072e13dd5799131e889bfa5"; # for fedora mirror
+    urls = let file_sha512 = "84396fe4e4f0bf0b591037277ff8679a08b2883207628aaa387644ad83ca5fbdaa74a581f33310e28222d2fea32a0b8ba37e579597cc7d6145df6eb956ea75db";
       in [
         ("http://pkgs.fedoraproject.org/repo/extras/ed"
-          + "/${name}.tar.bz2/${file_md5}/${name}.tar.bz2")
+          + "/${name}.tar.bz2/sha512/${file_sha512}/${name}.tar.bz2")
         "http://fossies.org/linux/privat/${name}.tar.bz2"
       ];
-    sha256 = "1iym2fsamxr886l3sz8lqzgf00bip5cr0aly8jp04f89kf5mvl0j";
+    sha256 = "1pk6qa4sr7qc6vgm34hjx44hsh8x2bwaxhdi78jhsacnn4zwi7bw";
   };
 
   /* FIXME: Tests currently fail on Darwin:
diff --git a/pkgs/applications/office/zim/default.nix b/pkgs/applications/office/zim/default.nix
index 313239581a1a..227b982689e1 100644
--- a/pkgs/applications/office/zim/default.nix
+++ b/pkgs/applications/office/zim/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, lib, fetchurl, pythonPackages }:
+{ stdenv, lib, fetchurl, python2Packages }:
 
 #
 # TODO: Declare configuration options for the following optional dependencies:
@@ -7,17 +7,16 @@
 #  -  pyxdg: Need to make it work first (see setupPyInstallFlags).
 #
 
-pythonPackages.buildPythonApplication rec {
+python2Packages.buildPythonApplication rec {
   name = "zim-${version}";
   version = "0.65";
-  namePrefix = "";
 
   src = fetchurl {
     url = "http://zim-wiki.org/downloads/${name}.tar.gz";
     sha256 = "15pdq4fxag85qjsrdmmssiq85qsk5vnbp8mrqnpvx8lm8crz6hjl";
   };
 
-  propagatedBuildInputs = with pythonPackages; [ pyGtkGlade pyxdg pygobject2 ];
+  propagatedBuildInputs = with python2Packages; [ pyGtkGlade pyxdg pygobject2 ];
 
   preBuild = ''
     export HOME=$TMP
diff --git a/pkgs/applications/virtualization/virt-manager/default.nix b/pkgs/applications/virtualization/virt-manager/default.nix
index 0964e1b4814b..bd003df57f85 100644
--- a/pkgs/applications/virtualization/virt-manager/default.nix
+++ b/pkgs/applications/virtualization/virt-manager/default.nix
@@ -1,11 +1,11 @@
-{ stdenv, fetchurl, pythonPackages, intltool, libxml2Python, curl
-, wrapGAppsHook, virtinst, gnome_python, gtkvnc, vte
+{ stdenv, fetchurl, python2Packages, intltool, curl
+, wrapGAppsHook, virtinst, gtkvnc, vte
 , gtk3, gobjectIntrospection, libvirt-glib, gsettings_desktop_schemas, glib
 , avahi, dconf, spiceSupport ? true, spice_gtk, libosinfo, gnome3, system-libvirt
 }:
 
 with stdenv.lib;
-with pythonPackages;
+with python2Packages;
 
 buildPythonApplication rec {
   name = "virt-manager-${version}";
@@ -21,8 +21,8 @@ buildPythonApplication rec {
     [ eventlet greenlet gflags netaddr carrot routes
       PasteDeploy m2crypto ipy twisted
       distutils_extra simplejson glanceclient cheetah lockfile httplib2
-      urlgrabber virtinst pyGtkGlade dbus-python gnome_python pygobject3
-      libvirt libxml2Python ipaddr vte libosinfo gobjectIntrospection gtk3 mox
+      urlgrabber virtinst pyGtkGlade dbus-python /*gnome_python FIXME*/ pygobject3
+      libvirt libxml2 ipaddr vte libosinfo gobjectIntrospection gtk3 mox
       gtkvnc libvirt-glib glib gsettings_desktop_schemas gnome3.defaultIconTheme
       wrapGAppsHook
     ] ++ optional spiceSupport spice_gtk;