about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2012-10-08 15:05:00 +0200
committeraszlig <aszlig@redmoonstudios.org>2012-10-08 15:05:00 +0200
commit692ad8059a4d9e10e6310a2256ad8f618463844c (patch)
treefedcaa235fe5ef8dc6039114b7e8ec876ca390a2 /pkgs/applications
parent58a4edd294b855057bedb97c302a681f4544c385 (diff)
downloadnixlib-692ad8059a4d9e10e6310a2256ad8f618463844c.tar
nixlib-692ad8059a4d9e10e6310a2256ad8f618463844c.tar.gz
nixlib-692ad8059a4d9e10e6310a2256ad8f618463844c.tar.bz2
nixlib-692ad8059a4d9e10e6310a2256ad8f618463844c.tar.lz
nixlib-692ad8059a4d9e10e6310a2256ad8f618463844c.tar.xz
nixlib-692ad8059a4d9e10e6310a2256ad8f618463844c.tar.zst
nixlib-692ad8059a4d9e10e6310a2256ad8f618463844c.zip
chromium: Build using libexif from nixpkgs.
While libexif has been bundled with chromium for some months already, they only
recently added the GYP option to switch to using the system library. So, let's
enable it.

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/browsers/chromium/default.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/pkgs/applications/networking/browsers/chromium/default.nix b/pkgs/applications/networking/browsers/chromium/default.nix
index b34e13c920e3..c4dc413c0f5b 100644
--- a/pkgs/applications/networking/browsers/chromium/default.nix
+++ b/pkgs/applications/networking/browsers/chromium/default.nix
@@ -5,6 +5,7 @@
 , libevent, expat, libjpeg
 , libpng, libxml2, libxslt
 , xdg_utils, yasm, zlib
+, libexif
 
 , python, perl, pkgconfig
 , nspr, udev, krb5
@@ -55,6 +56,7 @@ let
     use_system_flac = true;
     use_system_libevent = true;
     use_system_libexpat = true;
+    use_system_libexif = true;
     use_system_libjpeg = true;
     use_system_libpng = true;
     use_system_libxml = true;
@@ -78,6 +80,7 @@ let
     libevent expat libjpeg
     libpng libxml2 libxslt
     xdg_utils yasm zlib
+    libexif
   ];
 
   maybeSeccompPatch = let