about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authormarkuskowa <markus.kowalewski@gmail.com>2020-01-27 17:48:12 +0100
committerGitHub <noreply@github.com>2020-01-27 17:48:12 +0100
commit67a71b6fca749a8ce2864f968a00105ccd7f841d (patch)
tree4ab96dfee0f1f344a7ce5b266594bffb72fed1cb /pkgs/applications
parentfaab2914f3c3ef888e0826ee7a58e2f55d120d22 (diff)
parentf18604531390273733757ec36097699c469a9ab5 (diff)
downloadnixlib-67a71b6fca749a8ce2864f968a00105ccd7f841d.tar
nixlib-67a71b6fca749a8ce2864f968a00105ccd7f841d.tar.gz
nixlib-67a71b6fca749a8ce2864f968a00105ccd7f841d.tar.bz2
nixlib-67a71b6fca749a8ce2864f968a00105ccd7f841d.tar.lz
nixlib-67a71b6fca749a8ce2864f968a00105ccd7f841d.tar.xz
nixlib-67a71b6fca749a8ce2864f968a00105ccd7f841d.tar.zst
nixlib-67a71b6fca749a8ce2864f968a00105ccd7f841d.zip
Merge pull request #78436 from wucke13/foxtrotgps
foxtrotgps: init at 1.2.2
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/foxtrotgps/default.nix40
-rw-r--r--pkgs/applications/misc/tangogps/default.nix46
2 files changed, 40 insertions, 46 deletions
diff --git a/pkgs/applications/misc/foxtrotgps/default.nix b/pkgs/applications/misc/foxtrotgps/default.nix
new file mode 100644
index 000000000000..dc3f1922c214
--- /dev/null
+++ b/pkgs/applications/misc/foxtrotgps/default.nix
@@ -0,0 +1,40 @@
+{ fetchurl, stdenv, pkg-config, wrapGAppsHook, curl, gnome2, gpsd, gtk2
+, intltool, libexif, python3Packages, sqlite }:
+
+stdenv.mkDerivation rec {
+  pname = "foxtrotgps";
+  version = "1.2.2";
+
+  src = fetchurl {
+    url = "https://www.foxtrotgps.org/releases/foxtrotgps-${version}.tar.xz";
+    sha256 = "0grn35j5kwc286dxx18fv32qa330xmalqliwy6zirxmj6dffvrkg";
+  };
+
+  nativeBuildInputs = [ pkg-config wrapGAppsHook ];
+
+  buildInputs = [
+    curl.dev
+    gnome2.libglade.dev
+    gpsd
+    gtk2.dev
+    intltool
+    libexif
+    sqlite.dev
+    (python3Packages.python.withPackages (pythonPackages: with python3Packages;
+    [ beautifulsoup4 feedparser sqlalchemy ]))
+    ];
+
+  meta = with stdenv.lib; {
+    description = "GPS/GIS application optimized for small screens";
+    longDescription = ''
+      An easy to use, free & open-source GPS/GIS application that works well on
+      small screens, and is especially suited to touch input. It spun off of
+      tangoGPS in 2010 with a focus on cooperation and fostering community
+      innovation.
+    '';
+    homepage = "https://www.foxtrotgps.org/";
+    license = licenses.gpl2;
+    platforms = platforms.unix;
+    maintainers = with maintainers; [ wucke13 ];
+  };
+}
diff --git a/pkgs/applications/misc/tangogps/default.nix b/pkgs/applications/misc/tangogps/default.nix
deleted file mode 100644
index 10b487828ea5..000000000000
--- a/pkgs/applications/misc/tangogps/default.nix
+++ /dev/null
@@ -1,46 +0,0 @@
-{ fetchurl, stdenv, pkgconfig, gettext, gtk2, gconf
-, curl, libexif, sqlite, libxml2 }:
-
-stdenv.mkDerivation rec {
-  name = "tangogps-0.99.2";
-
-  src = fetchurl {
-    url = "http://www.tangogps.org/downloads/${name}.tar.gz";
-    sha256 = "15q2kkrv4mfsivfdzjgpxr7s2amw7d501q2ayjl3ff4vmvfn5516";
-  };
-
-  nativeBuildInputs = [ pkgconfig ];
-  buildInputs = [ gettext gtk2 gconf curl libexif sqlite libxml2 ];
-  NIX_LDFLAGS = "-lm";
-
-  # bogus includes fail with newer library version
-  postPatch = ''
-    sed -i -e 's,#include <glib/.*>,#include <glib.h>,g' src/*.c
-    sed -i -e 's,#include <curl/.*>,#include <curl/curl.h>,g' src/*.c src/*.h
-  '';
-
-  meta = {
-    description = "User friendly map and GPS user interface";
-
-    longDescription = ''
-      tangoGPS is an easy to use, fast and lightweight mapping
-      application for use with or without GPS.
-
-      It runs on any Linux platform from the desktop over eeePC down
-      to phones like the Openmoko Neo.
-
-      By default tangoGPS uses map data from the OpenStreetMap
-      project.  Additionally a variety of other repositories can be
-      easily added.
-
-      The maps are automagically downloaded and cached for offline use
-      while you drag or zoom the map.  Furthermore you can
-      conveniently pre-cache areas with tangoGPS.
-    '';
-
-    #homepage = http://www.tangogps.org/; # no longer valid, I couldn't find any other
-
-    license = stdenv.lib.licenses.gpl2Plus;
-    platforms = stdenv.lib.platforms.unix;
-  };
-}