about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorOrivej Desh <orivej@gmx.fr>2017-11-02 15:18:25 +0000
committerGitHub <noreply@github.com>2017-11-02 15:18:25 +0000
commit672efa467df012b4090f91dd254d876d3db8c797 (patch)
treeb87b21a2b3d8077adb68c6a7567fb21b318d97d2 /pkgs/applications
parent7c8ec77db2dd4acf1072938c4e3c7006bbb58e5d (diff)
parent8904ce343a67071dd080260d356fea556de7d0f2 (diff)
downloadnixlib-672efa467df012b4090f91dd254d876d3db8c797.tar
nixlib-672efa467df012b4090f91dd254d876d3db8c797.tar.gz
nixlib-672efa467df012b4090f91dd254d876d3db8c797.tar.bz2
nixlib-672efa467df012b4090f91dd254d876d3db8c797.tar.lz
nixlib-672efa467df012b4090f91dd254d876d3db8c797.tar.xz
nixlib-672efa467df012b4090f91dd254d876d3db8c797.tar.zst
nixlib-672efa467df012b4090f91dd254d876d3db8c797.zip
Merge pull request #31132 from pbogdan/sourceroot-fixes
fix source root locations after c3255fe8ec326d2c8fe9462d49ed83aa64d3e68f
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/puddletag/default.nix4
-rw-r--r--pkgs/applications/graphics/nomacs/default.nix4
-rw-r--r--pkgs/applications/graphics/screencloud/default.nix4
-rw-r--r--pkgs/applications/networking/instant-messengers/pidgin-plugins/pidgin-skypeweb/default.nix4
-rw-r--r--pkgs/applications/science/misc/golly/default.nix4
5 files changed, 15 insertions, 5 deletions
diff --git a/pkgs/applications/audio/puddletag/default.nix b/pkgs/applications/audio/puddletag/default.nix
index f5f580b3664f..00f58750408b 100644
--- a/pkgs/applications/audio/puddletag/default.nix
+++ b/pkgs/applications/audio/puddletag/default.nix
@@ -11,7 +11,9 @@ python2Packages.buildPythonApplication rec {
     sha256 = "1g6wa91awy17z5b704yi9kfynnvfm9lkrvpfvwccscr1h8s3qmiz";
   };
 
-  sourceRoot = "source/source";
+  setSourceRoot = ''
+    sourceRoot=$(echo */source)
+  '';
 
   disabled = python2Packages.isPy3k; # work to support python 3 has not begun
 
diff --git a/pkgs/applications/graphics/nomacs/default.nix b/pkgs/applications/graphics/nomacs/default.nix
index 669e46c6a842..ac0060ec7f8e 100644
--- a/pkgs/applications/graphics/nomacs/default.nix
+++ b/pkgs/applications/graphics/nomacs/default.nix
@@ -30,7 +30,9 @@ stdenv.mkDerivation rec {
 
   enableParallelBuilding = true;
 
-  sourceRoot = "${name}-src/ImageLounge";
+  setSourceRoot = ''
+    sourceRoot=$(echo */ImageLounge)
+  '';
 
   patches = [./fix-appdata-install.patch];
 
diff --git a/pkgs/applications/graphics/screencloud/default.nix b/pkgs/applications/graphics/screencloud/default.nix
index 6f2b0e34cbb3..cffe485711f6 100644
--- a/pkgs/applications/graphics/screencloud/default.nix
+++ b/pkgs/applications/graphics/screencloud/default.nix
@@ -43,7 +43,9 @@ stdenv.mkDerivation rec {
     "-DCONSUMER_SECRET_SCREENCLOUD=${consumerSecret}"
   ];
 
-  sourceRoot = "screencloud-v${version}-src/screencloud";
+  setSourceRoot = ''
+    sourceRoot=$(echo */screencloud)
+  '';
 
   preConfigure = ''
     # This needs to be set in preConfigure instead of cmakeFlags in order to
diff --git a/pkgs/applications/networking/instant-messengers/pidgin-plugins/pidgin-skypeweb/default.nix b/pkgs/applications/networking/instant-messengers/pidgin-plugins/pidgin-skypeweb/default.nix
index 53d1f30bee6a..7ab9b1947915 100644
--- a/pkgs/applications/networking/instant-messengers/pidgin-plugins/pidgin-skypeweb/default.nix
+++ b/pkgs/applications/networking/instant-messengers/pidgin-plugins/pidgin-skypeweb/default.nix
@@ -11,7 +11,9 @@ stdenv.mkDerivation rec {
     sha256 = "1lxpz316jmns6i143v4j6sd6k0a4a54alw08rvwjckf2rig57lj2";
   };
 
-  sourceRoot = "skype4pidgin-${version}-src/skypeweb";
+  setSourceRoot = ''
+    sourceRoot=$(echo */skypeweb)
+  '';
 
   nativeBuildInputs = [ pkgconfig ];
   buildInputs = [ pidgin json_glib ];
diff --git a/pkgs/applications/science/misc/golly/default.nix b/pkgs/applications/science/misc/golly/default.nix
index 8902bacf11ca..94e7c0efaaee 100644
--- a/pkgs/applications/science/misc/golly/default.nix
+++ b/pkgs/applications/science/misc/golly/default.nix
@@ -20,7 +20,9 @@ stdenv.mkDerivation rec {
     inherit (s) url sha256;
   };
 
-  sourceRoot="${name}-src/gui-wx/configure";
+  setSourceRoot = ''
+    sourceRoot=$(echo */gui-wx/configure)
+  '';
 
   # Link against Python explicitly as it is needed for scripts
   makeFlags=[