about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorAdam Stephens <adam@valkor.net>2024-03-09 18:53:43 -0500
committerAustin Seipp <aseipp@pobox.com>2024-03-10 12:58:45 -0500
commit672879b3c0348bce98e19c661e5a3a8ca09158a3 (patch)
tree5d80700788e0683652c220642b48658762bf058f /pkgs/applications
parent3fe65f39280c5360f00c8e7f760597708cb20920 (diff)
downloadnixlib-672879b3c0348bce98e19c661e5a3a8ca09158a3.tar
nixlib-672879b3c0348bce98e19c661e5a3a8ca09158a3.tar.gz
nixlib-672879b3c0348bce98e19c661e5a3a8ca09158a3.tar.bz2
nixlib-672879b3c0348bce98e19c661e5a3a8ca09158a3.tar.lz
nixlib-672879b3c0348bce98e19c661e5a3a8ca09158a3.tar.xz
nixlib-672879b3c0348bce98e19c661e5a3a8ca09158a3.tar.zst
nixlib-672879b3c0348bce98e19c661e5a3a8ca09158a3.zip
jujutsu: 0.14.0 -> 0.15.1
Diff: https://github.com/martinvonz/jj/compare/v0.14.0...v0.15.1

Changelog: https://github.com/martinvonz/jj/blob/v0.15.1/CHANGELOG.md
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/version-management/jujutsu/default.nix14
1 files changed, 9 insertions, 5 deletions
diff --git a/pkgs/applications/version-management/jujutsu/default.nix b/pkgs/applications/version-management/jujutsu/default.nix
index 9503c79e04d0..b6b4bd8e8e41 100644
--- a/pkgs/applications/version-management/jujutsu/default.nix
+++ b/pkgs/applications/version-management/jujutsu/default.nix
@@ -11,7 +11,6 @@
 , libssh2
 , libgit2
 , zstd
-, fetchpatch
 , installShellFiles
 , nix-update-script
 , testers
@@ -20,19 +19,19 @@
 
 rustPlatform.buildRustPackage rec {
   pname = "jujutsu";
-  version = "0.14.0";
+  version = "0.15.1";
 
   src = fetchFromGitHub {
     owner = "martinvonz";
     repo = "jj";
     rev = "v${version}";
-    hash = "sha256-xnGnervyXPfZyQTYsPu09fj+QvbEZ6rDJ4fYHBeF/RY=";
+    hash = "sha256-yppQIffjpyQ2nqhiZbV2pSMQJx8srmHjAk+UClCQfRw=";
   };
 
-  cargoHash = "sha256-wuZ0zthaemzyDn5J2au2L2k0QJnzbrCRjSBIPivEbnQ=";
+  cargoHash = "sha256-2BmKC8DaOdD/THchImmGqplhDrHQHEMyWORWnE2ygSM=";
 
   cargoBuildFlags = [ "--bin" "jj" ]; # don't install the fake editors
-  useNextest = true; # nextest is the upstream integration framework
+  useNextest = false; # nextest is the upstream integration framework, but is problematic for test skipping
   ZSTD_SYS_USE_PKG_CONFIG = "1";    # disable vendored zlib
   LIBSSH2_SYS_USE_PKG_CONFIG = "1"; # disable vendored libssh2
 
@@ -63,6 +62,11 @@ rustPlatform.buildRustPackage rec {
       --zsh <($out/bin/jj util completion zsh)
   '';
 
+  checkFlags = [
+    # signing tests spin up an ssh-agent and do git checkouts
+    "--skip=test_ssh_signing"
+  ];
+
   passthru = {
     updateScript = nix-update-script { };
     tests = {