about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorEmmanuel Rosa <emmanuelrosa@protonmail.com>2019-12-06 22:14:15 +0700
committerLassulus <github@lassul.us>2019-12-07 19:02:39 +0100
commit671fc82ece03a575a343110bc4b9b10bce150018 (patch)
tree0adc03776e1601521fbe89be4d4c70281d82489d /pkgs/applications
parent1d41c6eca74724c7ab02ef2a4b4f5ebf1b048ed5 (diff)
downloadnixlib-671fc82ece03a575a343110bc4b9b10bce150018.tar
nixlib-671fc82ece03a575a343110bc4b9b10bce150018.tar.gz
nixlib-671fc82ece03a575a343110bc4b9b10bce150018.tar.bz2
nixlib-671fc82ece03a575a343110bc4b9b10bce150018.tar.lz
nixlib-671fc82ece03a575a343110bc4b9b10bce150018.tar.xz
nixlib-671fc82ece03a575a343110bc4b9b10bce150018.tar.zst
nixlib-671fc82ece03a575a343110bc4b9b10bce150018.zip
syncthing: 1.3.0 -> 1.3.2
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/syncthing/add-stcli-target.patch16
-rw-r--r--pkgs/applications/networking/syncthing/default.nix6
2 files changed, 11 insertions, 11 deletions
diff --git a/pkgs/applications/networking/syncthing/add-stcli-target.patch b/pkgs/applications/networking/syncthing/add-stcli-target.patch
index 58ac15253aed..07b5e334b2c9 100644
--- a/pkgs/applications/networking/syncthing/add-stcli-target.patch
+++ b/pkgs/applications/networking/syncthing/add-stcli-target.patch
@@ -1,17 +1,17 @@
-diff --git i/build.go w/build.go
-index 7d400d6f..1b5e1d25 100644
---- i/build.go
-+++ w/build.go
-@@ -175,6 +175,12 @@ var targets = map[string]target{
+diff --git a/build.go b/build.go
+index c8a5c1cf..d75a8491 100644
+--- a/build.go
++++ b/build.go
+@@ -202,6 +202,12 @@ var targets = map[string]target{
  			{src: "AUTHORS", dst: "deb/usr/share/doc/syncthing-relaypoolsrv/AUTHORS.txt", perm: 0644},
  		},
  	},
 +	"stcli": {
 +		name:        "stcli",
 +		description: "Syncthing CLI",
-+		buildPkg:    "github.com/syncthing/syncthing/cmd/stcli",
-+		binaryName:  "stcli", // .exe will be added automatically for Windows builds
++		buildPkgs:   []string{"github.com/syncthing/syncthing/cmd/stcli"},
++		binaryName:  "stcli",
 +	},
  }
  
- func init() {
+ // These are repos we need to clone to run "go generate"
diff --git a/pkgs/applications/networking/syncthing/default.nix b/pkgs/applications/networking/syncthing/default.nix
index 555550d4d9e7..c7663ef4117b 100644
--- a/pkgs/applications/networking/syncthing/default.nix
+++ b/pkgs/applications/networking/syncthing/default.nix
@@ -3,19 +3,19 @@
 let
   common = { stname, target, postInstall ? "" }:
     buildGoModule rec {
-      version = "1.3.0";
+      version = "1.3.2";
       name = "${stname}-${version}";
 
       src = fetchFromGitHub {
         owner  = "syncthing";
         repo   = "syncthing";
         rev    = "v${version}";
-        sha256 = "14k1acap9y1z8sj28gcn72lkfxdzpcqj9d27hk8vzm47zjaxgp8l";
+        sha256 = "029mym3vdfg616gpmhv6p22iy65h8vff2sq6z70l37bjf3zx1cms";
       };
 
       goPackagePath = "github.com/syncthing/syncthing";
 
-      modSha256 = "17np8ym84ql7hwzsqfx2l6yiy9hag7h96q8ysvarlfg9l95g1m64";
+      modSha256 = "06anhfi9mswmwhhjyz8mla6h8v83cc7slfr752fvgfaxra1fwgx8";
 
       patches = [
         ./add-stcli-target.patch