about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorAaron Andersen <aaron@fosslib.net>2019-06-19 21:02:59 -0400
committerGitHub <noreply@github.com>2019-06-19 21:02:59 -0400
commit6675589d6d0eb5db9e2f79048b851d999364fd36 (patch)
tree9af591aaa2e2c41bbc00fed89f2a220a6555c45b /pkgs/applications
parent71b7116f12356338c42e000f8e2f2aa992787f50 (diff)
parent8fb4a6a55588dd258929e95caeacc232c19b9d5d (diff)
downloadnixlib-6675589d6d0eb5db9e2f79048b851d999364fd36.tar
nixlib-6675589d6d0eb5db9e2f79048b851d999364fd36.tar.gz
nixlib-6675589d6d0eb5db9e2f79048b851d999364fd36.tar.bz2
nixlib-6675589d6d0eb5db9e2f79048b851d999364fd36.tar.lz
nixlib-6675589d6d0eb5db9e2f79048b851d999364fd36.tar.xz
nixlib-6675589d6d0eb5db9e2f79048b851d999364fd36.tar.zst
nixlib-6675589d6d0eb5db9e2f79048b851d999364fd36.zip
Merge pull request #62978 from m-labs/for-upstream
amp: init at 2019.06.11
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/amp/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/applications/editors/amp/default.nix b/pkgs/applications/editors/amp/default.nix
new file mode 100644
index 000000000000..98692de43170
--- /dev/null
+++ b/pkgs/applications/editors/amp/default.nix
@@ -0,0 +1,30 @@
+{ stdenv, fetchFromGitHub, rustPlatform, openssl, pkgconfig, python3, xorg, cmake, libgit2 }:
+
+rustPlatform.buildRustPackage rec {
+  pname = "amp";
+  # The latest release (0.5.2) does not compile, so we use a git snapshot instead.
+  version = "unstable-2019-06-09";
+
+  src = fetchFromGitHub {
+    owner = "jmacdonald";
+    repo = pname;
+    rev = "2c88e82a88ada8a5fd2620ef225192395a4533a2";
+    sha256 = "0ha1xiabq31s687gkrnszf3zc7b3sfdl79iyg5ygbc49mzvarp8c";
+  };
+
+  cargoSha256 = "1bvj2zg19ak4vi47vjkqlybz011kn5zq1j7zznr76zrryacw4lz1";
+
+  nativeBuildInputs = [ cmake pkgconfig ];
+  buildInputs = [ openssl python3 xorg.libxcb libgit2 ];
+
+  # Tests need to write to the theme directory in HOME.
+  preCheck = "export HOME=`mktemp -d`";
+
+  meta = with stdenv.lib; {
+    description = "A modern text editor inspired by Vim";
+    homepage = "https://amp.rs";
+    license = [ licenses.gpl3 ];
+    maintainers = [ maintainers.sb0 ];
+    platforms = platforms.unix;
+  };
+}