about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorOrivej Desh <orivej@gmx.fr>2018-12-27 11:40:50 +0000
committerOrivej Desh <orivej@gmx.fr>2018-12-27 11:40:50 +0000
commit666be18aa32dd7114f52f078cd3ca11f7f0e43eb (patch)
tree78a32f47862d69f077f0e0961f3751ec6258a740 /pkgs/applications
parentae002fe44e96b868c62581e8066d559ca2179e01 (diff)
downloadnixlib-666be18aa32dd7114f52f078cd3ca11f7f0e43eb.tar
nixlib-666be18aa32dd7114f52f078cd3ca11f7f0e43eb.tar.gz
nixlib-666be18aa32dd7114f52f078cd3ca11f7f0e43eb.tar.bz2
nixlib-666be18aa32dd7114f52f078cd3ca11f7f0e43eb.tar.lz
nixlib-666be18aa32dd7114f52f078cd3ca11f7f0e43eb.tar.xz
nixlib-666be18aa32dd7114f52f078cd3ca11f7f0e43eb.tar.zst
nixlib-666be18aa32dd7114f52f078cd3ca11f7f0e43eb.zip
opentx: fix build, support building tests
It checks for "nano" with "if(NOT NANO STREQUAL NO)".

Broken since https://hydra.nixos.org/build/83296608 (#48286).
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/opentx/default.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/pkgs/applications/misc/opentx/default.nix b/pkgs/applications/misc/opentx/default.nix
index 95a2f2b940c2..cd9a86e7fac7 100644
--- a/pkgs/applications/misc/opentx/default.nix
+++ b/pkgs/applications/misc/opentx/default.nix
@@ -1,6 +1,6 @@
 { stdenv, fetchFromGitHub
 , cmake, gcc-arm-embedded, binutils-arm-embedded, python
-, qt5, SDL, gmock
+, qt5, SDL, gtest
 , dfu-util, avrdude
 }:
 
@@ -29,7 +29,7 @@ in stdenv.mkDerivation {
   buildInputs = with qt5; [
     python python.pkgs.pyqt4
     qtbase qtmultimedia qttranslations
-    SDL gmock
+    SDL
   ];
 
   postPatch = ''
@@ -38,11 +38,12 @@ in stdenv.mkDerivation {
   '';
 
   cmakeFlags = [
+    "-DGTEST_ROOT=${gtest.src}/googletest"
     "-DQT_TRANSLATIONS_DIR=${qt5.qttranslations}/translations"
     # XXX I would prefer to include these here, though we will need to file a bug upstream to get that changed.
     #"-DDFU_UTIL_PATH=${dfu-util}/bin/dfu-util"
     #"-DAVRDUDE_PATH=${avrdude}/bin/avrdude"
-    "-DNANO=OFF"
+    "-DNANO=NO"
   ];
 
   meta = with stdenv.lib; {