about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorGraham Christensen <graham@grahamc.com>2017-07-06 19:39:40 -0400
committerGitHub <noreply@github.com>2017-07-06 19:39:40 -0400
commit665dfda8e433de8c12849368869fca12a693014c (patch)
tree38f5e0806e539b21236dbded33e3f605735e4f64 /pkgs/applications
parentf834ce36a183a5a53d210960ade9c968cf32f895 (diff)
parented59b2c892f462fa3fb94e4a51dc6831f9ec06af (diff)
downloadnixlib-665dfda8e433de8c12849368869fca12a693014c.tar
nixlib-665dfda8e433de8c12849368869fca12a693014c.tar.gz
nixlib-665dfda8e433de8c12849368869fca12a693014c.tar.bz2
nixlib-665dfda8e433de8c12849368869fca12a693014c.tar.lz
nixlib-665dfda8e433de8c12849368869fca12a693014c.tar.xz
nixlib-665dfda8e433de8c12849368869fca12a693014c.tar.zst
nixlib-665dfda8e433de8c12849368869fca12a693014c.zip
Merge pull request #27046 from NixOS/revert-26983-i3/allow-custom-configuration
Revert "i3: add `configFile` to enable cutom configuration locations"
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/window-managers/i3/default.nix121
1 files changed, 54 insertions, 67 deletions
diff --git a/pkgs/applications/window-managers/i3/default.nix b/pkgs/applications/window-managers/i3/default.nix
index a4eb850f9390..df7ba69c5c5f 100644
--- a/pkgs/applications/window-managers/i3/default.nix
+++ b/pkgs/applications/window-managers/i3/default.nix
@@ -1,85 +1,72 @@
 { fetchurl, stdenv, which, pkgconfig, makeWrapper, libxcb, xcbutilkeysyms
 , xcbutil, xcbutilwm, xcbutilxrm, libstartup_notification, libX11, pcre, libev
 , yajl, xcb-util-cursor, coreutils, perl, pango, perlPackages, libxkbcommon
-, xorgserver, xvfb_run, symlinkJoin, configFile ? null }:
+, xorgserver, xvfb_run }:
 
-let
+stdenv.mkDerivation rec {
+  name = "i3-${version}";
   version = "4.13";
 
-  i3 = stdenv.mkDerivation rec {
-    name = "i3-${version}";
-
-    src = fetchurl {
-      url = "http://i3wm.org/downloads/${name}.tar.bz2";
-      sha256 = "12ngz32swh9n85xy0cz1lq16aqi9ys5hq19v589q9a97wn1k3hcl";
-    };
+  src = fetchurl {
+    url = "http://i3wm.org/downloads/${name}.tar.bz2";
+    sha256 = "12ngz32swh9n85xy0cz1lq16aqi9ys5hq19v589q9a97wn1k3hcl";
+  };
 
-    nativeBuildInputs = [ which pkgconfig makeWrapper ];
+  nativeBuildInputs = [ which pkgconfig makeWrapper ];
 
-    buildInputs = [
-      libxcb xcbutilkeysyms xcbutil xcbutilwm xcbutilxrm libxkbcommon
-      libstartup_notification libX11 pcre libev yajl xcb-util-cursor perl pango
-      perlPackages.AnyEventI3 perlPackages.X11XCB perlPackages.IPCRun
-      perlPackages.ExtUtilsPkgConfig perlPackages.TestMore perlPackages.InlineC
-      xorgserver xvfb_run
-    ];
+  buildInputs = [
+    libxcb xcbutilkeysyms xcbutil xcbutilwm xcbutilxrm libxkbcommon
+    libstartup_notification libX11 pcre libev yajl xcb-util-cursor perl pango
+    perlPackages.AnyEventI3 perlPackages.X11XCB perlPackages.IPCRun
+    perlPackages.ExtUtilsPkgConfig perlPackages.TestMore perlPackages.InlineC
+    xorgserver xvfb_run
+  ];
 
-    configureFlags = [ "--disable-builddir" ];
+  configureFlags = [ "--disable-builddir" ];
 
-    enableParallelBuilding = true;
+  enableParallelBuilding = true;
 
-    postPatch = ''
-      patchShebangs .
-    '';
+  postPatch = ''
+    patchShebangs .
+  '';
 
-    # Tests have been failing (at least for some people in some cases)
-    # and have been disabled until someone wants to fix them. Some
-    # initial digging uncovers that the tests call out to `git`, which
-    # they shouldn't, and then even once that's fixed have some
-    # perl-related errors later on. For more, see
-    # https://github.com/NixOS/nixpkgs/issues/7957
-    doCheck = false; # stdenv.system == "x86_64-linux";
+  # Tests have been failing (at least for some people in some cases)
+  # and have been disabled until someone wants to fix them. Some
+  # initial digging uncovers that the tests call out to `git`, which
+  # they shouldn't, and then even once that's fixed have some
+  # perl-related errors later on. For more, see
+  # https://github.com/NixOS/nixpkgs/issues/7957
+  doCheck = false; # stdenv.system == "x86_64-linux";
+
+  checkPhase = stdenv.lib.optionalString (stdenv.system == "x86_64-linux")
+  ''
+    (cd testcases && xvfb-run ./complete-run.pl -p 1 --keep-xserver-output)
+    ! grep -q '^not ok' testcases/latest/complete-run.log
+  '';
 
-    checkPhase = stdenv.lib.optionalString (stdenv.system == "x86_64-linux")
-    ''
-      (cd testcases && xvfb-run ./complete-run.pl -p 1 --keep-xserver-output)
-      ! grep -q '^not ok' testcases/latest/complete-run.log
-    '';
+  postInstall = ''
+    wrapProgram "$out/bin/i3-save-tree" --prefix PERL5LIB ":" "$PERL5LIB"
+    for program in $out/bin/i3-sensible-*; do
+      sed -i 's/which/command -v/' $program
+    done
+  '';
 
-    postInstall = ''
-      wrapProgram "$out/bin/i3-save-tree" --prefix PERL5LIB ":" "$PERL5LIB"
-      for program in $out/bin/i3-sensible-*; do
-        sed -i 's/which/command -v/' $program
-      done
+  separateDebugInfo = true;
+
+  meta = with stdenv.lib; {
+    description = "A tiling window manager";
+    homepage    = "http://i3wm.org";
+    maintainers = with maintainers; [ garbas modulistic fpletz ];
+    license     = licenses.bsd3;
+    platforms   = platforms.all;
+
+    longDescription = ''
+      A tiling window manager primarily targeted at advanced users and
+      developers. Based on a tree as data structure, supports tiling,
+      stacking, and tabbing layouts, handled dynamically, as well as
+      floating windows. Configured via plain text file. Multi-monitor.
+      UTF-8 clean.
     '';
-
-    separateDebugInfo = true;
-
-    meta = with stdenv.lib; {
-      description = "A tiling window manager";
-      homepage    = "http://i3wm.org";
-      maintainers = with maintainers; [ garbas modulistic fpletz ];
-      license     = licenses.bsd3;
-      platforms   = platforms.all;
-
-      longDescription = ''
-        A tiling window manager primarily targeted at advanced users and
-        developers. Based on a tree as data structure, supports tiling,
-        stacking, and tabbing layouts, handled dynamically, as well as
-        floating windows. Configured via plain text file. Multi-monitor.
-        UTF-8 clean.
-      '';
-    };
-
   };
-in if configFile == null then i3 else symlinkJoin {
-  name = "i3-with-config-${version}";
-  paths = [ i3 ];
-
-  buildInputs = [ makeWrapper ];
 
-  postBuild = ''
-      wrapProgram $out/bin/i3 \
-      --add-flags "-c ${configFile}"
-  '';
 }