about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMarc Weber <marco-oweber@gmx.de>2009-10-18 04:43:48 +0000
committerMarc Weber <marco-oweber@gmx.de>2009-10-18 04:43:48 +0000
commit6614345f296db923316b6b49503fa9888e34bf92 (patch)
tree84dc9d4926e10e76e7b6178410407cf9f10ee4d5 /pkgs/applications
parent1db4de344d9a78994796c8d3a4407c5f9f9784a3 (diff)
downloadnixlib-6614345f296db923316b6b49503fa9888e34bf92.tar
nixlib-6614345f296db923316b6b49503fa9888e34bf92.tar.gz
nixlib-6614345f296db923316b6b49503fa9888e34bf92.tar.bz2
nixlib-6614345f296db923316b6b49503fa9888e34bf92.tar.lz
nixlib-6614345f296db923316b6b49503fa9888e34bf92.tar.xz
nixlib-6614345f296db923316b6b49503fa9888e34bf92.tar.zst
nixlib-6614345f296db923316b6b49503fa9888e34bf92.zip
adding yate2 telephony engine
svn path=/nixpkgs/trunk/; revision=17861
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/yate/default.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/pkgs/applications/misc/yate/default.nix b/pkgs/applications/misc/yate/default.nix
new file mode 100644
index 000000000000..b67c69224c57
--- /dev/null
+++ b/pkgs/applications/misc/yate/default.nix
@@ -0,0 +1,39 @@
+args: with args;
+
+let inherit (args.composableDerivation) composableDerivation edf wwf; in
+
+composableDerivation {} ( fixed : {
+
+  name = "yate2";
+
+  src = fetchurl {
+    url = http://yate.null.ro/tarballs/yate2/yate2.tar.gz;
+    sha256 = "0nniicfal3nqkz9swzrxsmyq04cy6xd2dwrngwbjzv0ra5x2p415";
+  };
+
+  # TODO zaptel ? postgres ?
+  buildInputs = [qt openssl autoconf automake pkgconfig];
+
+  # /dev/null is used when linking which is a impure path for the wrapper
+  preConfigure = "
+  
+  sed -i 's@,/dev/null@@' configure
+  "; 
+
+  # --unresolved-symbols=ignore-in-shared-libs makes ld no longer find --library=yate? Why?
+  preBuild = ''
+    export NIX_LDFLAGS="-L$TMP/yate $NIX_LDFLAGS"
+    find . -type f -iname Makefile | xargs sed -i \
+      -e 's@-Wl,--unresolved-symbols=ignore-in-shared-libs@@' \
+      -e 's@-Wl,--retain-symbols-file@@'
+  '';
+
+  meta = { 
+    description = "YATE - Yet Another Telephony Engine";
+    homepage = http://yate.null.ro/;
+    license = ["GPL" "MPL"]; # Yate's license is GPL with an exception for linking with OpenH323 and PWlib (licensed under MPL).
+    maintainers = [args.lib.maintainers.marcweber];
+    platforms = args.lib.platforms.linux;
+  };
+
+} )