about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2018-11-03 12:45:23 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2018-11-03 12:45:23 +0100
commit64e19fdedae3abd589c0429da7e6ec4918d83e8b (patch)
treea8ee900cd9b3e0c6413b414dd60c77fbd066ae36 /pkgs/applications
parentea3935a6c418b076ed41dd1d661c2e1e06656bde (diff)
parent7f4b26681ded35a0e6cb6a90d3bf013c7f4c182d (diff)
downloadnixlib-64e19fdedae3abd589c0429da7e6ec4918d83e8b.tar
nixlib-64e19fdedae3abd589c0429da7e6ec4918d83e8b.tar.gz
nixlib-64e19fdedae3abd589c0429da7e6ec4918d83e8b.tar.bz2
nixlib-64e19fdedae3abd589c0429da7e6ec4918d83e8b.tar.lz
nixlib-64e19fdedae3abd589c0429da7e6ec4918d83e8b.tar.xz
nixlib-64e19fdedae3abd589c0429da7e6ec4918d83e8b.tar.zst
nixlib-64e19fdedae3abd589c0429da7e6ec4918d83e8b.zip
Merge staging into staging-next
Merging staging into staging-next even though we haven't merged staging-next into master yet.
The motivation for this merge is that it's been a while since we merged into master causing
the 3 branches to diverge too much.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/browsers/w3m/default.nix6
-rw-r--r--pkgs/applications/science/math/sage/sage-src.nix18
2 files changed, 20 insertions, 4 deletions
diff --git a/pkgs/applications/networking/browsers/w3m/default.nix b/pkgs/applications/networking/browsers/w3m/default.nix
index d1561a065269..70eb381c60e8 100644
--- a/pkgs/applications/networking/browsers/w3m/default.nix
+++ b/pkgs/applications/networking/browsers/w3m/default.nix
@@ -15,13 +15,13 @@ assert mouseSupport -> gpm-ncurses != null;
 with stdenv.lib;
 
 stdenv.mkDerivation rec {
-  name = "w3m-0.5.3+git20161120";
+  name = "w3m-0.5.3+git20180125";
 
   src = fetchFromGitHub {
     owner = "tats";
     repo = "w3m";
-    rev = "v0.5.3+git20161120";
-    sha256 = "06n5a9jdyihkd4xdjmyci32dpqp1k2l5awia5g9ng0bn256bacdc";
+    rev = "v0.5.3+git20180125";
+    sha256 = "0dafdfx1yhrvhbqzslkcapj09dvf64m2jadz3wl2icni0k4msq90";
   };
 
   NIX_LDFLAGS = optionalString stdenv.isSunOS "-lsocket -lnsl";
diff --git a/pkgs/applications/science/math/sage/sage-src.nix b/pkgs/applications/science/math/sage/sage-src.nix
index f631fe38a5b0..50eae575bc18 100644
--- a/pkgs/applications/science/math/sage/sage-src.nix
+++ b/pkgs/applications/science/math/sage/sage-src.nix
@@ -39,7 +39,17 @@ stdenv.mkDerivation rec {
     ./patches/Only-test-py2-py3-optional-tests-when-all-of-sage-is.patch
   ];
 
-  packageUpgradePatches = [
+  packageUpgradePatches = let
+    fetchSageCommit = { rev, ...}@args: (
+      fetchpatch ({
+        url = "https://git.sagemath.org/sage.git/patch/?h=${rev}";
+        # TODO better https://git.sagemath.org/sage.git/patch/?id=${rev} ?
+        # We don't care about sage's own build system (which builds all its dependencies).
+        # Exclude build system changes to avoid conflicts.
+        excludes = [ "build/*" ];
+      } // builtins.removeAttrs args [ "rev" ])
+    );
+  in [
     # New glpk version has new warnings, filter those out until upstream sage has found a solution
     # https://trac.sagemath.org/ticket/24824
     ./patches/pari-stackwarn.patch # not actually necessary since tha pari upgrade, but necessary for the glpk patch to apply
@@ -53,12 +63,18 @@ stdenv.mkDerivation rec {
     ./patches/numpy-1.15.1.patch
 
     # ntl upgrade
+    # https://trac.sagemath.org/ticket/25532#comment:29
     (fetchpatch {
       name = "lcalc-c++11.patch";
       url = "https://git.archlinux.org/svntogit/community.git/plain/trunk/sagemath-lcalc-c++11.patch?h=packages/sagemath&id=0e31ae526ab7c6b5c0bfacb3f8b1c4fd490035aa";
       sha256 = "0p5wnvbx65i7cp0bjyaqgp4rly8xgnk12pqwaq3dqby0j2bk6ijb";
     })
 
+    (fetchpatch {
+      name = "cython-0.29.patch";
+      url = "https://git.sagemath.org/sage.git/patch/?h=f77de1d0e7f90ee12761140500cb8cbbb789ab20";
+      sha256 = "14wrpy8jgbnpza1j8a2nx8y2r946y82pll1fv3cn6gpfmm6640l3";
+    })
     # https://trac.sagemath.org/ticket/26360
     (fetchpatch {
       name = "arb-2.15.1.patch";