about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2023-08-05 12:01:30 +0000
committerGitHub <noreply@github.com>2023-08-05 12:01:30 +0000
commit6458cb74a2d16d200ef040c881e3eb1c4378ad2d (patch)
tree423239861f2711307dc0f8f8f9b8521ec7104c51 /pkgs/applications
parent91c8b652dbbc8eff5007621ba32cf66ee28a218c (diff)
parent0d98427489fd368378069a56a094c452d9ad8b7f (diff)
downloadnixlib-6458cb74a2d16d200ef040c881e3eb1c4378ad2d.tar
nixlib-6458cb74a2d16d200ef040c881e3eb1c4378ad2d.tar.gz
nixlib-6458cb74a2d16d200ef040c881e3eb1c4378ad2d.tar.bz2
nixlib-6458cb74a2d16d200ef040c881e3eb1c4378ad2d.tar.lz
nixlib-6458cb74a2d16d200ef040c881e3eb1c4378ad2d.tar.xz
nixlib-6458cb74a2d16d200ef040c881e3eb1c4378ad2d.tar.zst
nixlib-6458cb74a2d16d200ef040c881e3eb1c4378ad2d.zip
Merge master into staging-next
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/colorstorm/default.nix29
-rw-r--r--pkgs/applications/misc/mepo/default.nix94
-rw-r--r--pkgs/applications/misc/rivercarro/default.nix42
-rw-r--r--pkgs/applications/misc/waylock/default.nix46
-rw-r--r--pkgs/applications/networking/cluster/timoni/default.nix6
-rw-r--r--pkgs/applications/networking/instant-messengers/profanity/default.nix4
-rw-r--r--pkgs/applications/office/libreoffice/darwin/default.nix6
-rw-r--r--pkgs/applications/science/electronics/dataexplorer/default.nix4
-rw-r--r--pkgs/applications/science/molecular-dynamics/lammps/default.nix4
-rw-r--r--pkgs/applications/version-management/gex/default.nix6
-rw-r--r--pkgs/applications/window-managers/river/default.nix96
11 files changed, 194 insertions, 143 deletions
diff --git a/pkgs/applications/misc/colorstorm/default.nix b/pkgs/applications/misc/colorstorm/default.nix
new file mode 100644
index 000000000000..540d315d6371
--- /dev/null
+++ b/pkgs/applications/misc/colorstorm/default.nix
@@ -0,0 +1,29 @@
+{ lib
+, stdenv
+, fetchFromGitHub
+, zigHook
+}:
+
+stdenv.mkDerivation (finalAttrs: {
+  pname = "colorstorm";
+  version = "2.0.0";
+
+  src = fetchFromGitHub {
+    owner = "benbusby";
+    repo = "colorstorm";
+    rev = "v${finalAttrs.version}";
+    hash = "sha256-6+P+QQpP1jxsydqhVrZkjl1gaqNcx4kS2994hOBhtu8=";
+  };
+
+  nativeBuildInputs = [
+    zigHook
+  ];
+
+  meta = {
+    description = "A color theme generator for editors and terminal emulators";
+    homepage = "https://github.com/benbusby/colorstorm";
+    license = lib.licenses.mit;
+    maintainers = with lib.maintainers; [ ];
+    inherit (zigHook.meta) platforms;
+  };
+})
diff --git a/pkgs/applications/misc/mepo/default.nix b/pkgs/applications/misc/mepo/default.nix
index 5a7640c2414f..680bb54a0ee1 100644
--- a/pkgs/applications/misc/mepo/default.nix
+++ b/pkgs/applications/misc/mepo/default.nix
@@ -1,66 +1,60 @@
 { lib
 , stdenv
 , fetchFromSourcehut
-, pkg-config
-, zig
-, makeWrapper
-, busybox
-, curl
 , SDL2
 , SDL2_gfx
 , SDL2_image
 , SDL2_ttf
+, busybox
+, curl
 , findutils
+, geoclue2-with-demo-agent
+, gpsd
 , jq
+, makeWrapper
 , ncurses
-, gnome
-, xorg
+, pkg-config
 , util-linux
-, gpsd
-, geoclue2-with-demo-agent
+, xwininfo
+, zenity
+, zigHook
 }:
 
-stdenv.mkDerivation rec {
+stdenv.mkDerivation (finalAttrs: {
   pname = "mepo";
   version = "1.1";
 
   src = fetchFromSourcehut {
     owner = "~mil";
-    repo = pname;
-    rev = version;
+    repo = "mepo";
+    rev = finalAttrs.version;
     hash = "sha256-OIZ617QLjiTiDwcsn0DnRussYtjDkVyifr2mdSqA98A=";
   };
 
-  nativeBuildInputs = [ pkg-config zig makeWrapper ];
+  nativeBuildInputs = [
+    pkg-config
+    zigHook
+    makeWrapper
+  ];
 
   buildInputs = [
-    curl SDL2 SDL2_gfx SDL2_image SDL2_ttf jq ncurses
+    curl
+    SDL2
+    SDL2_gfx
+    SDL2_image
+    SDL2_ttf
+    jq
+    ncurses
   ];
 
-  preBuild = ''
-    export HOME=$TMPDIR
-  '';
-
   doCheck = true;
-  checkPhase = ''
-    runHook preCheck
-
-    zig build test
-
-    runHook postCheck
-  '';
-
-  installPhase = ''
-    runHook preInstall
 
-    zig build -Drelease-safe=true -Dcpu=baseline --prefix $out install
+  postInstall = ''
     install -d $out/share/man/man1
     $out/bin/mepo -docman > $out/share/man/man1/mepo.1
-
-    runHook postInstall
   '';
 
-  postInstall = ''
+  postFixup = ''
     substituteInPlace $out/bin/mepo_ui_menu_user_pin_updater.sh \
       --replace /usr/libexec/geoclue-2.0 ${geoclue2-with-demo-agent}/libexec/geoclue-2.0
     substituteInPlace $out/bin/mepo_ui_central_menu.sh \
@@ -68,19 +62,37 @@ stdenv.mkDerivation rec {
       --replace " ls " " ls -a " #circumvent wrapping for script detection
     for program in $out/bin/* ; do
       wrapProgram $program \
-        --suffix PATH : $out/bin:${lib.makeBinPath ([ jq ncurses curl busybox findutils util-linux gpsd gnome.zenity xorg.xwininfo ])}
+        --suffix PATH : $out/bin:${lib.makeBinPath ([
+          busybox
+          curl
+          findutils
+          gpsd
+          jq
+          ncurses
+          util-linux
+          xwininfo
+          zenity
+        ])}
     done
   '';
 
-  meta = with lib; {
+  meta = {
+    homepage = "https://mepo.milesalan.com";
     description = "Fast, simple, and hackable OSM map viewer";
     longDescription = ''
-      It is recommended to use the corresponding NixOS module.
+      Mepo is a fast, simple, and hackable OSM map viewer for desktop & mobile
+      Linux devices (like the PinePhone, Librem 5, postmarketOS devices etc.)
+      and both environment's various user interfaces (Wayland & X
+      inclusive). Environments supported include Phosh, Sxmo, Plasma Mobile,
+      desktop X, and desktop Wayland. Mepo works both offline and online,
+      features a minimalist both touch/mouse and keyboard compatible interface,
+      and offers a UNIX-philosophy inspired underlying design, exposing a
+      powerful command language called Mepolang capable of being scripted to
+      provide things like custom bounding-box search scripts, bookmarks, and
+      more.
     '';
-
-    homepage = "https://mepo.milesalan.com";
-    license = licenses.gpl3Plus;
-    maintainers = with maintainers; [ sikmir McSinyx laalsaas ];
-    platforms = platforms.linux;
+    license = lib.licenses.gpl3Plus;
+    maintainers = with lib.maintainers; [ sikmir McSinyx laalsaas ];
+    platforms = lib.platforms.linux;
   };
-}
+})
diff --git a/pkgs/applications/misc/rivercarro/default.nix b/pkgs/applications/misc/rivercarro/default.nix
index 0074a923f417..ff53ba1a769f 100644
--- a/pkgs/applications/misc/rivercarro/default.nix
+++ b/pkgs/applications/misc/rivercarro/default.nix
@@ -1,49 +1,47 @@
 { lib
 , stdenv
 , fetchFromSourcehut
-, zig
+, pkg-config
 , river
 , wayland
-, pkg-config
+, zigHook
 }:
 
-stdenv.mkDerivation rec {
+stdenv.mkDerivation (finalAttrs: {
   pname = "rivercarro";
   version = "0.1.4";
 
   src = fetchFromSourcehut {
     owner = "~novakane";
-    repo = pname;
+    repo = "rivercarro";
+    rev = "v${finalAttrs.version}";
     fetchSubmodules = true;
-    rev = "v${version}";
-    sha256 = "sha256-eATbbwIt5ytEVLPodyq9vFF9Rs5S1xShpvNYQnfwdV4=";
+    hash = "sha256-eATbbwIt5ytEVLPodyq9vFF9Rs5S1xShpvNYQnfwdV4=";
   };
 
   nativeBuildInputs = [
     pkg-config
     river
     wayland
-    zig
+    zigHook
   ];
 
-  dontConfigure = true;
-
-  preBuild = ''
-    export HOME=$TMPDIR
-  '';
-
-  installPhase = ''
-    runHook preInstall
-    zig build -Drelease-safe -Dcpu=baseline --prefix $out install
-    runHook postInstall
-  '';
-
   meta = with lib; {
     homepage = "https://git.sr.ht/~novakane/rivercarro";
     description = "A layout generator for river Wayland compositor, fork of rivertile";
+    longDescription = ''
+      A slightly modified version of rivertile layout generator for river.
+
+      Compared to rivertile, rivercarro adds:
+      - Monocle layout, views will takes all the usable area on the screen.
+      - Gaps instead of padding around views or layout area.
+      - Modify gaps size at runtime.
+      - Smart gaps, if there is only one view, gaps will be disable.
+      - Limit the width of the usable area of the screen.
+    '';
+    changelog = "https://git.sr.ht/~novakane/rivercarro/refs/v${finalAttrs.version}";
     license = licenses.gpl3Plus;
-    platforms = platforms.linux;
     maintainers = with maintainers; [ kraem ];
+    inherit (zigHook.meta) platforms;
   };
-}
-
+})
diff --git a/pkgs/applications/misc/waylock/default.nix b/pkgs/applications/misc/waylock/default.nix
index 499f1b44db4f..cfd4afee67b3 100644
--- a/pkgs/applications/misc/waylock/default.nix
+++ b/pkgs/applications/misc/waylock/default.nix
@@ -1,27 +1,33 @@
 { lib
 , stdenv
 , fetchFromGitHub
-, zig
-, wayland
+, libxkbcommon
+, pam
 , pkg-config
 , scdoc
+, wayland
 , wayland-protocols
-, libxkbcommon
-, pam
+, zigHook
 }:
-stdenv.mkDerivation rec {
+
+stdenv.mkDerivation (finalAttrs: {
   pname = "waylock";
   version = "0.6.2";
 
   src = fetchFromGitHub {
     owner = "ifreund";
-    repo = pname;
-    rev = "v${version}";
-    hash = "sha256-jl4jSDWvJB6OfBbVXfVQ7gv/aDkN6bBy+/yK+AQDQL0=";
+    repo = "waylock";
+    rev = "v${finalAttrs.version}";
     fetchSubmodules = true;
+    hash = "sha256-jl4jSDWvJB6OfBbVXfVQ7gv/aDkN6bBy+/yK+AQDQL0=";
   };
 
-  nativeBuildInputs = [ zig wayland scdoc pkg-config ];
+  nativeBuildInputs = [
+    pkg-config
+    scdoc
+    wayland
+    zigHook
+  ];
 
   buildInputs = [
     wayland-protocols
@@ -29,23 +35,13 @@ stdenv.mkDerivation rec {
     pam
   ];
 
-  dontConfigure = true;
-
-  preBuild = ''
-    export HOME=$TMPDIR
-  '';
-
-  installPhase = ''
-    runHook preInstall
-    zig build -Drelease-safe -Dman-pages -Dcpu=baseline --prefix $out install
-    runHook postInstall
-  '';
+  zigBuildFlags = [ "-Dman-pages" ];
 
-  meta = with lib; {
+  meta = {
     homepage = "https://github.com/ifreund/waylock";
     description = "A small screenlocker for Wayland compositors";
-    license = licenses.isc;
-    platforms = platforms.linux;
-    maintainers = with maintainers; [ jordanisaacs ];
+    license = lib.licenses.isc;
+    maintainers = with lib.maintainers; [ jordanisaacs ];
+    platforms = lib.platforms.linux;
   };
-}
+})
diff --git a/pkgs/applications/networking/cluster/timoni/default.nix b/pkgs/applications/networking/cluster/timoni/default.nix
index 573e2cd78e4a..c0616c6ea395 100644
--- a/pkgs/applications/networking/cluster/timoni/default.nix
+++ b/pkgs/applications/networking/cluster/timoni/default.nix
@@ -6,16 +6,16 @@
 
 buildGoModule rec {
   pname = "timoni";
-  version = "0.11.0";
+  version = "0.11.1";
 
   src = fetchFromGitHub {
     owner = "stefanprodan";
     repo = "timoni";
     rev = "v${version}";
-    hash = "sha256-1l+PEG3ptlWmM48v9K7Rm090WF8cv+e2ezYFN2JRK/o=";
+    hash = "sha256-o5s/3c6fi6aYzKIBKq23U6FtzueDN0WVsG/wdCMEjDU=";
   };
 
-  vendorHash = "sha256-Mgo6Q3P8Piv5uLgyXDGpRI4CgbZn1DUcM7XhVZxl8EE=";
+  vendorHash = "sha256-rMLswgEWWaDupBHDXs/JATaaw4n5D+LjlM72eq8hPAM=";
 
   subPackages = [ "cmd/timoni" ];
   nativeBuildInputs = [ installShellFiles ];
diff --git a/pkgs/applications/networking/instant-messengers/profanity/default.nix b/pkgs/applications/networking/instant-messengers/profanity/default.nix
index e68941d2a51a..cb8b09c336db 100644
--- a/pkgs/applications/networking/instant-messengers/profanity/default.nix
+++ b/pkgs/applications/networking/instant-messengers/profanity/default.nix
@@ -28,13 +28,13 @@
 
 stdenv.mkDerivation rec {
   pname = "profanity";
-  version = "0.13.1";
+  version = "0.14.0";
 
   src = fetchFromGitHub {
     owner = "profanity-im";
     repo = "profanity";
     rev = version;
-    hash = "sha256-A9ZgHliLb4v/3W5tm5zD0WN8mRmxLE/MUSTBXGvBCCM=";
+    hash = "sha256-u/mp+vtMj602LfrulA+nhLNH8K6sqKIOuPJzhZusVmE=";
   };
 
   patches = [
diff --git a/pkgs/applications/office/libreoffice/darwin/default.nix b/pkgs/applications/office/libreoffice/darwin/default.nix
index 815eb78144d5..99420d75db95 100644
--- a/pkgs/applications/office/libreoffice/darwin/default.nix
+++ b/pkgs/applications/office/libreoffice/darwin/default.nix
@@ -9,21 +9,21 @@
 let
   appName = "LibreOffice.app";
   scriptName = "soffice";
-  version = "7.4.7";
+  version = "7.5.5";
 
   dist = {
     aarch64-darwin = rec {
       arch = "aarch64";
       archSuffix = arch;
       url = "https://download.documentfoundation.org/libreoffice/stable/${version}/mac/${arch}/LibreOffice_${version}_MacOS_${archSuffix}.dmg";
-      sha256 = "d02513c6a58f35cb0da6880f76be3f4b3a620daaa9ce5c244d6efc40ed26a273";
+      sha256 = "75a7d64aa5d08b56c9d9c1c32484b9aff07268c1642cc01a03e45b7690500745";
     };
 
     x86_64-darwin = rec {
       arch = "x86_64";
       archSuffix = "x86-64";
       url = "https://download.documentfoundation.org/libreoffice/stable/${version}/mac/${arch}/LibreOffice_${version}_MacOS_${archSuffix}.dmg";
-      sha256 = "c8ae0cbaa043b30718a4ac0ca93369e887fe6a46bb3618cea054bffaafd8b8e2";
+      sha256 = "4aad9f08ef7a4524b85fc46b3301fdf4f5ab8ab63dd01d01c297f96ff474804a";
     };
   };
 in
diff --git a/pkgs/applications/science/electronics/dataexplorer/default.nix b/pkgs/applications/science/electronics/dataexplorer/default.nix
index 76f3ee826986..596978fc9280 100644
--- a/pkgs/applications/science/electronics/dataexplorer/default.nix
+++ b/pkgs/applications/science/electronics/dataexplorer/default.nix
@@ -8,11 +8,11 @@
 
 stdenv.mkDerivation rec {
   pname = "dataexplorer";
-  version = "3.7.8";
+  version = "3.7.9";
 
   src = fetchurl {
     url = "mirror://savannah/dataexplorer/dataexplorer-${version}-src.tar.gz";
-    sha256 = "sha256-NiCtUqavYNUXsTkgi2V9u2qn8dBTLTEm52ju450d5Lw=";
+    sha256 = "sha256-CdIWAde7mytXP9U1PfI9d/rFK7Agy5biIq5tMTW9RD4=";
   };
 
   nativeBuildInputs = [ ant makeWrapper ];
diff --git a/pkgs/applications/science/molecular-dynamics/lammps/default.nix b/pkgs/applications/science/molecular-dynamics/lammps/default.nix
index 5842efea44e8..580dbb679680 100644
--- a/pkgs/applications/science/molecular-dynamics/lammps/default.nix
+++ b/pkgs/applications/science/molecular-dynamics/lammps/default.nix
@@ -45,14 +45,14 @@
 
 stdenv.mkDerivation rec {
   # LAMMPS has weird versioning converted to ISO 8601 format
-  version = "23Jun2022_update4";
+  version = "2Aug2023";
   pname = "lammps";
 
   src = fetchFromGitHub {
     owner = "lammps";
     repo = "lammps";
     rev = "stable_${version}";
-    hash = "sha256-zGztc+iUFNIa0KKtfpAhwitInvMmXeTHp1XsOLibfzM=";
+    hash = "sha256-6T4YAa4iN3pJpODGPW+faR16xxyYYdkHLavtiPUbZ4o=";
   };
   preConfigure = ''
     cd cmake
diff --git a/pkgs/applications/version-management/gex/default.nix b/pkgs/applications/version-management/gex/default.nix
index 5e1faa58dced..051b7dfdc924 100644
--- a/pkgs/applications/version-management/gex/default.nix
+++ b/pkgs/applications/version-management/gex/default.nix
@@ -8,19 +8,19 @@
 
 rustPlatform.buildRustPackage rec {
   pname = "gex";
-  version = "0.6.0";
+  version = "0.6.1";
 
   src = fetchFromGitHub {
     owner = "Piturnah";
     repo = pname;
     rev = "v${version}";
-    hash = "sha256-J2tmDpt4vRFgD5yfFZOdBLROvyZVEthc+MHM1Yta5jI=";
+    hash = "sha256-OCC2kHPHWFwqdE0THNZbH7d3gxTBD5MUMWY6PO5GuHU";
   };
 
   nativeBuildInputs = [ pkg-config ];
   buildInputs = [ libgit2 ];
 
-  cargoHash = "sha256-AsUHswR7+wMyAvOp3rkvRJvThHLH993gQ+/V38vbbNQ=";
+  cargoHash = "sha256-28sMY47LAdaGmPNmxeu/w1Pn6AV3JlWbxFcit5pLkI0";
 
   meta = with lib; {
     description = "Git Explorer: cross-platform git workflow improvement tool inspired by Magit";
diff --git a/pkgs/applications/window-managers/river/default.nix b/pkgs/applications/window-managers/river/default.nix
index 439030f34da3..41b9324db413 100644
--- a/pkgs/applications/window-managers/river/default.nix
+++ b/pkgs/applications/window-managers/river/default.nix
@@ -1,75 +1,91 @@
 { lib
 , stdenv
 , fetchFromGitHub
-, zig
-, wayland
+, libGL
+, libX11
+, libevdev
+, libinput
+, libxkbcommon
+, pixman
 , pkg-config
 , scdoc
-, xwayland
+, udev
+, wayland
 , wayland-protocols
 , wlroots_0_16
-, libxkbcommon
-, pixman
-, udev
-, libevdev
-, libinput
-, libGL
-, libX11
+, xwayland
+, zigHook
+, withManpages ? true
 , xwaylandSupport ? true
 }:
 
-stdenv.mkDerivation rec {
+stdenv.mkDerivation (finalAttrs: {
   pname = "river";
   version = "0.2.4";
 
+  outputs = [ "out" ] ++ lib.optionals withManpages [ "man" ];
+
   src = fetchFromGitHub {
     owner = "riverwm";
-    repo = pname;
-    rev = "refs/tags/v${version}";
-    hash = "sha256-cIcO6owM6eYn+obYVaBOVQpnBx4++KOqQk5Hzo3GcNs=";
+    repo = "river";
+    rev = "refs/tags/v${finalAttrs.version}";
     fetchSubmodules = true;
+    hash = "sha256-cIcO6owM6eYn+obYVaBOVQpnBx4++KOqQk5Hzo3GcNs=";
   };
 
-  nativeBuildInputs = [ zig wayland xwayland scdoc pkg-config ];
+  nativeBuildInputs = [
+    pkg-config
+    wayland
+    xwayland
+    zigHook
+  ]
+  ++ lib.optional withManpages scdoc;
 
   buildInputs = [
-    wayland-protocols
-    wlroots_0_16
+    libGL
+    libevdev
+    libinput
     libxkbcommon
     pixman
     udev
-    libevdev
-    libinput
-    libGL
+    wayland-protocols
+    wlroots_0_16
   ] ++ lib.optional xwaylandSupport libX11;
 
   dontConfigure = true;
 
-  preBuild = ''
-    export HOME=$TMPDIR
-  '';
+  zigBuildFlags = lib.optional withManpages "-Dman-pages"
+                  ++ lib.optional xwaylandSupport "-Dxwayland";
 
-  installPhase = ''
-    runHook preInstall
-    zig build -Drelease-safe -Dcpu=baseline ${lib.optionalString xwaylandSupport "-Dxwayland"} -Dman-pages --prefix $out install
+  postInstall = ''
     install contrib/river.desktop -Dt $out/share/wayland-sessions
-    runHook postInstall
   '';
 
-  /* Builder patch install dir into river to get default config
-    When installFlags is removed, river becomes half broken.
-    See https://github.com/riverwm/river/blob/7ffa2f4b9e7abf7d152134f555373c2b63ccfc1d/river/main.zig#L56
-  */
-  installFlags = [ "DESTDIR=$(out)" ];
+  passthru.providedSessions = [ "river" ];
 
-  passthru.providedSessions = ["river"];
-
-  meta = with lib; {
-    changelog = "https://github.com/ifreund/river/releases/tag/v${version}";
+  meta = {
     homepage = "https://github.com/ifreund/river";
     description = "A dynamic tiling wayland compositor";
-    license = licenses.gpl3Plus;
-    platforms = platforms.linux;
-    maintainers = with maintainers; [ fortuneteller2k adamcstephens rodrgz ];
+    longDescription = ''
+      River is a dynamic tiling Wayland compositor with flexible runtime
+      configuration.
+
+      Its design goals are:
+      - Simple and predictable behavior, river should be easy to use and have a
+        low cognitive load.
+      - Window management based on a stack of views and tags.
+      - Dynamic layouts generated by external, user-written executables. A
+        default rivertile layout generator is provided.
+      - Scriptable configuration and control through a custom Wayland protocol
+        and separate riverctl binary implementing it.
+    '';
+    changelog = "https://github.com/ifreund/river/releases/tag/v${finalAttrs.version}";
+    license = lib.licenses.gpl3Plus;
+    maintainers = with lib.maintainers; [
+      adamcstephens
+      fortuneteller2k
+      rodrgz
+    ];
+    platforms = lib.platforms.linux;
   };
-}
+})