about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2008-05-26 07:47:07 +0000
committerMichael Raskin <7c6f434c@mail.ru>2008-05-26 07:47:07 +0000
commit642ff45e22ac5e37726b5cbdbcadfcca71382e11 (patch)
tree9dcb79eac6e81892e2ad82661518e5868d7e39f4 /pkgs/applications
parent82177d1bc23cf0eebf4414d9b8e073c7fe0f3ce5 (diff)
downloadnixlib-642ff45e22ac5e37726b5cbdbcadfcca71382e11.tar
nixlib-642ff45e22ac5e37726b5cbdbcadfcca71382e11.tar.gz
nixlib-642ff45e22ac5e37726b5cbdbcadfcca71382e11.tar.bz2
nixlib-642ff45e22ac5e37726b5cbdbcadfcca71382e11.tar.lz
nixlib-642ff45e22ac5e37726b5cbdbcadfcca71382e11.tar.xz
nixlib-642ff45e22ac5e37726b5cbdbcadfcca71382e11.tar.zst
nixlib-642ff45e22ac5e37726b5cbdbcadfcca71382e11.zip
Added codeville - a distributed revision control system with special efforts spent on merging. Heh, efforts into RCS availability seem to have side effects on Python side, too..
svn path=/nixpkgs/trunk/; revision=11891
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/version-management/codeville/0.8.0.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/applications/version-management/codeville/0.8.0.nix b/pkgs/applications/version-management/codeville/0.8.0.nix
new file mode 100644
index 000000000000..57552bac2fca
--- /dev/null
+++ b/pkgs/applications/version-management/codeville/0.8.0.nix
@@ -0,0 +1,23 @@
+args : with args; 
+
+if (! python ? db4Support) || (! python.db4Support) then 
+  throw ''Python DB4 support is required for codeville.'' 
+else
+
+rec {
+  src = fetchurl {
+    url = http://codeville.org/download/Codeville-0.8.0.tar.gz;
+    sha256 = "1p8zc4ijwcwf5bxl34n8d44mlxk1zhbpca68r93ywxqkqm2aqz37";
+  };
+
+  buildInputs = [python makeWrapper];
+  configureFlags = [];
+
+  /* doConfigure should be specified separately */
+  phaseNames = ["installPythonPackage" (makeManyWrappers ''$out/bin/*'' ''--prefix PYTHONPATH : $(toPythonPath $out)'')];
+      
+  name = "codeville-" + version;
+  meta = {
+    description = "Codeville - RCS with powerful merge.";
+  };
+}