about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorIoannis Koutras <ioannis.koutras@gmail.com>2016-07-27 17:27:14 +0300
committerIoannis Koutras <ioannis.koutras@gmail.com>2016-07-30 20:19:16 +0300
commit631edf7de8e6f2d39fbaf2da48f9b2bfff03ad86 (patch)
tree73669bd1e51635a28ec7a19e1b497ead1d781fd9 /pkgs/applications
parent1e43d54695a626ca9e8106ee4db415ac69fd6761 (diff)
downloadnixlib-631edf7de8e6f2d39fbaf2da48f9b2bfff03ad86.tar
nixlib-631edf7de8e6f2d39fbaf2da48f9b2bfff03ad86.tar.gz
nixlib-631edf7de8e6f2d39fbaf2da48f9b2bfff03ad86.tar.bz2
nixlib-631edf7de8e6f2d39fbaf2da48f9b2bfff03ad86.tar.lz
nixlib-631edf7de8e6f2d39fbaf2da48f9b2bfff03ad86.tar.xz
nixlib-631edf7de8e6f2d39fbaf2da48f9b2bfff03ad86.tar.zst
nixlib-631edf7de8e6f2d39fbaf2da48f9b2bfff03ad86.zip
syncthing-inotify: init at 0.8.3
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/syncthing/inotify-deps.json38
-rw-r--r--pkgs/applications/networking/syncthing/inotify.nix26
2 files changed, 64 insertions, 0 deletions
diff --git a/pkgs/applications/networking/syncthing/inotify-deps.json b/pkgs/applications/networking/syncthing/inotify-deps.json
new file mode 100644
index 000000000000..e0cc9680e228
--- /dev/null
+++ b/pkgs/applications/networking/syncthing/inotify-deps.json
@@ -0,0 +1,38 @@
+[
+  {
+    "goPackagePath": "github.com/cenkalti/backoff",
+    "fetch": {
+      "type": "git",
+      "url": "https://github.com/cenkalti/backoff",
+      "rev": "cdf48bbc1eb78d1349cbda326a4a037f7ba565c6",
+      "sha256": "0dg7hvpv0a1db8qriygz1jqgp16v8k505b197x9902z7z6lldgbh"
+    }
+  },
+  {
+    "goPackagePath": "github.com/gobwas/glob",
+    "fetch": {
+      "type": "git",
+      "url": "https://github.com/gobwas/glob",
+      "rev": "ce6abff51712df5da11095fb41dd4b0353559797",
+      "sha256": "1gxv4nnn3f9hw1ncdmhsr8fbfdma2h713ima7b4k28gxydfa8i9m"
+    }
+  },
+  {
+    "goPackagePath": "github.com/syncthing/syncthing",
+    "fetch": {
+      "type": "git",
+      "url": "https://github.com/syncthing/syncthing",
+      "rev": "66a506e72b9dcc749d09a03cb120ba86bbf3d7f8",
+      "sha256": "0is4f1r3im2bbmbca9fafzxffikxaf86vd6f851831fk5wi4pzw9"
+    }
+  },
+  {
+    "goPackagePath": "github.com/zillode/notify",
+    "fetch": {
+      "type": "git",
+      "url": "https://github.com/zillode/notify",
+      "rev": "2da5cc9881e8f16bab76b63129c7781898f97d16",
+      "sha256": "0qwsj730p5mivp2xw9zr5vq8xr7rr9cxjmi564wgmsn7dcvqnr40"
+    }
+  }
+]
\ No newline at end of file
diff --git a/pkgs/applications/networking/syncthing/inotify.nix b/pkgs/applications/networking/syncthing/inotify.nix
new file mode 100644
index 000000000000..4f001794e86d
--- /dev/null
+++ b/pkgs/applications/networking/syncthing/inotify.nix
@@ -0,0 +1,26 @@
+{ stdenv, buildGoPackage, fetchFromGitHub }:
+
+buildGoPackage rec {
+  name = "syncthing-inotify-${version}";
+  version = "0.8.3";
+
+  goPackagePath = "github.com/syncthing/syncthing-inotify";
+
+  src = fetchFromGitHub {
+    owner = "syncthing";
+    repo = "syncthing-inotify";
+    rev = "v${version}";
+    sha256 = "194pbz9zzxaz0vri93czpbsxl85znlba2gy61mjgyr0dm2h4s6yw";
+  };
+
+  goDeps = ./inotify-deps.json;
+
+  meta = {
+    homepage = https://github.com/syncthing/syncthing-inotify;
+    description = "File watcher intended for use with Syncthing";
+    license = stdenv.lib.licenses.mpl20;
+    maintainers = with stdenv.lib.maintainers; [ joko ];
+    platforms = with stdenv.lib.platforms; linux ++ freebsd ++ openbsd ++ netbsd;
+  };
+
+}