about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas@tuxera.com>2016-10-01 23:38:06 +0300
committerTuomas Tynkkynen <tuomas@tuxera.com>2016-10-01 23:38:06 +0300
commit5bf5de58ea568b733d7399233f4d661f911c742d (patch)
treeeb0614162926a8e103a59e87284d759139c8aed7 /pkgs/applications
parentc61cc2d56cb1f790c1921c18deaf6d6c33d5627f (diff)
downloadnixlib-5bf5de58ea568b733d7399233f4d661f911c742d.tar
nixlib-5bf5de58ea568b733d7399233f4d661f911c742d.tar.gz
nixlib-5bf5de58ea568b733d7399233f4d661f911c742d.tar.bz2
nixlib-5bf5de58ea568b733d7399233f4d661f911c742d.tar.lz
nixlib-5bf5de58ea568b733d7399233f4d661f911c742d.tar.xz
nixlib-5bf5de58ea568b733d7399233f4d661f911c742d.tar.zst
nixlib-5bf5de58ea568b733d7399233f4d661f911c742d.zip
treewide: Fix 'lib.optional' misuses
These add a singleton list of a package to buildInputs.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/cd-discid/default.nix2
-rw-r--r--pkgs/applications/graphics/feh/default.nix2
-rw-r--r--pkgs/applications/networking/cluster/spark/default.nix2
-rw-r--r--pkgs/applications/networking/mumble/default.nix2
4 files changed, 4 insertions, 4 deletions
diff --git a/pkgs/applications/audio/cd-discid/default.nix b/pkgs/applications/audio/cd-discid/default.nix
index 2cf9849e351b..382d4a1b6675 100644
--- a/pkgs/applications/audio/cd-discid/default.nix
+++ b/pkgs/applications/audio/cd-discid/default.nix
@@ -13,7 +13,7 @@ stdenv.mkDerivation rec {
   installFlags = "PREFIX=$(out) INSTALL=install";
 
   buildInputs = []
-    ++ stdenv.lib.optional stdenv.isDarwin [ IOKit ];
+    ++ stdenv.lib.optional stdenv.isDarwin IOKit;
 
   meta = with stdenv.lib; {
     homepage = http://linukz.org/cd-discid.shtml;
diff --git a/pkgs/applications/graphics/feh/default.nix b/pkgs/applications/graphics/feh/default.nix
index 380e5d298864..40fe178d6257 100644
--- a/pkgs/applications/graphics/feh/default.nix
+++ b/pkgs/applications/graphics/feh/default.nix
@@ -12,7 +12,7 @@ stdenv.mkDerivation rec {
   outputs = [ "out" "doc" ];
 
   nativeBuildInputs = [ makeWrapper xorg.libXt ]
-    ++ stdenv.lib.optional doCheck [ perlPackages.TestCommand perlPackages.TestHarness ];
+    ++ stdenv.lib.optionals doCheck [ perlPackages.TestCommand perlPackages.TestHarness ];
 
   buildInputs = [ xorg.libX11 xorg.libXinerama imlib2 libjpeg libpng curl libexif ];
 
diff --git a/pkgs/applications/networking/cluster/spark/default.nix b/pkgs/applications/networking/cluster/spark/default.nix
index 79074d2d28e6..b4c20e22680b 100644
--- a/pkgs/applications/networking/cluster/spark/default.nix
+++ b/pkgs/applications/networking/cluster/spark/default.nix
@@ -14,7 +14,7 @@ stdenv.mkDerivation rec {
   };
 
   buildInputs = [ makeWrapper jre pythonPackages.python pythonPackages.numpy ]
-    ++ optional mesosSupport [ mesos ];
+    ++ optional mesosSupport mesos;
 
   untarDir = "${name}-bin-cdh4";
   installPhase = ''
diff --git a/pkgs/applications/networking/mumble/default.nix b/pkgs/applications/networking/mumble/default.nix
index fff0bc5edc46..038f4cb1a739 100644
--- a/pkgs/applications/networking/mumble/default.nix
+++ b/pkgs/applications/networking/mumble/default.nix
@@ -104,7 +104,7 @@ let
       "CONFIG+=no-client"
     ];
 
-    buildInputs = [ libcap ] ++ optional iceSupport [ zeroc_ice ];
+    buildInputs = [ libcap ] ++ optional iceSupport zeroc_ice;
   };
 
   stableSource = rec {