about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@protonmail.ch>2019-07-08 19:33:54 -0400
committerGitHub <noreply@github.com>2019-07-08 19:33:54 -0400
commit5b4e865c5bb51d37e404709c5af955d4f771a9a6 (patch)
tree7ade30e38aaf06103043f1894c91ee7b22de823b /pkgs/applications
parent3752453b930ee706750b6e90061b8fd605fc05ba (diff)
parent6a41fca56adcd8ca630254d3ec206ec0cc4f59f4 (diff)
downloadnixlib-5b4e865c5bb51d37e404709c5af955d4f771a9a6.tar
nixlib-5b4e865c5bb51d37e404709c5af955d4f771a9a6.tar.gz
nixlib-5b4e865c5bb51d37e404709c5af955d4f771a9a6.tar.bz2
nixlib-5b4e865c5bb51d37e404709c5af955d4f771a9a6.tar.lz
nixlib-5b4e865c5bb51d37e404709c5af955d4f771a9a6.tar.xz
nixlib-5b4e865c5bb51d37e404709c5af955d4f771a9a6.tar.zst
nixlib-5b4e865c5bb51d37e404709c5af955d4f771a9a6.zip
Merge pull request #64447 from xrelkd/update/rofi
rofi: 1.5.3 -> 1.5.4
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/rofi/default.nix16
-rw-r--r--pkgs/applications/misc/rofi/wrapper.nix4
2 files changed, 12 insertions, 8 deletions
diff --git a/pkgs/applications/misc/rofi/default.nix b/pkgs/applications/misc/rofi/default.nix
index 0cf297b1b5d9..94381d4f6f96 100644
--- a/pkgs/applications/misc/rofi/default.nix
+++ b/pkgs/applications/misc/rofi/default.nix
@@ -1,15 +1,16 @@
-{ stdenv, fetchurl, autoreconfHook, pkgconfig, libxkbcommon, pango, which, git
+{ stdenv, lib, fetchurl
+, autoreconfHook, pkgconfig, libxkbcommon, pango, which, git
 , cairo, libxcb, xcbutil, xcbutilwm, xcbutilxrm, libstartup_notification
 , bison, flex, librsvg, check
 }:
 
 stdenv.mkDerivation rec {
-  version = "1.5.3";
-  name = "rofi-unwrapped-${version}";
+  pname = "rofi-unwrapped";
+  version = "1.5.4";
 
   src = fetchurl {
-    url = "https://github.com/DaveDavenport/rofi/releases/download/${version}/rofi-${version}.tar.gz";
-    sha256 = "1mskknfnpgmaghplwcyc44qc8swb1f9qiyi67fz9i77jijjpj1lx";
+    url = "https://github.com/davatorium/rofi/releases/download/${version}/rofi-${version}.tar.gz";
+    sha256 = "1g1170zmh5v7slnm1sm2d08jgz6icikf8rm17apm1bjzzyw1lhk7";
   };
 
   preConfigure = ''
@@ -22,11 +23,12 @@ stdenv.mkDerivation rec {
   buildInputs = [ libxkbcommon pango cairo git bison flex librsvg check
     libstartup_notification libxcb xcbutil xcbutilwm xcbutilxrm which
   ];
+
   doCheck = false;
 
-  meta = with stdenv.lib; {
+  meta = with lib; {
     description = "Window switcher, run dialog and dmenu replacement";
-    homepage = https://github.com/davatorium/rofi;
+    homepage = "https://github.com/davatorium/rofi";
     license = licenses.mit;
     maintainers = with maintainers; [ mbakke ma27 ];
     platforms = with platforms; linux;
diff --git a/pkgs/applications/misc/rofi/wrapper.nix b/pkgs/applications/misc/rofi/wrapper.nix
index c2384f56faa1..8c24d27f0752 100644
--- a/pkgs/applications/misc/rofi/wrapper.nix
+++ b/pkgs/applications/misc/rofi/wrapper.nix
@@ -2,7 +2,9 @@
 
 if theme == null then rofi-unwrapped else
 stdenv.mkDerivation {
-  name = "rofi-${rofi-unwrapped.version}";
+  pname = "rofi";
+  version = rofi-unwrapped.version;
+
   buildInputs = [ makeWrapper ];
   preferLocalBuild = true;
   passthru.unwrapped = rofi-unwrapped;