about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorDaiderd Jordan <daiderd@gmail.com>2017-01-02 00:54:06 +0100
committerDaiderd Jordan <daiderd@gmail.com>2017-01-02 00:54:17 +0100
commit5a67b130b9b4d72a4398b8f0cd4893674213fb20 (patch)
tree81354bb3b5c2447bda9e93dbc94acdbc4d913c25 /pkgs/applications
parent2bb33130cc3a00a8fb1a6afb341cf31079061e5a (diff)
parent2c288548b93b657365c27a0132a43ba0080870cc (diff)
downloadnixlib-5a67b130b9b4d72a4398b8f0cd4893674213fb20.tar
nixlib-5a67b130b9b4d72a4398b8f0cd4893674213fb20.tar.gz
nixlib-5a67b130b9b4d72a4398b8f0cd4893674213fb20.tar.bz2
nixlib-5a67b130b9b4d72a4398b8f0cd4893674213fb20.tar.lz
nixlib-5a67b130b9b4d72a4398b8f0cd4893674213fb20.tar.xz
nixlib-5a67b130b9b4d72a4398b8f0cd4893674213fb20.tar.zst
nixlib-5a67b130b9b4d72a4398b8f0cd4893674213fb20.zip
Merge branch 'master' into staging
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/kakoune/default.nix9
-rw-r--r--pkgs/applications/editors/nano/default.nix4
-rw-r--r--pkgs/applications/gis/grass/default.nix1
-rw-r--r--pkgs/applications/graphics/darktable/default.nix14
-rw-r--r--pkgs/applications/misc/calibre/default.nix6
-rw-r--r--pkgs/applications/misc/font-manager/default.nix1
-rw-r--r--pkgs/applications/misc/rofi/default.nix10
-rw-r--r--pkgs/applications/networking/dropbox/default.nix6
-rw-r--r--pkgs/applications/networking/dyndns/cfdyndns/default.nix1
-rw-r--r--pkgs/applications/networking/flexget/default.nix39
-rw-r--r--pkgs/applications/networking/mailreaders/astroid/default.nix36
-rw-r--r--pkgs/applications/networking/mailreaders/astroid/propagate-environment.patch13
-rw-r--r--pkgs/applications/networking/mailreaders/neomutt/default.nix9
-rw-r--r--pkgs/applications/office/ppl-address-book/Gemfile2
-rw-r--r--pkgs/applications/office/ppl-address-book/Gemfile.lock34
-rw-r--r--pkgs/applications/office/ppl-address-book/default.nix38
-rw-r--r--pkgs/applications/office/ppl-address-book/gemset.nix90
-rw-r--r--pkgs/applications/science/logic/lean/default.nix6
-rw-r--r--pkgs/applications/science/misc/fityk/default.nix4
-rw-r--r--pkgs/applications/science/physics/sherpa/default.nix23
-rw-r--r--pkgs/applications/version-management/cvsps/01_ignoretrunk.dpatch23
-rw-r--r--pkgs/applications/version-management/cvsps/02_dynamicbufferalloc.dpatch125
-rw-r--r--pkgs/applications/version-management/cvsps/03_diffoptstypo.dpatch19
-rw-r--r--pkgs/applications/version-management/cvsps/default.nix48
-rw-r--r--pkgs/applications/version-management/git-and-tools/transcrypt/default.nix4
-rw-r--r--pkgs/applications/version-management/pijul/default.nix1
26 files changed, 361 insertions, 205 deletions
diff --git a/pkgs/applications/editors/kakoune/default.nix b/pkgs/applications/editors/kakoune/default.nix
index 73ee7ed64cd5..14b13c394f31 100644
--- a/pkgs/applications/editors/kakoune/default.nix
+++ b/pkgs/applications/editors/kakoune/default.nix
@@ -4,17 +4,18 @@ with stdenv.lib;
 
 stdenv.mkDerivation rec {
   name = "kakoune-nightly-${version}";
-  version = "2016-12-10";
+  version = "2016-12-30";
   src = fetchFromGitHub {
     repo = "kakoune";
     owner = "mawww";
-    rev = "e44129577a010ebb4dc609b806104d3175659074";
-    sha256 = "1jkpbk6wa9x5nlv002y1whv6ddhqawxzbp3jcbzcb51cg8bz0b1l";
+    rev = "76c58aa022a896dc170c207ff821992ee354d934";
+    sha256 = "0hgpcp6444cyg4bm0a9ypywjwfh19qpqpfr5w0wcd2y3clnsvsdz";
   };
   buildInputs = [ ncurses boost asciidoc docbook_xsl libxslt ];
 
   buildPhase = ''
     sed -ie 's#--no-xmllint#--no-xmllint --xsltproc-opts="--nonet"#g' src/Makefile
+    substituteInPlace src/Makefile --replace "boost_regex-mt" "boost_regex"
     export PREFIX=$out
     (cd src && make )
   '';
@@ -28,6 +29,6 @@ stdenv.mkDerivation rec {
     description = "A vim inspired text editor";
     license = licenses.publicDomain;
     maintainers = with maintainers; [ vrthra ];
-    platforms = platforms.linux;
+    platforms = platforms.unix;
   };
 }
diff --git a/pkgs/applications/editors/nano/default.nix b/pkgs/applications/editors/nano/default.nix
index 738476b98e2e..0b45f9502fad 100644
--- a/pkgs/applications/editors/nano/default.nix
+++ b/pkgs/applications/editors/nano/default.nix
@@ -12,10 +12,10 @@ with stdenv.lib;
 
 stdenv.mkDerivation rec {
   name = "nano-${version}";
-  version = "2.7.2";
+  version = "2.7.3";
   src = fetchurl {
     url = "mirror://gnu/nano/${name}.tar.xz";
-    sha256 = "1hlhwgvzdgkc7k74fbbn49hn6vmvzqr7h8gclgl7r1c6qrrny0bp";
+    sha256 = "1z0bfyc5cvv83l3bjmlcwl49mpxrp65k5ffsfpnayfyjc18fy9nr";
   };
   nativeBuildInputs = [ texinfo ] ++ optional enableNls gettext;
   buildInputs = [ ncurses ];
diff --git a/pkgs/applications/gis/grass/default.nix b/pkgs/applications/gis/grass/default.nix
index 44e07cc22c0b..7d2828115f77 100644
--- a/pkgs/applications/gis/grass/default.nix
+++ b/pkgs/applications/gis/grass/default.nix
@@ -60,6 +60,7 @@ stdenv.mkDerivation {
     wrapProgram $out/bin/grass70 \
     --set PYTHONPATH $PYTHONPATH \
     --set GRASS_PYTHON ${python2Packages.python}/bin/${python2Packages.python.executable}
+    --suffix LD_LIBRARY_PATH ':' '${gdal}/lib'
     ln -s $out/grass-*/lib $out/lib
   '';
 
diff --git a/pkgs/applications/graphics/darktable/default.nix b/pkgs/applications/graphics/darktable/default.nix
index a9ad0210baa1..ea5113246ba9 100644
--- a/pkgs/applications/graphics/darktable/default.nix
+++ b/pkgs/applications/graphics/darktable/default.nix
@@ -11,12 +11,12 @@
 assert stdenv ? glibc;
 
 stdenv.mkDerivation rec {
-  version = "2.0.7";
+  version = "2.2.0";
   name = "darktable-${version}";
 
   src = fetchurl {
     url = "https://github.com/darktable-org/darktable/releases/download/release-${version}/darktable-${version}.tar.xz";
-    sha256 = "1aqxiaw89xdx0s0h3gb9nvdzw4690y3kp7h794sihf2581bn28m9";
+    sha256 = "3eca193831faae58200bb1cb6ef29e658bce43a81706b54420953a7c33d79377";
   };
 
   buildInputs =
@@ -34,6 +34,16 @@ stdenv.mkDerivation rec {
     "-DBUILD_USERMANUAL=False"
   ];
 
+  # darktable changed its rpath handling in commit
+  # 83c70b876af6484506901e6b381304ae0d073d3c and as a result the
+  # binaries can't find libdarktable.so, so change LD_LIBRARY_PATH in
+  # the wrappers:
+  preFixup = ''
+    gappsWrapperArgs+=(
+      --prefix LD_LIBRARY_PATH ":" "$out/lib/darktable"
+    )
+  '';
+  
   meta = with stdenv.lib; {
     description = "Virtual lighttable and darkroom for photographers";
     homepage = https://www.darktable.org;
diff --git a/pkgs/applications/misc/calibre/default.nix b/pkgs/applications/misc/calibre/default.nix
index b98d327d3b8a..5c05d1e17873 100644
--- a/pkgs/applications/misc/calibre/default.nix
+++ b/pkgs/applications/misc/calibre/default.nix
@@ -5,12 +5,12 @@
 }:
 
 stdenv.mkDerivation rec {
-  version = "2.73.0";
+  version = "2.76.0";
   name = "calibre-${version}";
 
   src = fetchurl {
     url = "https://download.calibre-ebook.com/${version}/${name}.tar.xz";
-    sha256 = "17qs7dakzd25wbshsny2x82ppdqa6kwwfbp2vp1i8qmfc1nq61gc";
+    sha256 = "1xfm586n6gm44mkyn25mbiyhj6w9ji9yl6fvmnr4zk1q6qcga3v8";
   };
 
   patches = [
@@ -56,7 +56,7 @@ stdenv.mkDerivation rec {
     apsw beautifulsoup cssselect cssutils dateutil lxml mechanize netifaces pillow
     python pyqt5 sip
     # the following are distributed with calibre, but we use upstream instead
-    chardet cherrypy html5lib odfpy routes
+    chardet cherrypy html5lib_0_9999999 odfpy routes
   ]);
 
   installPhase = ''
diff --git a/pkgs/applications/misc/font-manager/default.nix b/pkgs/applications/misc/font-manager/default.nix
index 5f8d00ce996a..6d67d3a340f5 100644
--- a/pkgs/applications/misc/font-manager/default.nix
+++ b/pkgs/applications/misc/font-manager/default.nix
@@ -35,6 +35,7 @@ stdenv.mkDerivation rec {
     gnome3.gucharmap
     gnome3.libgee
     gnome3.file-roller
+    gnome3.defaultIconTheme
   ];
 
   enableParallelBuilding = true;
diff --git a/pkgs/applications/misc/rofi/default.nix b/pkgs/applications/misc/rofi/default.nix
index d6ff999b23d4..c7da77a3a030 100644
--- a/pkgs/applications/misc/rofi/default.nix
+++ b/pkgs/applications/misc/rofi/default.nix
@@ -1,14 +1,14 @@
-{ stdenv, fetchurl, autoreconfHook, pkgconfig, libxkbcommon, pango
+{ stdenv, fetchurl, autoreconfHook, pkgconfig, libxkbcommon, pango, which, git
 , cairo, glib, libxcb, xcbutil, xcbutilwm, xcbutilxrm, libstartup_notification
 }:
 
 stdenv.mkDerivation rec {
-  version = "1.2.0";
+  version = "1.3.0";
   name = "rofi-${version}";
 
   src = fetchurl {
     url = "https://github.com/DaveDavenport/rofi/releases/download/${version}/${name}.tar.xz";
-    sha256 = "0xxx0xpxhrhlhi2axq9867zqrhwqavc1qrr833k1xr0pvm5m0aqc";
+    sha256 = "1a65ai93ygras5bi7wc0s5i3zqslzqlnw3klq3sdnp2p0d6hjjqn";
   };
 
   preConfigure = ''
@@ -17,8 +17,8 @@ stdenv.mkDerivation rec {
     sed -i 's/~root/~nobody/g' test/helper-expand.c
   '';
 
-  buildInputs = [ autoreconfHook pkgconfig libxkbcommon pango cairo
-    libstartup_notification libxcb xcbutil xcbutilwm xcbutilxrm
+  buildInputs = [ autoreconfHook pkgconfig libxkbcommon pango cairo git
+    libstartup_notification libxcb xcbutil xcbutilwm xcbutilxrm which
   ];
   doCheck = true;
 
diff --git a/pkgs/applications/networking/dropbox/default.nix b/pkgs/applications/networking/dropbox/default.nix
index 20d50bd0f7a7..e78230a74b4d 100644
--- a/pkgs/applications/networking/dropbox/default.nix
+++ b/pkgs/applications/networking/dropbox/default.nix
@@ -23,11 +23,11 @@
 let
   # NOTE: When updating, please also update in current stable,
   # as older versions stop working
-  version = "16.4.29";
+  version = "16.4.30";
   sha256 =
     {
-      "x86_64-linux" = "0zng19qisbr3c9d312ar43p1b44xidabj4x2l3g3q85i300vj661";
-      "i686-linux"   = "0hc5fs0akc437valbxwlymk7ncjkdnhc51pja5bbiy48gqmd42bb";
+      "x86_64-linux" = "0inwc12d14i6gyfllxbhizb434a7vy0l5nvc07kz0bca7c4665wb";
+      "i686-linux"   = "0pdn8558ll317k3jrrjir90pn6abwbm99y9wzdq39wxj4dmrlh6w";
     }."${stdenv.system}" or (throw "system ${stdenv.system} not supported");
 
   arch =
diff --git a/pkgs/applications/networking/dyndns/cfdyndns/default.nix b/pkgs/applications/networking/dyndns/cfdyndns/default.nix
index d3be9c28df35..a79404e77c85 100644
--- a/pkgs/applications/networking/dyndns/cfdyndns/default.nix
+++ b/pkgs/applications/networking/dyndns/cfdyndns/default.nix
@@ -27,5 +27,6 @@ buildRustPackage rec {
     license = stdenv.lib.licenses.mit;
     maintainers = with maintainers; [ colemickens ];
     platforms = with platforms; linux;
+    broken = true;
   };
 }
diff --git a/pkgs/applications/networking/flexget/default.nix b/pkgs/applications/networking/flexget/default.nix
new file mode 100644
index 000000000000..f7dd96183070
--- /dev/null
+++ b/pkgs/applications/networking/flexget/default.nix
@@ -0,0 +1,39 @@
+{ lib
+, pythonPackages
+, fetchurl
+, transmission
+, deluge
+, config
+}:
+
+with pythonPackages;
+
+buildPythonPackage rec {
+  version = "1.2.337";
+  name = "FlexGet-${version}";
+  disabled = isPy3k;
+
+  src = fetchurl {
+    url = "mirror://pypi/F/FlexGet/${name}.tar.gz";
+    sha256 = "0f7aaf0bf37860f0c5adfb0ba59ca228aa3f5c582131445623a4c3bc82d45346";
+  };
+
+  doCheck = false;
+
+  buildInputs = [ nose ];
+  propagatedBuildInputs = [
+    paver feedparser sqlalchemy pyyaml rpyc
+    beautifulsoup_4_1_3 html5lib_0_9999999 pyrss2gen pynzb progressbar jinja2 flask
+    cherrypy requests dateutil_2_1 jsonschema python_tvrage tmdb3
+    guessit pathpy apscheduler ]
+  # enable deluge and transmission plugin support, if they're installed
+  ++ lib.optional (config.deluge or false) deluge
+  ++ lib.optional (transmission != null) transmissionrpc;
+
+  meta = {
+    homepage = http://flexget.com/;
+    description = "Multipurpose automation tool for content like torrents";
+    license = lib.licenses.mit;
+    maintainers = with lib.maintainers; [ domenkozar ];
+  };
+}
\ No newline at end of file
diff --git a/pkgs/applications/networking/mailreaders/astroid/default.nix b/pkgs/applications/networking/mailreaders/astroid/default.nix
new file mode 100644
index 000000000000..31cad15296cf
--- /dev/null
+++ b/pkgs/applications/networking/mailreaders/astroid/default.nix
@@ -0,0 +1,36 @@
+{ stdenv, fetchFromGitHub, scons, pkgconfig, gnome3, gmime, webkitgtk24x
+  , libsass, notmuch, boost, makeWrapper }:
+
+stdenv.mkDerivation rec {
+  name = "astroid-${version}";
+  version = "0.6";
+
+  src = fetchFromGitHub {
+    owner = "astroidmail";
+    repo = "astroid";
+    rev = "v${version}";
+    sha256 = "0zashjmqv8ips9q8ckyhgm9hfyf01wpgs6g21cwl05q5iklc5x7r";
+  };
+
+  patches = [ ./propagate-environment.patch ];
+
+  buildInputs = [ scons pkgconfig gnome3.gtkmm gmime webkitgtk24x libsass
+                  gnome3.libpeas notmuch boost gnome3.gsettings_desktop_schemas
+                  makeWrapper ];
+
+  buildPhase = "scons --prefix=$out build";
+  installPhase = "scons --prefix=$out install";
+
+  preFixup = ''
+    wrapProgram "$out/bin/astroid" \
+      --prefix XDG_DATA_DIRS : "$GSETTINGS_SCHEMAS_PATH"
+  '';
+
+  meta = {
+    homepage = "https://astroidmail.github.io/";
+    description = "GTK+ frontend to the notmuch mail system";
+    maintainers = [ stdenv.lib.maintainers.bdimcheff ];
+    license = stdenv.lib.licenses.gpl3Plus;
+    platforms = stdenv.lib.platforms.linux;
+  };
+}
diff --git a/pkgs/applications/networking/mailreaders/astroid/propagate-environment.patch b/pkgs/applications/networking/mailreaders/astroid/propagate-environment.patch
new file mode 100644
index 000000000000..db536ea721f2
--- /dev/null
+++ b/pkgs/applications/networking/mailreaders/astroid/propagate-environment.patch
@@ -0,0 +1,13 @@
+diff --git a/SConstruct b/SConstruct
+index a80bca3..ed2cd6d 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -5,7 +5,7 @@ from subprocess import *
+ def getGitDesc():
+   return Popen('git describe --abbrev=8 --tags --always', stdout=PIPE, shell=True).stdout.read ().strip ()
+ 
+-env = Environment ()
++env = Environment(ENV = os.environ)
+ 
+ AddOption ("--release", action="store", dest="release", default="git", help="Make a release (default: git describe output)")
+ AddOption ("--enable-debug", action="store", dest="debug", default=None, help="Enable the -g flag for debugging (default: true when release is git)")
diff --git a/pkgs/applications/networking/mailreaders/neomutt/default.nix b/pkgs/applications/networking/mailreaders/neomutt/default.nix
index 2033dfc8e913..57f633d2c990 100644
--- a/pkgs/applications/networking/mailreaders/neomutt/default.nix
+++ b/pkgs/applications/networking/mailreaders/neomutt/default.nix
@@ -1,20 +1,20 @@
 { stdenv, fetchFromGitHub, which, autoconf, automake, ncurses, perl
-, cyrus_sasl, gdbm, gpgme, kerberos, libidn, notmuch, openssl }:
+, cyrus_sasl, gdbm, gpgme, kerberos, libidn, notmuch, openssl, lmdb }:
 
 stdenv.mkDerivation rec {
-  version = "20161104";
+  version = "20161126";
   name = "neomutt-${version}";
 
   src = fetchFromGitHub {
     owner = "neomutt";
     repo = "neomutt";
     rev = "neomutt-${version}";
-    sha256 = "070p18khvxsrcn30jhyrnagka5mgza9mi5vmrrr6xl8mpgkyrlaw";
+    sha256 = "10ycfya11pvwv0rdyyak56r6f8ia8yf0h8qyi904bbpvm8lqvqfd";
   };
 
   buildInputs =
     [ autoconf automake cyrus_sasl gdbm gpgme kerberos libidn ncurses
-      notmuch which openssl perl ];
+      notmuch which openssl perl lmdb ];
 
   configureFlags = [
     "--enable-debug"
@@ -36,6 +36,7 @@ stdenv.mkDerivation rec {
     "--with-curses"
     "--with-regex"
     "--with-idn"
+    "--with-lmdb"
 
     # Look in $PATH at runtime, instead of hardcoding /usr/bin/sendmail
     "ac_cv_path_SENDMAIL=sendmail"
diff --git a/pkgs/applications/office/ppl-address-book/Gemfile b/pkgs/applications/office/ppl-address-book/Gemfile
new file mode 100644
index 000000000000..0039c4366963
--- /dev/null
+++ b/pkgs/applications/office/ppl-address-book/Gemfile
@@ -0,0 +1,2 @@
+source 'https://rubygems.org'
+gem 'ppl'
diff --git a/pkgs/applications/office/ppl-address-book/Gemfile.lock b/pkgs/applications/office/ppl-address-book/Gemfile.lock
new file mode 100644
index 000000000000..5054bb8b9c8b
--- /dev/null
+++ b/pkgs/applications/office/ppl-address-book/Gemfile.lock
@@ -0,0 +1,34 @@
+GEM
+  remote: https://rubygems.org/
+  specs:
+    colored (1.2)
+    greencard (0.0.5)
+    i18n (0.7.0)
+    inifile (2.0.2)
+    mail (2.5.3)
+      i18n (>= 0.4.0)
+      mime-types (~> 1.16)
+      treetop (~> 1.4.8)
+    mime-types (1.25.1)
+    morphine (0.1.1)
+    polyglot (0.3.5)
+    ppl (2.4.0)
+      colored (= 1.2)
+      greencard (= 0.0.5)
+      inifile (= 2.0.2)
+      mail (= 2.5.3)
+      morphine (= 0.1.1)
+      rugged (= 0.17.0.b6)
+    rugged (0.17.0.b6)
+    treetop (1.4.15)
+      polyglot
+      polyglot (>= 0.3.1)
+
+PLATFORMS
+  ruby
+
+DEPENDENCIES
+  ppl
+
+BUNDLED WITH
+   1.12.5
diff --git a/pkgs/applications/office/ppl-address-book/default.nix b/pkgs/applications/office/ppl-address-book/default.nix
new file mode 100644
index 000000000000..1c48fc50842d
--- /dev/null
+++ b/pkgs/applications/office/ppl-address-book/default.nix
@@ -0,0 +1,38 @@
+{ stdenv, lib, bundlerEnv, ruby, makeWrapper, which }:
+
+let
+  pname = "ppl-address-book";
+
+  version = (import ./gemset.nix).ppl.version;
+
+  env = bundlerEnv rec {
+    name = "${pname}-env-${version}";
+    inherit ruby;
+    gemfile = ./Gemfile;
+    lockfile = ./Gemfile.lock;
+    gemset = ./gemset.nix;
+
+    gemConfig.rugged = attrs: { buildInputs = [ which ]; };
+  };
+
+in stdenv.mkDerivation {
+  name = "${pname}-${version}";
+
+  phases = [ "installPhase" ];
+
+  buildInputs = [ env makeWrapper ];
+
+  installPhase = ''
+    mkdir -p $out/bin
+    makeWrapper ${env}/bin/ppl $out/bin/ppl
+  '';
+
+  meta = with lib; {
+    description = "Address book software for command-line users";
+    homepage    = http://ppladdressbook.org/;
+    license     = with licenses; mit;
+    maintainers = with maintainers; [ chris-martin ];
+    platforms   = platforms.unix;
+  };
+
+}
diff --git a/pkgs/applications/office/ppl-address-book/gemset.nix b/pkgs/applications/office/ppl-address-book/gemset.nix
new file mode 100644
index 000000000000..e8229f6153fd
--- /dev/null
+++ b/pkgs/applications/office/ppl-address-book/gemset.nix
@@ -0,0 +1,90 @@
+{
+  colored = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "0b0x5jmsyi0z69bm6sij1k89z7h0laag3cb4mdn7zkl9qmxb90lx";
+      type = "gem";
+    };
+    version = "1.2";
+  };
+  greencard = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "11pxrl1w8c7m7rmnnmdaplrv53qgylyvkv8bzsfyjna7k16hynvq";
+      type = "gem";
+    };
+    version = "0.0.5";
+  };
+  i18n = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "1i5z1ykl8zhszsxcs8mzl8d0dxgs3ylz8qlzrw74jb0gplkx6758";
+      type = "gem";
+    };
+    version = "0.7.0";
+  };
+  inifile = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "03rpacxnrnisjhd2zhc7629ica958bkdbakicl5kipw1wbprck25";
+      type = "gem";
+    };
+    version = "2.0.2";
+  };
+  mail = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "1afr3acz7vsvr4gp6wnrkw1iwbjhf14mh8g8mlm40r86wcwzr39k";
+      type = "gem";
+    };
+    version = "2.5.3";
+  };
+  mime-types = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "0mhzsanmnzdshaba7gmsjwnv168r1yj8y0flzw88frw1cickrvw8";
+      type = "gem";
+    };
+    version = "1.25.1";
+  };
+  morphine = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "05aw93cijd1gq39ikw2dw3i2c79bjq05kvxrs81mqxqdlini5wwa";
+      type = "gem";
+    };
+    version = "0.1.1";
+  };
+  polyglot = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "1bqnxwyip623d8pr29rg6m8r0hdg08fpr2yb74f46rn1wgsnxmjr";
+      type = "gem";
+    };
+    version = "0.3.5";
+  };
+  ppl = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "0vpp4s12ggbk5kpl9z1i7vi9vvghgxrc8my35yk8knckg5waxg47";
+      type = "gem";
+    };
+    version = "2.4.0";
+  };
+  rugged = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "025rj3rkj5yxf4pjj1s8x4yzshlyni3hgrjwhggg54nvw6b688qi";
+      type = "gem";
+    };
+    version = "0.17.0.b6";
+  };
+  treetop = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "1zqj5y0mvfvyz11nhsb4d5ch0i0rfcyj64qx19mw4qhg3hh8z9pz";
+      type = "gem";
+    };
+    version = "1.4.15";
+  };
+}
\ No newline at end of file
diff --git a/pkgs/applications/science/logic/lean/default.nix b/pkgs/applications/science/logic/lean/default.nix
index d1f4bc0a4145..af338338550f 100644
--- a/pkgs/applications/science/logic/lean/default.nix
+++ b/pkgs/applications/science/logic/lean/default.nix
@@ -2,13 +2,13 @@
 
 stdenv.mkDerivation rec {
   name = "lean-${version}";
-  version = "2016-12-08";
+  version = "2016-12-30";
 
   src = fetchFromGitHub {
     owner  = "leanprover";
     repo   = "lean";
-    rev    = "7b63d6566faaf1dc0f2c8e873c61f51dce9ab618";
-    sha256 = "0xxr7dnh7pmdbpxhl3cq9clwamxjk54zcxplsrz6xirk0qy7ga4l";
+    rev    = "fd4fffea27c442b12a45f664a8680ebb47482ca3";
+    sha256 = "1izbjxbr1nvv5kv2b7qklqjx2b1qmwrxhmvk0f2lrl9pxz9h0bmd";
   };
 
   buildInputs = [ gmp mpfr cmake gperftools ];
diff --git a/pkgs/applications/science/misc/fityk/default.nix b/pkgs/applications/science/misc/fityk/default.nix
index 7d9f8542eed3..1c1cac203f8b 100644
--- a/pkgs/applications/science/misc/fityk/default.nix
+++ b/pkgs/applications/science/misc/fityk/default.nix
@@ -3,7 +3,7 @@
 
 let
   name    = "fityk";
-  version = "1.3.0";
+  version = "1.3.1";
 in
 stdenv.mkDerivation {
   name = "${name}-${version}";
@@ -12,7 +12,7 @@ stdenv.mkDerivation {
     owner = "wojdyr";
     repo = "fityk";
     rev = "v${version}";
-    sha256 = "07xzhy47q5ddg1qn51qds4wp6r5g2cx8bla0hm0a9ipr2hg92lm9";
+    sha256 = "0kmrjjjwrh6xgw590awcd52b86kksmv6rfgih75zvpiavr1ygwsi";
   };
 
   buildInputs = [ autoreconfHook wxGTK30 boost lua zlib bzip2 xylib readline
diff --git a/pkgs/applications/science/physics/sherpa/default.nix b/pkgs/applications/science/physics/sherpa/default.nix
new file mode 100644
index 000000000000..d863964ad90a
--- /dev/null
+++ b/pkgs/applications/science/physics/sherpa/default.nix
@@ -0,0 +1,23 @@
+{ stdenv, fetchurl, gfortran, sqlite }:
+
+stdenv.mkDerivation rec {
+  name = "sherpa-${version}";
+  version = "2.2.1";
+
+  src = fetchurl {
+    url = "http://www.hepforge.org/archive/sherpa/SHERPA-MC-${version}.tar.gz";
+    sha256 = "13vkz6w8kqyv8sgy3mxnlps5ykml5rnlj50vjj0pp9rgbl5y8ali";
+  };
+
+  buildInputs = [ gfortran sqlite ];
+
+  enableParallelBuilding = true;
+
+  meta = {
+    description = "Simulation of High-Energy Reactions of PArticles in lepton-lepton, lepton-photon, photon-photon, lepton-hadron and hadron-hadron collisions";
+    license     = stdenv.lib.licenses.gpl2;
+    homepage    = https://sherpa.hepforge.org;
+    platforms   = stdenv.lib.platforms.unix;
+    maintainers = with stdenv.lib.maintainers; [ veprbl ];
+  };
+}
diff --git a/pkgs/applications/version-management/cvsps/01_ignoretrunk.dpatch b/pkgs/applications/version-management/cvsps/01_ignoretrunk.dpatch
deleted file mode 100644
index 39185ae2bfa6..000000000000
--- a/pkgs/applications/version-management/cvsps/01_ignoretrunk.dpatch
+++ /dev/null
@@ -1,23 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 01_ignoretrunk.dpatch by  <crafterm@debian.org>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Ignore TRUNK branch name patch
-
-@DPATCH@
-
-diff -urN cvsps-2.1.orig/cvsps.c cvsps-2.1/cvsps.c
---- cvsps-2.1.orig/cvsps.c	2005-05-25 22:39:40.000000000 -0500
-+++ cvsps-2.1/cvsps.c	2005-06-19 23:07:20.000000000 -0500
-@@ -2104,6 +2109,11 @@
-     
-     if (!get_branch_ext(rev, eot, &leaf))
-     {
-+	if (strcmp(tag, "TRUNK") == 0)
-+	{
-+	    debug(DEBUG_STATUS, "ignoring the TRUNK branch/tag");
-+	    return;
-+	}
- 	debug(DEBUG_APPERROR, "malformed revision");
- 	exit(1);
-     }
diff --git a/pkgs/applications/version-management/cvsps/02_dynamicbufferalloc.dpatch b/pkgs/applications/version-management/cvsps/02_dynamicbufferalloc.dpatch
deleted file mode 100644
index 70ffb02a21aa..000000000000
--- a/pkgs/applications/version-management/cvsps/02_dynamicbufferalloc.dpatch
+++ /dev/null
@@ -1,125 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 02_dynamicbufferalloc.dpatch by  <crafterm@debian.org>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Dynamic buffer allocation
-
-@DPATCH@
-
-diff -urN cvsps-2.1-orig/cache.c cvsps-2.1/cache.c
---- cvsps-2.1-orig/cache.c	2005-05-25 22:39:40.000000000 -0500
-+++ cvsps-2.1/cache.c	2005-07-26 15:21:29.716569500 -0500
-@@ -108,10 +108,19 @@
-     int tag_flags = 0;
-     char branchbuff[LOG_STR_MAX] = "";
-     int branch_add = 0;
--    char logbuff[LOG_STR_MAX] = "";
-+    int logbufflen = LOG_STR_MAX + 1;
-+    char * logbuff = malloc(logbufflen);
-     time_t cache_date = -1;
-     int read_version;
- 
-+    if (logbuff == NULL)
-+    {
-+	debug(DEBUG_SYSERROR, "could not malloc %d bytes for logbuff in read_cache", logbufflen);
-+	exit(1);
-+    }
-+
-+    logbuff[0] = 0;
-+
-     if (!(fp = cache_open("r")))
- 	goto out;
- 
-@@ -299,8 +308,19 @@
- 	    else
- 	    {
- 		/* Make sure we have enough in the buffer */
--		if (strlen(logbuff)+strlen(buff)<LOG_STR_MAX)
--		    strcat(logbuff, buff);
-+		int len = strlen(buff);
-+		if (strlen(logbuff) + len >= LOG_STR_MAX)
-+		{
-+		    logbufflen += (len >= LOG_STR_MAX ? (len+1) : LOG_STR_MAX);
-+		    char * newlogbuff = realloc(logbuff, logbufflen);
-+		    if (newlogbuff == NULL)
-+		    {
-+			debug(DEBUG_SYSERROR, "could not realloc %d bytes for logbuff in read_cache", logbufflen);
-+			exit(1);
-+		    }
-+		    logbuff = newlogbuff;
-+		}
-+		strcat(logbuff, buff);
- 	    }
- 	    break;
- 	case CACHE_NEED_PS_MEMBERS:
-@@ -332,6 +352,7 @@
-  out_close:
-     fclose(fp);
-  out:
-+    free(logbuff);
-     return cache_date;
- }
- 
-diff -urN cvsps-2.1-orig/cvsps.c cvsps-2.1/cvsps.c
---- cvsps-2.1-orig/cvsps.c	2005-05-25 22:39:40.000000000 -0500
-+++ cvsps-2.1/cvsps.c	2005-07-26 15:22:02.558230700 -0500
-@@ -265,7 +265,8 @@
-     PatchSetMember * psm = NULL;
-     char datebuff[20];
-     char authbuff[AUTH_STR_MAX];
--    char logbuff[LOG_STR_MAX + 1];
-+    int logbufflen = LOG_STR_MAX + 1;
-+    char * logbuff = malloc(logbufflen);
-     int loglen = 0;
-     int have_log = 0;
-     char cmd[BUFSIZ];
-@@ -273,6 +274,12 @@
-     char use_rep_buff[PATH_MAX];
-     char * ltype;
- 
-+    if (logbuff == NULL)
-+    {
-+	debug(DEBUG_SYSERROR, "could not malloc %d bytes for logbuff in load_from_cvs", logbufflen);
-+	exit(1);
-+    }
-+
-     if (!no_rlog && !test_log_file && cvs_check_cap(CAP_HAVE_RLOG))
-     {
- 	ltype = "rlog";
-@@ -480,24 +487,22 @@
- 		 */
- 		if (have_log || !is_revision_metadata(buff))
- 		{
--		    /* if the log buffer is full, that's it.  
--		     * 
--		     * Also, read lines (fgets) always have \n in them
--		     * which we count on.  So if truncation happens,
--		     * be careful to put a \n on.
--		     * 
--		     * Buffer has LOG_STR_MAX + 1 for room for \0 if
--		     * necessary
--		     */
--		    if (loglen < LOG_STR_MAX)
-+		    /* If the log buffer is full, try to reallocate more. */
-+		    if (loglen < logbufflen)
- 		    {
- 			int len = strlen(buff);
- 			
--			if (len >= LOG_STR_MAX - loglen)
-+			if (len >= logbufflen - loglen)
- 			{
--			    debug(DEBUG_APPMSG1, "WARNING: maximum log length exceeded, truncating log");
--			    len = LOG_STR_MAX - loglen;
--			    buff[len - 1] = '\n';
-+			    debug(DEBUG_STATUS, "reallocating logbufflen to %d bytes for file %s", logbufflen, file->filename);
-+			    logbufflen += (len >= LOG_STR_MAX ? (len+1) : LOG_STR_MAX);
-+			    char * newlogbuff = realloc(logbuff, logbufflen);
-+			    if (newlogbuff == NULL)
-+			    {
-+				debug(DEBUG_SYSERROR, "could not realloc %d bytes for logbuff in load_from_cvs", logbufflen);
-+				exit(1);
-+			    }
-+			    logbuff = newlogbuff;
- 			}
- 
- 			debug(DEBUG_STATUS, "appending %s to log", buff);
diff --git a/pkgs/applications/version-management/cvsps/03_diffoptstypo.dpatch b/pkgs/applications/version-management/cvsps/03_diffoptstypo.dpatch
deleted file mode 100644
index eb3818ed97e9..000000000000
--- a/pkgs/applications/version-management/cvsps/03_diffoptstypo.dpatch
+++ /dev/null
@@ -1,19 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 03_diffoptstypo.dpatch by  <crafterm@debian.org>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Diff opts typo fix
-
-@DPATCH@
-
---- cvsps-2.1-orig/cvsps.1	2005-05-26 05:39:40.000000000 +0200
-+++ cvsps-2.1/cvsps.1	2005-07-28 15:17:48.885112048 +0200
-@@ -83,7 +83,7 @@
- disable the use of rlog internally.  Note: rlog is
- required for stable PatchSet numbering.  Use with care.
- .TP
--.B \-\-diffs\-opts <option string>
-+.B \-\-diff\-opts <option string>
- send a custom set of options to diff, for example to increase
- the number of context lines, or change the diff format.
- .TP
diff --git a/pkgs/applications/version-management/cvsps/default.nix b/pkgs/applications/version-management/cvsps/default.nix
index 9bc4401e0681..aa3bcb273949 100644
--- a/pkgs/applications/version-management/cvsps/default.nix
+++ b/pkgs/applications/version-management/cvsps/default.nix
@@ -1,22 +1,53 @@
-{ fetchurl, stdenv, cvs, zlib }:
+{ stdenv, fetchurl, fetchpatch, cvs, zlib }:
 
 stdenv.mkDerivation rec {
-  name = "cvsps-2.1";
+  name = "cvsps-${version}";
+  version = "2.1";
+
   src = fetchurl {
-    url = "http://www.cobite.com/cvsps/${name}.tar.gz";
+    url = "mirror://debian/pool/main/c/cvsps/cvsps_${version}.orig.tar.gz";
     sha256 = "0nh7q7zcmagx0i63h6fqqkkq9i55k77myvb8h6jn2f266f5iklwi";
   };
 
-  # Patches from Debian's `cvsps-2.1-4'.
-  patches = [ ./01_ignoretrunk.dpatch
-              ./02_dynamicbufferalloc.dpatch
-	      ./03_diffoptstypo.dpatch ];
+  # Patches from https://sources.debian.net/src/cvsps/2.1-7/debian/patches
+  patches =
+    [ (fetchpatch {
+        url = "https://sources.debian.net/data/main/c/cvsps/2.1-7/debian/patches/01_ignoretrunk.patch";
+        sha256 = "1gzb97dw2a6bm0bmim7p7wvsn0r82y3a8n22ln6rbbkkd8vlnzcb";
+      })
+
+      (fetchpatch {
+        url = "https://sources.debian.net/data/main/c/cvsps/2.1-7/debian/patches/02_dynamicbufferalloc.patch";
+        sha256 = "0dm7azxnw0g9pdqkb3y4y2h047zgrclbh40av6c868wfp2j6l9sc";
+      })
+
+      (fetchpatch {
+        url = "https://sources.debian.net/data/main/c/cvsps/2.1-7/debian/patches/03_diffoptstypo.patch";
+        sha256 = "06n8652g7inpv8cgqir7ijq00qw1fr0v44m2pbmgx7ilmna2vrcw";
+      })
+
+      (fetchpatch {
+        url = "https://sources.debian.net/data/main/c/cvsps/2.1-7/debian/patches/05-inet_addr_fix.patch";
+        sha256 = "10w6px96dz8bb69asjzshvp787ccazmqnjsggqc4gwdal95q3cn7";
+      })
+
+      (fetchpatch {
+        url = "https://sources.debian.net/data/main/c/cvsps/2.1-7/debian/patches/fix-makefile";
+        sha256 = "0m92b55hgldwg6lwdaybbj0n3lw1b3wj2xkk1cz1ywq073bpf3jm";
+      })
+
+      (fetchpatch {
+        url = "https://sources.debian.net/data/main/c/cvsps/2.1-7/debian/patches/fix-manpage";
+        sha256 = "0gky14rhx82wv0gj8bkc74ki5xilhv5i3k1jc7khklr4lb6mmhpx";
+      })
+    ];
 
   buildInputs = [ cvs zlib ];
 
-  installPhase = "make install prefix=$out";
+  installFlags = [ "prefix=$(out)" ];
 
   meta = {
+    description = ''A tool to generate CVS patch set information'';
     longDescription = ''
       CVSps is a program for generating `patchset' information from a
       CVS repository.  A patchset in this case is defined as a set of
@@ -25,5 +56,6 @@ stdenv.mkDerivation rec {
     '';
     homepage = http://www.cobite.com/cvsps/;
     license = stdenv.lib.licenses.gpl2;
+    platforms = stdenv.lib.platforms.unix;
   };
 }
diff --git a/pkgs/applications/version-management/git-and-tools/transcrypt/default.nix b/pkgs/applications/version-management/git-and-tools/transcrypt/default.nix
index 3047ca023423..44a00238a5c1 100644
--- a/pkgs/applications/version-management/git-and-tools/transcrypt/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/transcrypt/default.nix
@@ -2,13 +2,13 @@
 
 stdenv.mkDerivation rec {
   name = "transcrypt-${version}";
-  version = "0.9.9";
+  version = "1.0.0";
 
   src = fetchFromGitHub {
     owner = "elasticdog";
     repo = "transcrypt";
     rev = "v${version}";
-    sha256 = "0brsgj3qmvkgxzqqamk8krwyarwff1dlb3jjd09snnbfl0kdq1a5";
+    sha256 = "195hi8lq1i9rfcwj3raw4pa7fhvv3ghznxp4crmbjm7c0sqilcpd";
   };
 
   buildInputs = [ git makeWrapper openssl ];
diff --git a/pkgs/applications/version-management/pijul/default.nix b/pkgs/applications/version-management/pijul/default.nix
index 4f1f28a7aac7..04a91a6b4a44 100644
--- a/pkgs/applications/version-management/pijul/default.nix
+++ b/pkgs/applications/version-management/pijul/default.nix
@@ -33,5 +33,6 @@ buildRustPackage rec {
     license = licenses.gpl3;
     platforms = stdenv.lib.platforms.x86_64;  # i686 builds fail due to lmdb
     maintainers = with maintainers; [ puffnfresh ];
+    broken = true;
   };
 }