about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2016-05-02 11:35:09 +0200
committerRobin Gloster <mail@glob.in>2016-05-02 11:35:09 +0200
commit5a2b26cf7b4de3c8a2c86e5230eb9423e4a3dfaa (patch)
treee80f5a5639c8785c4a8b2d71617807da1ef85b1b /pkgs/applications
parent3829bcf8663b540d5e5ae69e04b196d291dc091b (diff)
parent05f2ebe16d6fdbd159d6b25a8d0dfb30135638e1 (diff)
downloadnixlib-5a2b26cf7b4de3c8a2c86e5230eb9423e4a3dfaa.tar
nixlib-5a2b26cf7b4de3c8a2c86e5230eb9423e4a3dfaa.tar.gz
nixlib-5a2b26cf7b4de3c8a2c86e5230eb9423e4a3dfaa.tar.bz2
nixlib-5a2b26cf7b4de3c8a2c86e5230eb9423e4a3dfaa.tar.lz
nixlib-5a2b26cf7b4de3c8a2c86e5230eb9423e4a3dfaa.tar.xz
nixlib-5a2b26cf7b4de3c8a2c86e5230eb9423e4a3dfaa.tar.zst
nixlib-5a2b26cf7b4de3c8a2c86e5230eb9423e4a3dfaa.zip
Merge pull request #15056 from simonvandel/fix-qbittorent-qmake
Fix qbittorent qmake build error
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/p2p/qbittorrent/default.nix14
1 files changed, 10 insertions, 4 deletions
diff --git a/pkgs/applications/networking/p2p/qbittorrent/default.nix b/pkgs/applications/networking/p2p/qbittorrent/default.nix
index 31931aa75d92..ee03bfeedb09 100644
--- a/pkgs/applications/networking/p2p/qbittorrent/default.nix
+++ b/pkgs/applications/networking/p2p/qbittorrent/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchurl, pkgconfig, which
-, boost, libtorrentRasterbar, qt5
+, boost, libtorrentRasterbar, qmakeHook, qt5
 , debugSupport ? false # Debugging
 , guiSupport ? true, dbus_libs ? null # GUI (disable to run headless)
 , webuiSupport ? true # WebUI
@@ -10,18 +10,24 @@ assert guiSupport -> (dbus_libs != null);
 with stdenv.lib;
 stdenv.mkDerivation rec {
   name = "qbittorrent-${version}";
-  version = "3.3.3";
+  version = "3.3.4";
 
   src = fetchurl {
     url = "mirror://sourceforge/qbittorrent/${name}.tar.xz";
-    sha256 = "0lyv230vqwb77isjqm6fwwgv8hdap88zir9yrccj0qxj7zf8p3cw";
+    sha256 = "1f4impsjck8anl39pwypsck7j6xw0dl18qd0b4xi23r45jvx9l60";
   };
 
-  nativeBuildInputs = [ pkgconfig which ];
+  nativeBuildInputs = [ pkgconfig which qmakeHook ];
 
   buildInputs = [ boost libtorrentRasterbar qt5.qtbase qt5.qttools ]
     ++ optional guiSupport dbus_libs;
 
+  dontUseQmakeConfigure = true;
+
+  preConfigure = ''
+    export QT_QMAKE="$qtOut/bin"
+  '';
+
   configureFlags = [
     "--with-boost-libdir=${boost.lib}/lib"
     "--with-boost=${boost.dev}"