about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMatías Lang <matiasl@infobytesec.com>2020-05-29 02:56:21 -0300
committerMatías Lang <matiasl@infobytesec.com>2020-06-06 14:46:15 -0300
commit5930a0ea449514cff02563326f95a1947db85d00 (patch)
tree9fcfb81daedc15d6e4db08c0ff6776e294ccf70b /pkgs/applications
parent164985ab68e3a10b75c58dd00bd325f8f219025d (diff)
downloadnixlib-5930a0ea449514cff02563326f95a1947db85d00.tar
nixlib-5930a0ea449514cff02563326f95a1947db85d00.tar.gz
nixlib-5930a0ea449514cff02563326f95a1947db85d00.tar.bz2
nixlib-5930a0ea449514cff02563326f95a1947db85d00.tar.lz
nixlib-5930a0ea449514cff02563326f95a1947db85d00.tar.xz
nixlib-5930a0ea449514cff02563326f95a1947db85d00.tar.zst
nixlib-5930a0ea449514cff02563326f95a1947db85d00.zip
mpvScripts.simple-mpv-webui: init at 1.0.0
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/video/mpv/default.nix3
-rw-r--r--pkgs/applications/video/mpv/scripts/simple-mpv-webui.nix33
2 files changed, 36 insertions, 0 deletions
diff --git a/pkgs/applications/video/mpv/default.nix b/pkgs/applications/video/mpv/default.nix
index ff837756e3db..51d284f277a1 100644
--- a/pkgs/applications/video/mpv/default.nix
+++ b/pkgs/applications/video/mpv/default.nix
@@ -39,6 +39,9 @@
 , libpngSupport      ? true,           libpng        ? null
 , pulseSupport       ? config.pulseaudio or stdenv.isLinux, libpulseaudio ? null
 , rubberbandSupport  ? stdenv.isLinux, rubberband    ? null
+# NOTE: samba support should be removed on the next mpv release, see also:
+# https://github.com/NixOS/nixpkgs/pull/89145#issuecomment-636424362
+# Please remove this line on the next mpv release.
 , sambaSupport       ? false,          samba         ? null
 , screenSaverSupport ? true,           libXScrnSaver ? null
 , sdl2Support        ? true,           SDL2          ? null
diff --git a/pkgs/applications/video/mpv/scripts/simple-mpv-webui.nix b/pkgs/applications/video/mpv/scripts/simple-mpv-webui.nix
new file mode 100644
index 000000000000..d51434e241c9
--- /dev/null
+++ b/pkgs/applications/video/mpv/scripts/simple-mpv-webui.nix
@@ -0,0 +1,33 @@
+{ stdenv
+, fetchFromGitHub }:
+stdenv.mkDerivation rec {
+  pname = "simple-mpv-ui";
+  version = "1.0.0";
+
+  src = fetchFromGitHub {
+    owner = "open-dynaMIX";
+    repo = "simple-mpv-webui";
+    rev = "v${version}";
+    sha256 = "1glrnnl1slcl0ri0zs4j64lc9aa52p9ffh6av0d81fk95nm98917";
+  };
+
+  dontBuild = true;
+  installPhase = ''
+    mkdir -p $out/share/mpv/scripts
+    cp -r webui.lua webui-page $out/share/mpv/scripts/
+  '';
+  passthru.scriptName = "webui.lua";
+
+  meta = with stdenv.lib; {
+    description = "A web based user interface with controls for the mpv mediaplayer";
+    homepage = "https://github.com/open-dynaMIX/simple-mpv-webui";
+    maintainers = [ maintainers.cript0nauta ];
+    longDescription = ''
+      You can access the webui when accessing http://127.0.0.1:8080 or
+      http://[::1]:8080 in your webbrowser. By default it listens on
+      0.0.0.0:8080 and [::0]:8080
+    '';
+    license = licenses.mit;
+  };
+}
+