about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2021-02-12 20:17:47 +0000
committerGitHub <noreply@github.com>2021-02-12 20:17:47 +0000
commit5852a21819542e6809f68ba5a798600e69874e76 (patch)
tree119c77d4fadc0bfbc29e90f51446c8b8bacb04c4 /pkgs/applications
parentecf06378f7caba04a1018509d04e23cfbd5635ff (diff)
parent3270eec8f0e24afc1a38cbca46a26ac4e8d2e8b6 (diff)
downloadnixlib-5852a21819542e6809f68ba5a798600e69874e76.tar
nixlib-5852a21819542e6809f68ba5a798600e69874e76.tar.gz
nixlib-5852a21819542e6809f68ba5a798600e69874e76.tar.bz2
nixlib-5852a21819542e6809f68ba5a798600e69874e76.tar.lz
nixlib-5852a21819542e6809f68ba5a798600e69874e76.tar.xz
nixlib-5852a21819542e6809f68ba5a798600e69874e76.tar.zst
nixlib-5852a21819542e6809f68ba5a798600e69874e76.zip
Merge pull request #112755 from 06kellyjac/tektoncd-cli
tektoncd-cli: cleanup
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/cluster/tektoncd-cli/default.nix29
1 files changed, 18 insertions, 11 deletions
diff --git a/pkgs/applications/networking/cluster/tektoncd-cli/default.nix b/pkgs/applications/networking/cluster/tektoncd-cli/default.nix
index 0f28225ad012..581af59f0c8f 100644
--- a/pkgs/applications/networking/cluster/tektoncd-cli/default.nix
+++ b/pkgs/applications/networking/cluster/tektoncd-cli/default.nix
@@ -13,19 +13,26 @@ buildGoModule rec {
 
   vendorSha256 = null;
 
-  doCheck = false;
+  buildFlagsArray = [
+    "-ldflags="
+    "-s"
+    "-w"
+    "-X github.com/tektoncd/cli/pkg/cmd/version.clientVersion=${version}"
+  ];
 
   nativeBuildInputs = [ installShellFiles ];
 
-  buildPhase = ''
-    make bin/tkn
-  '';
+  # third_party/VENDOR-LICENSE breaks build/check as go files are still included
+  # docs is a tool for generating docs
+  excludedPackages = "\\(third_party\\|cmd/docs\\)";
 
-  installPhase = ''
-    install bin/tkn -Dt $out/bin
+  preCheck = ''
+    # Change the golden files to match our desired version
+    sed -i "s/dev/${version}/" pkg/cmd/version/testdata/TestGetVersions-*.golden
+  '';
 
-    mkdir -p "$out/share/man/man1"
-    cp docs/man/man1/* "$out/share/man/man1"
+  postInstall = ''
+    installManPage docs/man/man1/*
 
     installShellCompletion --cmd tkn \
       --bash <($out/bin/tkn completion bash) \
@@ -34,14 +41,14 @@ buildGoModule rec {
   '';
 
   meta = with lib; {
-    description = "The Tekton Pipelines cli project provides a CLI for interacting with Tekton";
     homepage = "https://tekton.dev";
+    changelog = "https://github.com/tektoncd/cli/releases/tag/v${version}";
+    description = "Provides a CLI for interacting with Tekton";
     longDescription = ''
       The Tekton Pipelines cli project provides a CLI for interacting with Tekton!
       For your convenience, it is recommended that you install the Tekton CLI, tkn, together with the core component of Tekton, Tekton Pipelines.
     '';
     license = licenses.asl20;
-    maintainers = with maintainers; [ jk mstrangfeld ];
-    platforms = platforms.linux ++ platforms.darwin;
+    maintainers = with maintainers; [ jk mstrangfeld vdemeester ];
   };
 }