about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorjokogr <ioannis.koutras@gmail.com>2016-07-27 19:49:43 +0300
committerRok Garbas <rok@garbas.si>2016-07-27 18:49:43 +0200
commit54e870e3b1ded6999247a52750ca5142301d5096 (patch)
tree3047764e19848e15965552728b2285e6109efac5 /pkgs/applications
parent251a1ccf55d34aa0da7ecc4ac96f9f741e343ceb (diff)
downloadnixlib-54e870e3b1ded6999247a52750ca5142301d5096.tar
nixlib-54e870e3b1ded6999247a52750ca5142301d5096.tar.gz
nixlib-54e870e3b1ded6999247a52750ca5142301d5096.tar.bz2
nixlib-54e870e3b1ded6999247a52750ca5142301d5096.tar.lz
nixlib-54e870e3b1ded6999247a52750ca5142301d5096.tar.xz
nixlib-54e870e3b1ded6999247a52750ca5142301d5096.tar.zst
nixlib-54e870e3b1ded6999247a52750ca5142301d5096.zip
syncthing: 0.14.0 -> 0.14.2 (#17274)
* Update syncthing from 0.14.0 to 0.14.2
* Use fetchFromGitHub instead of fetchgit
* Add joko to package maintainers
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/syncthing/default.nix15
1 files changed, 8 insertions, 7 deletions
diff --git a/pkgs/applications/networking/syncthing/default.nix b/pkgs/applications/networking/syncthing/default.nix
index 4529cf3bd78a..035bfd406af5 100644
--- a/pkgs/applications/networking/syncthing/default.nix
+++ b/pkgs/applications/networking/syncthing/default.nix
@@ -1,13 +1,14 @@
-{ stdenv, fetchgit, go }:
+{ stdenv, fetchFromGitHub, go }:
 
 stdenv.mkDerivation rec {
-  version = "0.14.0";
+  version = "0.14.2";
   name = "syncthing-${version}";
 
-  src = fetchgit {
-    url = https://github.com/syncthing/syncthing;
-    rev = "refs/tags/v${version}";
-    sha256 = "15l3q3r6i3q95i474winswx4y149b5ic7xhpnj52s78fxd4va2q2";
+  src = fetchFromGitHub {
+    owner = "syncthing";
+    repo = "syncthing";
+    rev = "v${version}";
+    sha256 = "0is4f1r3im2bbmbca9fafzxffikxaf86vd6f851831fk5wi4pzw9";
   };
 
   buildInputs = [ go ];
@@ -32,7 +33,7 @@ stdenv.mkDerivation rec {
     homepage = https://www.syncthing.net/;
     description = "Open Source Continuous File Synchronization";
     license = stdenv.lib.licenses.mpl20;
-    maintainers = with stdenv.lib.maintainers; [pshendry];
+    maintainers = with stdenv.lib.maintainers; [ pshendry joko ];
     platforms = with stdenv.lib.platforms; linux ++ freebsd ++ openbsd ++ netbsd;
   };
 }